aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-01-11 00:19:37 +0800
committerbapt <bapt@FreeBSD.org>2016-01-11 00:19:37 +0800
commitc28300b2e6c0aaa987f2b45724e48962368775fa (patch)
treee9e56b4b803cd544cd8f132d6c3d6bb7f6e9e442
parentfaa87cb5e67c5459b4bd7260bdc640184d487f93 (diff)
downloadfreebsd-ports-gnome-c28300b2e6c0aaa987f2b45724e48962368775fa.tar.gz
freebsd-ports-gnome-c28300b2e6c0aaa987f2b45724e48962368775fa.tar.zst
freebsd-ports-gnome-c28300b2e6c0aaa987f2b45724e48962368775fa.zip
Convert www ports to USES=sqlite and USES=firebird
-rw-r--r--www/bacula-web/Makefile3
-rw-r--r--www/ephemera/Makefile3
-rw-r--r--www/epiphany/Makefile3
-rw-r--r--www/fusionpbx/Makefile2
-rw-r--r--www/midori/Makefile3
-rw-r--r--www/mnogosearch/Makefile15
-rw-r--r--www/mod_tsa/Makefile2
-rw-r--r--www/newsbeuter/Makefile4
-rw-r--r--www/trafficserver/Makefile3
-rw-r--r--www/webkit-gtk2/Makefile3
-rw-r--r--www/webkit-gtk3/Makefile3
-rw-r--r--www/webkit-qt5/Makefile4
-rw-r--r--www/webkit2-gtk3/Makefile3
-rw-r--r--www/xsp/Makefile3
14 files changed, 21 insertions, 33 deletions
diff --git a/www/bacula-web/Makefile b/www/bacula-web/Makefile
index 00294304d461..a24265a00643 100644
--- a/www/bacula-web/Makefile
+++ b/www/bacula-web/Makefile
@@ -29,6 +29,8 @@ SUB_LIST= BASE=${BASE}
OPTIONS_DEFINE= MYSQL PGSQL SQLITE
OPTIONS_DEFAULT= PGSQL
+SQLITE_USES= sqlite
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
@@ -46,7 +48,6 @@ USE_PHP+= pdo_pgsql
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
CONFIGURE_ARGS+= --with-sqlite=yes
SUB_LIST+= REQ_SQLITE=sqlite
USE_PHP+= pdo_sqlite
diff --git a/www/ephemera/Makefile b/www/ephemera/Makefile
index 0b11b07d10ef..c13890c96d94 100644
--- a/www/ephemera/Makefile
+++ b/www/ephemera/Makefile
@@ -11,10 +11,9 @@ COMMENT= Blog server
LICENSE= BSD3CLAUSE
+USES= sqlite
RUN_DEPENDS= munger:${PORTSDIR}/lang/munger
DATADIR= ${PREFIX}/share/ephemera
-USE_SQLITE= 3
-
.include <bsd.port.mk>
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 9c9c0f525d43..cbb7471c65f2 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -29,12 +29,11 @@ RUN_DEPENDS= iso-codes>=0:${PORTSDIR}/misc/iso-codes \
PORTSCOUT= limitw:1,even
USES= cpe desktop-file-utils gettext gmake libtool pathfix \
- pkgconfig python:3 tar:xz
+ pkgconfig python:3 sqlite tar:xz
CPE_VENDOR= gnome
USE_GNOME= gnomedesktop3 intlhack libwnck3 libxml2 libxslt
USE_XORG= ice x11 sm
INSTALLS_ICONS= yes
-USE_SQLITE= 3
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=\
diff --git a/www/fusionpbx/Makefile b/www/fusionpbx/Makefile
index 29fb13c6a4fa..ac086eb1ee11 100644
--- a/www/fusionpbx/Makefile
+++ b/www/fusionpbx/Makefile
@@ -19,10 +19,10 @@ EXPIRATION_DATE= 2016-01-15
LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_odbc
+USES= sqlite
USE_PHP= dom filter ftp json pcre pdo pdo_sqlite posix \
session simplexml xml xmlreader xmlwriter xmlrpc \
xsl zlib odbc
-USE_SQLITE= yes
DEFAULT_VERSIONS+=php=5
diff --git a/www/midori/Makefile b/www/midori/Makefile
index fed9ac0528d7..37ae76da3e2e 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -31,8 +31,7 @@ USE_GNOME= glib20 intltool libxml2
USE_XORG= xscrnsaver
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USES= cmake desktop-file-utils gettext pkgconfig tar:bzip2
-USE_SQLITE= yes
+USES= cmake desktop-file-utils gettext pkgconfig sqlite tar:bzip2
PLIST_SUB= VERSION="${PORTVERSION:R}"
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index 2a6db13d1101..3600da8ffdcf 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -40,6 +40,11 @@ SUB_FILES+= pkg-message
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql=${LOCALBASE}
+SQLITE2_USES= sqlite:2
+SQLITE3_USES= sqlite
+SQLITE2_CONFIGURE_WITH= sqlite=${LOCALBASE}
+SQLITE3_CONFIGURE_WITH= sqlite3=${LOCALBASE}
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
@@ -69,16 +74,6 @@ USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
.endif
-.if ${PORT_OPTIONS:MSQLITE2}
-USE_SQLITE= 2
-CONFIGURE_ARGS+= --with-sqlite=${LOCALBASE}
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE3}
-USE_SQLITE= 3
-CONFIGURE_ARGS+= --with-sqlite3=${LOCALBASE}
-.endif
-
PORTDATA= *
PORTDOCS= ChangeLog INSTALL README.html
PORTEXAMPLES= README *.conf
diff --git a/www/mod_tsa/Makefile b/www/mod_tsa/Makefile
index 14fc78eafd1b..15d507399925 100644
--- a/www/mod_tsa/Makefile
+++ b/www/mod_tsa/Makefile
@@ -51,7 +51,7 @@ AP_LIB+= -lpq
.endif
.if ${PORT_OPTIONS:MFIREBIRD}
-USE_FIREBIRD= yes
+USE+= firebird
CONFIGURE_ARGS+= --enable-firebird=yes
SRC_FILE+= db_firebird.c
AP_LIB+= -lgds
diff --git a/www/newsbeuter/Makefile b/www/newsbeuter/Makefile
index efeafc2d9f0b..f98518c7234c 100644
--- a/www/newsbeuter/Makefile
+++ b/www/newsbeuter/Makefile
@@ -22,11 +22,11 @@ OPTIONS_DEFAULT=PODCAST
OPTIONS_SUB= yes
PODCAST_DESC= Podcast client (podbeuter)
-USES= compiler:c++11-lib gettext gmake iconv:translit ncurses perl5 pkgconfig shebangfix
+USES= compiler:c++11-lib gettext gmake iconv:translit ncurses perl5 \
+ pkgconfig sqlite shebangfix
USE_CXXSTD= gnu++11
USE_PERL5= build
SHEBANG_FILES= txt2h.pl
-USE_SQLITE= yes
USE_GNOME= libxml2
.include <bsd.port.pre.mk>
diff --git a/www/trafficserver/Makefile b/www/trafficserver/Makefile
index b791622831f0..2d07dfb28763 100644
--- a/www/trafficserver/Makefile
+++ b/www/trafficserver/Makefile
@@ -20,14 +20,13 @@ LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= cpe execinfo gmake libtool perl5 pkgconfig tar:bzip2 tcl
+USES= cpe execinfo gmake libtool perl5 pkgconfig tar:bzip2 sqlite tcl
CPE_VENDOR= apache
CPE_PRODUCT= traffic_server
USE_PERL5= build run
USE_LDCONFIG= yes
USE_OPENSSL= yes
USE_RC_SUBR= ${PORTNAME}
-USE_SQLITE= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index 04d4a90d92a4..41c7ee32b1b6 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -28,12 +28,11 @@ PORTSCOUT= limit:1.4.*$$
USE_GSTREAMER1= yes
USE_XORG= xt xdamage xcomposite
USES= bison compiler:c++11-lib gettext gmake gperf libtool \
- perl5 pkgconfig shebangfix tar:xz
+ perl5 pkgconfig shebangfix sqlite tar:xz
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS=yes
USE_GNOME= cairo gtk20 introspection:build libxslt
USE_GL= gl
-USE_SQLITE= 3
USE_PERL5= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/www/webkit-gtk3/Makefile b/www/webkit-gtk3/Makefile
index ad93c387fdd5..f70d7471ee05 100644
--- a/www/webkit-gtk3/Makefile
+++ b/www/webkit-gtk3/Makefile
@@ -28,12 +28,11 @@ PORTSCOUT= limit:1.4.*$$
USE_GSTREAMER1= yes
USE_XORG= xt xdamage xcomposite
USES= bison compiler:c++11-lib gettext gmake gperf libtool perl5 \
- pkgconfig shebangfix tar:xz
+ pkgconfig shebangfix sqlite tar:xz
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS=yes
USE_GNOME= cairo gtk20 gtk30 introspection:build libxslt
USE_GL= gl
-USE_SQLITE= 3
USE_PERL5= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/www/webkit-qt5/Makefile b/www/webkit-qt5/Makefile
index cf492d22c174..ace31bd39870 100644
--- a/www/webkit-qt5/Makefile
+++ b/www/webkit-qt5/Makefile
@@ -23,9 +23,9 @@ USE_QT5= core gui network opengl printsupport qml quick sql \
QT_DIST= ${PORTNAME}
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS= yes
-USE_SQLITE= 3
USE_XORG= x11 xcomposite xrender
-USES= bison gmake gperf jpeg perl5 pkgconfig python:build qmake:outsource
+USES= bison gmake gperf jpeg perl5 pkgconfig python:build qmake:outsource \
+ sqlite
# Use flex(1) from ports.
MAKE_ENV= PATH="${LOCALBASE}/bin:${PATH}"
# "all" builds many more targets. The default one is called "first" in
diff --git a/www/webkit2-gtk3/Makefile b/www/webkit2-gtk3/Makefile
index 769f00056bc8..78a9b2b6ce56 100644
--- a/www/webkit2-gtk3/Makefile
+++ b/www/webkit2-gtk3/Makefile
@@ -28,12 +28,11 @@ PORTSCOUT= limitw:1,even
USE_GSTREAMER1= yes
USE_XORG= x11 xext ice
USES= bison cmake compiler:c++11-lib gettext gmake gperf jpeg perl5 \
- pkgconfig python:2 tar:xz
+ pkgconfig python:2 sqlite tar:xz
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS=yes
USE_GNOME= cairo gtk20 gtk30 introspection:build libxml2 libxslt
USE_GL= gl egl
-USE_SQLITE= 3
USE_PERL5= build
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/www/xsp/Makefile b/www/xsp/Makefile
index 9cc486bb9ed1..f057ac296bfd 100644
--- a/www/xsp/Makefile
+++ b/www/xsp/Makefile
@@ -14,8 +14,7 @@ MAKE_JOBS_UNSAFE= yes
GH_ACCOUNT= mono
USE_GITHUB= yes
-USE_SQLITE= 3
-USES= gmake mono pathfix pkgconfig tar:bzip2
+USES= gmake mono pathfix pkgconfig sqlite tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_GMCS=${LOCALBASE}/bin/mcs
USE_AUTOTOOLS= automake autoconf aclocal