aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-02-22 18:19:19 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-02-22 18:19:19 +0800
commitc3387bc3b1ee97c4fc082edc2be670b4ac9333df (patch)
treef7a3eeec64b07e33c8e696e80a0e2ee5c6b6b311
parentff8d9bd6ab165b4133ac4c6444e1a6bdeff2659f (diff)
downloadfreebsd-ports-gnome-c3387bc3b1ee97c4fc082edc2be670b4ac9333df.tar.gz
freebsd-ports-gnome-c3387bc3b1ee97c4fc082edc2be670b4ac9333df.tar.zst
freebsd-ports-gnome-c3387bc3b1ee97c4fc082edc2be670b4ac9333df.zip
- Fix build with openssl-devel and libressl-devel
- Add LICENSE - Pass maintainership to submitter PR: 216915 Submitted by: pkubaj@anongoth.pl
-rw-r--r--www/links1/Makefile16
-rw-r--r--www/links1/files/patch-connect.c20
-rw-r--r--www/links1/files/patch-default.c6
-rw-r--r--www/links1/files/patch-kbd.c6
-rw-r--r--www/links1/files/patch-types.c8
-rw-r--r--www/links1/pkg-plist2
6 files changed, 39 insertions, 19 deletions
diff --git a/www/links1/Makefile b/www/links1/Makefile
index 33c98731da62..0f2c0b47f9ec 100644
--- a/www/links1/Makefile
+++ b/www/links1/Makefile
@@ -9,9 +9,15 @@ CATEGORIES= www
MASTER_SITES= http://www.jikos.cz/~mikulas/links/download/
PKGNAMESUFFIX= 1
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= pkubaj@anongoth.pl
COMMENT= Lynx-like text WWW browser
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PLIST_FILES= man/man1/links.1.gz \
+ bin/links
+
GNU_CONFIGURE= yes
USES= ssl
@@ -19,10 +25,4 @@ CONFLICTS= links-2*
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
-.include <bsd.port.pre.mk>
-
-.if ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/links1/files/patch-connect.c b/www/links1/files/patch-connect.c
new file mode 100644
index 000000000000..4219cf4f3afc
--- /dev/null
+++ b/www/links1/files/patch-connect.c
@@ -0,0 +1,20 @@
+--- connect.c.orig 2017-02-08 12:41:56 UTC
++++ connect.c
+@@ -106,7 +106,7 @@ void ssl_want_read(struct connection *c)
+
+ set_timeout(c);
+
+- if (c->no_tsl) c->ssl->options |= SSL_OP_NO_TLSv1;
++ if (c->no_tsl) SSL_set_options(c->ssl, SSL_OP_NO_TLSv1);
+ switch (SSL_get_error(c->ssl, SSL_connect(c->ssl))) {
+ case SSL_ERROR_NONE:
+ c->newconn = NULL;
+@@ -186,7 +186,7 @@ void connected(struct connection *c)
+ if (c->ssl) {
+ c->ssl = getSSL();
+ SSL_set_fd(c->ssl, *b->sock);
+- if (c->no_tsl) c->ssl->options |= SSL_OP_NO_TLSv1;
++ if (c->no_tsl) SSL_set_options(c->ssl, SSL_OP_NO_TLSv1);
+ switch (SSL_get_error(c->ssl, SSL_connect(c->ssl))) {
+ case SSL_ERROR_WANT_READ:
+ setcstate(c, S_SSL_NEG);
diff --git a/www/links1/files/patch-default.c b/www/links1/files/patch-default.c
index 5ccd03bad611..e4e7da95f21a 100644
--- a/www/links1/files/patch-default.c
+++ b/www/links1/files/patch-default.c
@@ -1,6 +1,6 @@
---- default.c.orig Sun May 19 20:12:20 2002
-+++ default.c Sun May 19 20:12:23 2002
-@@ -267,7 +267,7 @@
+--- default.c.orig 2011-11-23 00:54:28 UTC
++++ default.c
+@@ -361,7 +361,7 @@ void init_home()
get_system_name();
links_home = get_home(&first_use);
if (!links_home) {
diff --git a/www/links1/files/patch-kbd.c b/www/links1/files/patch-kbd.c
index 6f2f1d8d35d9..e0dc3a5bf132 100644
--- a/www/links1/files/patch-kbd.c
+++ b/www/links1/files/patch-kbd.c
@@ -1,6 +1,6 @@
---- kbd.c.orig 2013-03-12 19:47:22.000000000 +0400
-+++ kbd.c 2013-03-12 19:47:24.000000000 +0400
-@@ -582,10 +582,10 @@
+--- kbd.c.orig 2011-11-22 22:27:53 UTC
++++ kbd.c
+@@ -582,10 +582,10 @@ int process_queue(struct itrm *itrm)
case 'B': ev.x = KBD_DOWN; break;
case 'C': ev.x = KBD_RIGHT; break;
case 'D': ev.x = KBD_LEFT; break;
diff --git a/www/links1/files/patch-types.c b/www/links1/files/patch-types.c
index 59ac9b2731a7..eca6fec740d3 100644
--- a/www/links1/files/patch-types.c
+++ b/www/links1/files/patch-types.c
@@ -1,6 +1,7 @@
---- types.c.orig Fri Apr 26 09:11:15 2002
-+++ types.c Fri Apr 26 09:12:27 2002
-@@ -66,5 +66,6 @@
+--- types.c.orig 2011-11-16 19:19:29 UTC
++++ types.c
+@@ -66,7 +66,8 @@ unsigned char *get_content_type(unsigned
+ if (*ct == '.') ext = ct + 1;
else if (dir_sep(*ct)) ext = NULL;
if (ext) while (ext[extl] && !dir_sep(ext[extl]) && !end_of_dir(ext[extl])) extl++;
- if ((extl == 3 && !casecmp(ext, "htm", 3)) ||
@@ -8,3 +9,4 @@
+ (extl == 3 && !casecmp(ext, "htm", 3)) ||
(extl == 4 && !casecmp(ext, "html", 4))) return stracpy("text/html");
foreach(e, extensions) if (is_in_list(e->ext, ext, extl)) return stracpy(e->ct);
+ exxt = init_str(); el = 0;
diff --git a/www/links1/pkg-plist b/www/links1/pkg-plist
deleted file mode 100644
index b7ef617f46d4..000000000000
--- a/www/links1/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-man/man1/links.1.gz
-bin/links