aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2018-11-24 19:47:52 +0800
committerdbn <dbn@FreeBSD.org>2018-11-24 19:47:52 +0800
commitc3eb2d9dd5df549ac849a5e3a54904c0c01f0e06 (patch)
treef23c709777735f8f3ed1dbb12607155ea643deb7
parentce5e1e62573fa7f88630855ad8e85b63f93cd220 (diff)
downloadfreebsd-ports-gnome-c3eb2d9dd5df549ac849a5e3a54904c0c01f0e06.tar.gz
freebsd-ports-gnome-c3eb2d9dd5df549ac849a5e3a54904c0c01f0e06.tar.zst
freebsd-ports-gnome-c3eb2d9dd5df549ac849a5e3a54904c0c01f0e06.zip
devel/monodevelop: rather mark as BROKEN for openssl111
Reported by: mat@
-rw-r--r--devel/monodevelop/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/devel/monodevelop/Makefile b/devel/monodevelop/Makefile
index aee305fc29c8..ccce05a63162 100644
--- a/devel/monodevelop/Makefile
+++ b/devel/monodevelop/Makefile
@@ -15,16 +15,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= msbuild:devel/msbuild \
fsharpc:lang/fsharp \
- cmake:devel/cmake \
- ${LOCALBASE}/lib/libcrypto.so:security/openssl
+ cmake:devel/cmake
LIB_DEPENDS= libcurl.so:ftp/curl \
libssh2.so:security/libssh2
RUN_DEPENDS= ${LOCALBASE}/lib/libgdiplus.a:x11-toolkits/libgdiplus \
exctags:devel/ctags \
git:devel/git \
svn:devel/subversion \
- fsharpc:lang/fsharp \
- ${LOCALBASE}/lib/libcrypto.so:security/openssl
+ fsharpc:lang/fsharp
# main/external/fsharpbinding/paket.lock
NUGET_FEEDS= NUGET ROSLYN ROSLYN_FOR_VS_FOR_MAC TEMPLATING VS_IMPL VS_EDITOR VSSDK VSTEST
@@ -49,7 +47,7 @@ PAKET_DEPENDS= ExtCore=0.8.46 \
System.ValueTuple=4.4.0
PAKET_PACKAGEDIR=${WRKSRC}/external/fsharpbinding/packages
-USES= autoreconf desktop-file-utils gettext gmake gnome mono:nuget pathfix pkgconfig shared-mime-info
+USES= autoreconf desktop-file-utils gettext gmake gnome mono:nuget pathfix pkgconfig shared-mime-info ssl
USE_GNOME= gtksharp20 gnomesharp20
INSTALLS_ICONS= yes
@@ -73,12 +71,21 @@ GH_TUPLE= icsharpcode:RefactoringEssentials:0148f6a:1/external/RefactoringEssent
INSTALL_TARGET= install-strip
MAKE_ENV= DOTNET_MSBUILD_SDK_RESOLVER_SDKS_DIR= \
XDG_CACHE_HOME=${WRKDIR} \
- OPENSSL_ROOT_DIR=${LOCALBASE}
+ OPENSSL_ROOT_DIR=${OPENSSLBASE}
MAKE_JOBS_UNSAFE=Build parallelization not implemented
WRKSRC_SUBDIR= main
PORTSCOUT= limit:^\d+\.\d+\.[1-9].*
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT} == base
+BROKEN_FreeBSD_12= fails to compile: incomplete definition of type 'struct bio_st'
+BROKEN_FreeBSD_13= fails to compile: incomplete definition of type 'struct bio_st'
+.elif ${SSL_DEFAULT} == openssl111
+BROKEN= fails to compile: incomplete definition of type 'struct bio_st'
+.endif
+
post-patch:
${ECHO} "Release ID: ${PORTVERSION}" > ${WRKSRC}/buildinfo
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>