aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortimur <timur@FreeBSD.org>2008-08-06 07:06:17 +0800
committertimur <timur@FreeBSD.org>2008-08-06 07:06:17 +0800
commitc46430c2b248682ef9a8e3be0a02507facc58c3b (patch)
treeb51cce1770ea1606d46f7e2ade3a7f0da85a7a84
parent796924800e8a93c33f6a4f428330b567b58c430d (diff)
downloadfreebsd-ports-gnome-c46430c2b248682ef9a8e3be0a02507facc58c3b.tar.gz
freebsd-ports-gnome-c46430c2b248682ef9a8e3be0a02507facc58c3b.tar.zst
freebsd-ports-gnome-c46430c2b248682ef9a8e3be0a02507facc58c3b.zip
Add new port, that installs only smbclient out of samba3 suite for ports,
that need only it's functionality instead of full net/samba3 port. Submitted by: garga
-rw-r--r--net/Makefile1
-rw-r--r--net/samba-smbclient/Makefile42
-rw-r--r--net/samba-smbclient/files/smb-client.conf.sample9
-rw-r--r--net/samba-smbclient/pkg-descr6
4 files changed, 58 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3046c3730835..3bce35220efe 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -819,6 +819,7 @@
SUBDIR += samba-libsmbclient
SUBDIR += samba-nmblookup
SUBDIR += samba-pdbsql
+ SUBDIR += samba-smbclient
SUBDIR += samba3
SUBDIR += samba4wins
SUBDIR += sambasentinel
diff --git a/net/samba-smbclient/Makefile b/net/samba-smbclient/Makefile
new file mode 100644
index 000000000000..efbb2525a49d
--- /dev/null
+++ b/net/samba-smbclient/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: samba-smbclient
+# Date created: Mon Jul 28 12:43:50 BRT 2008
+# Whom: garga
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PORTEPOCH= 0
+PKGNAMESUFFIX= -smbclient
+
+COMMENT= Samba "ftp-like" client
+
+CONFLICTS= ja-samba-2.* ja-samba-3.* samba-2.* samba-3.*
+
+SAMBA_CONFIG= smb-client.conf
+SAMBA_PORT?= samba3
+SAMBA_SUBPORT= yes
+
+MASTERDIR= ${.CURDIR}/../${SAMBA_PORT}
+FILESDIR= ${.CURDIR}/files
+PKGDIR= ${.CURDIR}
+
+WITHOUT_ADS= yes
+
+MAN1= smbclient.1
+PLIST_FILES= bin/smbclient \
+ ${SAMBA_CONFDIR:S,^${PREFIX}/,,}/${SAMBA_CONFIG}.sample
+
+do-build:
+ cd ${WRKSRC} && ${MAKE} include/proto.h
+ cd ${WRKSRC} && ${MAKE} bin/smbclient
+
+do-install:
+ ${INSTALL_DATA} ${FILESDIR}/smb-client.conf.sample ${SAMBA_CONFDIR}/${SAMBA_CONFIG}.sample
+ @if [ ! -f "${SAMBA_CONFDIR}/${SAMBA_CONFIG}" ]; then \
+ ${CP} -p "${SAMBA_CONFDIR}/${SAMBA_CONFIG}.sample" "${SAMBA_CONFDIR}/${SAMBA_CONFIG}"; \
+ fi
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/smbclient ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/docs/manpages/smbclient.1 ${MAN1PREFIX}/man/man1
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/samba-smbclient/files/smb-client.conf.sample b/net/samba-smbclient/files/smb-client.conf.sample
new file mode 100644
index 000000000000..e493fd5c8419
--- /dev/null
+++ b/net/samba-smbclient/files/smb-client.conf.sample
@@ -0,0 +1,9 @@
+[global]
+
+# workgroup = NT-Domain-Name or Workgroup-Name, eg: MIDEARTH
+; workgroup = MYGROUP
+
+# Charset settings
+; display charset = koi8-r
+; unix charset = koi8-r
+; dos charset = cp866
diff --git a/net/samba-smbclient/pkg-descr b/net/samba-smbclient/pkg-descr
new file mode 100644
index 000000000000..4e691cb33725
--- /dev/null
+++ b/net/samba-smbclient/pkg-descr
@@ -0,0 +1,6 @@
+smbclient is samba client with an "ftp like" interface. It is a useful tool to
+test connectivity to a Windows share. It can be used to transfer files, or to
+look at share names. In addition, it has a nifty ability to 'tar' (backup) and
+restore files from a server to a client and visa versa.
+
+WWW: http://www.samba.org/