aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-12-16 08:07:24 +0800
committerpav <pav@FreeBSD.org>2006-12-16 08:07:24 +0800
commitc653e8b0610a26c9ad82f0e87a1cf7a8b67466d1 (patch)
tree83a5e5cf8332949619a7cfa3045326d151bc55bc
parent6cc5f96b7fcbcb6344725169eb37496ef38331e8 (diff)
downloadfreebsd-ports-gnome-c653e8b0610a26c9ad82f0e87a1cf7a8b67466d1.tar.gz
freebsd-ports-gnome-c653e8b0610a26c9ad82f0e87a1cf7a8b67466d1.tar.zst
freebsd-ports-gnome-c653e8b0610a26c9ad82f0e87a1cf7a8b67466d1.zip
- Fix build on -CURRENT
-rw-r--r--comms/hcidump/Makefile4
-rw-r--r--comms/hcidump/files/patch-parser.c11
-rw-r--r--comms/hcidump/files/timet.patch19
3 files changed, 11 insertions, 23 deletions
diff --git a/comms/hcidump/Makefile b/comms/hcidump/Makefile
index 89b6a8929c42..5bd014e94218 100644
--- a/comms/hcidump/Makefile
+++ b/comms/hcidump/Makefile
@@ -30,8 +30,4 @@ IGNORE= it needs Bluetooth stack (FreeBSD 5.2 or newer)
ONLY_FOR_ARCHS= i386
.endif
-.if ${OSVERSION} <= 700011
-EXTRA_PATCHES= files/timet.patch
-.endif
-
.include <bsd.port.post.mk>
diff --git a/comms/hcidump/files/patch-parser.c b/comms/hcidump/files/patch-parser.c
new file mode 100644
index 000000000000..8ed8a87e7ed4
--- /dev/null
+++ b/comms/hcidump/files/patch-parser.c
@@ -0,0 +1,11 @@
+--- parser/parser.c.ORIG Fri Sep 22 23:33:36 2006
++++ parser/parser.c Fri Sep 22 23:34:45 2006
+@@ -65,7 +65,7 @@
+
+ if (!parser.state) {
+ if (parser.flags & DUMP_TSTAMP)
+- printf("%8lu.%06lu ", f->ts.tv_sec, f->ts.tv_usec);
++ printf("%8lu.%06lu ", (unsigned long)f->ts.tv_sec, f->ts.tv_usec);
+ printf("%c ", (f->in ? '>' : '<'));
+ parser.state = 1;
+ } else
diff --git a/comms/hcidump/files/timet.patch b/comms/hcidump/files/timet.patch
deleted file mode 100644
index ed96df401261..000000000000
--- a/comms/hcidump/files/timet.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- parser/parser.c Fri Sep 12 19:38:11 2003
-+++ parser/parser.c Tue Jan 3 15:09:30 2006
-@@ -29,6 +29,7 @@
- #include <ctype.h>
- #include <stdio.h>
- #include <string.h>
-+#include <inttypes.h>
-
- #include "parser.h"
-
-@@ -65,7 +66,7 @@
-
- if (!parser.state) {
- if (parser.flags & DUMP_TSTAMP)
-- printf("%8lu.%06lu ", f->ts.tv_sec, f->ts.tv_usec);
-+ printf("%8jd.%06lu ", (intmax_t)f->ts.tv_sec, f->ts.tv_usec);
- printf("%c ", (f->in ? '>' : '<'));
- parser.state = 1;
- } else