aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-01-02 18:38:21 +0800
committeryuri <yuri@FreeBSD.org>2018-01-02 18:38:21 +0800
commitc7bb172141e04285ac2e6f32443c04d3250647e7 (patch)
treeacfdab0498936b7d95ec04415e513a1348332634
parent40bbc2803a1a513536fc2a897cd041d3820a89f4 (diff)
downloadfreebsd-ports-gnome-c7bb172141e04285ac2e6f32443c04d3250647e7.tar.gz
freebsd-ports-gnome-c7bb172141e04285ac2e6f32443c04d3250647e7.tar.zst
freebsd-ports-gnome-c7bb172141e04285ac2e6f32443c04d3250647e7.zip
New port: databases/py-python-arango: Python driver for ArangoDB
Submitted by: myself Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13733
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-python-arango/Makefile24
-rw-r--r--databases/py-python-arango/distinfo3
-rw-r--r--databases/py-python-arango/pkg-descr8
4 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 868145462f35..48f02faeb414 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -826,6 +826,7 @@
SUBDIR += py-pypuppetdb
SUBDIR += py-pypuppetdb03
SUBDIR += py-pytc
+ SUBDIR += py-python-arango
SUBDIR += py-python-memcached
SUBDIR += py-python-rrdtool
SUBDIR += py-python-sql
diff --git a/databases/py-python-arango/Makefile b/databases/py-python-arango/Makefile
new file mode 100644
index 000000000000..9f01aa4701d7
--- /dev/null
+++ b/databases/py-python-arango/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= python-arango
+DISTVERSION= 3.12.1
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python driver for ArangoDB
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+post-extract:
+ @${RM} -r ${WRKSRC}/tests # otherwise they are installed under the root directory and cause conflicts
+
+.include <bsd.port.mk>
diff --git a/databases/py-python-arango/distinfo b/databases/py-python-arango/distinfo
new file mode 100644
index 000000000000..275699f546ac
--- /dev/null
+++ b/databases/py-python-arango/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514862633
+SHA256 (python-arango-3.12.1.tar.gz) = 9a092133a0951e23b1164c4055349500e99a7c5713926e277b376bef8c3fa2d8
+SIZE (python-arango-3.12.1.tar.gz) = 76402
diff --git a/databases/py-python-arango/pkg-descr b/databases/py-python-arango/pkg-descr
new file mode 100644
index 000000000000..26b5e893ace8
--- /dev/null
+++ b/databases/py-python-arango/pkg-descr
@@ -0,0 +1,8 @@
+A python driver for ArangoDB.
+
+Features:
+* Clean, Pythonic interface
+* Lightweight
+* High ArangoDB REST API coverage
+
+WWW: https://github.com/joowani/python-arango