aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2015-11-30 22:59:46 +0800
committermiwi <miwi@FreeBSD.org>2015-11-30 22:59:46 +0800
commitc9b7336f3ab0b7c2e5d95cf56e700c710723c291 (patch)
tree99f6b44f4c612e8e5d7dd1839446ca942c70d519
parent160d36afbee4c9e362f148494afe52a60b2e6c7a (diff)
downloadfreebsd-ports-gnome-c9b7336f3ab0b7c2e5d95cf56e700c710723c291.tar.gz
freebsd-ports-gnome-c9b7336f3ab0b7c2e5d95cf56e700c710723c291.tar.zst
freebsd-ports-gnome-c9b7336f3ab0b7c2e5d95cf56e700c710723c291.zip
- Update to 1.0.4
Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D4321
-rw-r--r--devel/pecl-runkit/Makefile3
-rw-r--r--devel/pecl-runkit/distinfo4
-rw-r--r--devel/pecl-runkit/files/patch-php_runkit.h16
-rw-r--r--devel/pecl-runkit/files/patch-runkit.c13
-rw-r--r--devel/pecl-runkit/files/patch-runkit_constants.c13
-rw-r--r--devel/pecl-runkit/files/patch-runkit_import.c13
-rw-r--r--devel/pecl-runkit/files/patch-runkit_props.c13
-rw-r--r--devel/pecl-runkit/files/patch-runkit_sandbox.c125
8 files changed, 3 insertions, 197 deletions
diff --git a/devel/pecl-runkit/Makefile b/devel/pecl-runkit/Makefile
index bdbc323479a3..a29dca08ca26 100644
--- a/devel/pecl-runkit/Makefile
+++ b/devel/pecl-runkit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= runkit
-PORTVERSION= 0.9
+PORTVERSION= 1.0.4
CATEGORIES= devel pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -17,7 +17,6 @@ USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= runkit
-IGNORE_WITH_PHP= 5 54 55 56
CONFIGURE_ARGS= --enable-runkit=classkit
diff --git a/devel/pecl-runkit/distinfo b/devel/pecl-runkit/distinfo
index 68af1d30c3d2..05743b744d73 100644
--- a/devel/pecl-runkit/distinfo
+++ b/devel/pecl-runkit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PECL/runkit-0.9.tgz) = f0b4113c767225099741ef7eef38163a14929138e6143375d42d9b16082369af
-SIZE (PECL/runkit-0.9.tgz) = 49807
+SHA256 (PECL/runkit-1.0.4.tgz) = 5b1db0f53ac3d7445da22e8d8f851a4559ef1b6742e397f2cf412a2d0401555e
+SIZE (PECL/runkit-1.0.4.tgz) = 103274
diff --git a/devel/pecl-runkit/files/patch-php_runkit.h b/devel/pecl-runkit/files/patch-php_runkit.h
deleted file mode 100644
index 3dca7fc16d0d..000000000000
--- a/devel/pecl-runkit/files/patch-php_runkit.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./php_runkit.h.orig 2006-06-06 17:06:08.000000000 -0400
-+++ ./php_runkit.h 2010-04-13 00:04:47.000000000 -0400
-@@ -41,6 +41,13 @@
- #define PHP_RUNKIT_IMPORT_CLASSES (PHP_RUNKIT_IMPORT_CLASS_METHODS|PHP_RUNKIT_IMPORT_CLASS_CONSTS|PHP_RUNKIT_IMPORT_CLASS_PROPS)
- #define PHP_RUNKIT_IMPORT_OVERRIDE 0x0010
-
-+#if ZEND_MODULE_API_NO > 20050922
-+#define ZEND_ENGINE_2_2
-+#endif
-+#if ZEND_MODULE_API_NO > 20050921
-+#define ZEND_ENGINE_2_1
-+#endif
-+
- /* The TSRM interpreter patch required by runkit_sandbox was added in 5.1, but this package includes diffs for older versions
- * Those diffs include an additional #define to indicate that they've been applied
- */
diff --git a/devel/pecl-runkit/files/patch-runkit.c b/devel/pecl-runkit/files/patch-runkit.c
deleted file mode 100644
index 2acd62484d34..000000000000
--- a/devel/pecl-runkit/files/patch-runkit.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./runkit.c.orig 2006-06-06 17:06:08.000000000 -0400
-+++ ./runkit.c 2010-04-13 00:04:47.000000000 -0400
-@@ -58,8 +58,8 @@
- addr_len = spprintf(&addr, 0, "0x%0lx", (long)value);
- add_assoc_stringl(return_value, "address", addr, addr_len, 0);
-
-- add_assoc_long(return_value, "refcount", value->refcount);
-- add_assoc_bool(return_value, "is_ref", value->is_ref);
-+ add_assoc_long(return_value, "refcount", Z_REFCOUNT_P(value));
-+ add_assoc_bool(return_value, "is_ref", Z_ISREF_P(value));
- add_assoc_long(return_value, "type", value->type);
- }
- /* }}} */
diff --git a/devel/pecl-runkit/files/patch-runkit_constants.c b/devel/pecl-runkit/files/patch-runkit_constants.c
deleted file mode 100644
index 00139494d37f..000000000000
--- a/devel/pecl-runkit/files/patch-runkit_constants.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./runkit_constants.c.orig 2006-06-06 17:06:08.000000000 -0400
-+++ ./runkit_constants.c 2010-04-13 00:06:11.000000000 -0400
-@@ -197,8 +197,8 @@
- ALLOC_ZVAL(copyval);
- *copyval = *value;
- zval_copy_ctor(copyval);
-- copyval->refcount = 1;
-- copyval->is_ref = 0;
-+ Z_SET_REFCOUNT_P(copyval, 1);
-+ Z_UNSET_ISREF_P(copyval);
- if (zend_hash_add(&ce->constants_table, constname, constname_len + 1, &copyval, sizeof(zval *), NULL) == FAILURE) {
- php_error_docref(NULL TSRMLS_CC, E_WARNING, "Unable to add constant to class definition");
- zval_ptr_dtor(&copyval);
diff --git a/devel/pecl-runkit/files/patch-runkit_import.c b/devel/pecl-runkit/files/patch-runkit_import.c
deleted file mode 100644
index 757e1813b314..000000000000
--- a/devel/pecl-runkit/files/patch-runkit_import.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./runkit_import.c.orig 2006-06-06 17:06:08.000000000 -0400
-+++ ./runkit_import.c 2010-04-13 00:04:47.000000000 -0400
-@@ -226,7 +226,9 @@
- if (zend_hash_get_current_key_ex(&ce->default_properties, &key, &key_len, &idx, 0, &pos) == HASH_KEY_IS_STRING) {
- char *cname = NULL, *pname = key;
-
--#ifdef ZEND_ENGINE_2
-+#ifdef ZEND_ENGINE_2_2
-+ zend_unmangle_property_name(key, key_len - 1, &cname, &pname);
-+#elif defined(ZEND_ENGINE_2)
- zend_unmangle_property_name(key, &cname, &pname);
- #endif
- if (zend_hash_exists(&dce->default_properties, key, key_len)) {
diff --git a/devel/pecl-runkit/files/patch-runkit_props.c b/devel/pecl-runkit/files/patch-runkit_props.c
deleted file mode 100644
index 04fcdd10abc6..000000000000
--- a/devel/pecl-runkit/files/patch-runkit_props.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./runkit_props.c.orig 2006-06-06 17:06:08.000000000 -0400
-+++ ./runkit_props.c 2010-04-13 00:04:47.000000000 -0400
-@@ -124,8 +124,8 @@
- ALLOC_ZVAL(copyval);
- *copyval = *value;
- zval_copy_ctor(copyval);
-- copyval->refcount = 1;
-- copyval->is_ref = 0;
-+ Z_SET_REFCOUNT_P(copyval, 1);
-+ Z_UNSET_ISREF_P(copyval);
-
- if (zend_hash_add(&ce->default_properties, key, key_len + 1, &copyval, sizeof(zval *), NULL) == FAILURE) {
- php_error_docref(NULL TSRMLS_CC, E_WARNING, "Unable to add default property to class definition");
diff --git a/devel/pecl-runkit/files/patch-runkit_sandbox.c b/devel/pecl-runkit/files/patch-runkit_sandbox.c
deleted file mode 100644
index 630f8e14f27b..000000000000
--- a/devel/pecl-runkit/files/patch-runkit_sandbox.c
+++ /dev/null
@@ -1,125 +0,0 @@
---- ./runkit_sandbox.c.orig 2006-06-06 17:06:08.000000000 -0400
-+++ ./runkit_sandbox.c 2010-04-13 00:04:47.000000000 -0400
-@@ -728,7 +728,7 @@
- /* ZE expects refcount == 0 for unowned values */
- INIT_PZVAL(return_value);
- PHP_SANDBOX_CROSS_SCOPE_ZVAL_COPY_CTOR(return_value);
-- return_value->refcount--;
-+ Z_DELREF_P(return_value);
-
- return return_value;
- } else {
-@@ -801,7 +801,7 @@
- member_copy = *member;
- member = &member_copy;
- zval_copy_ctor(member);
-- member->refcount = 1;
-+ Z_SET_REFCOUNT_P(member, 1);
- convert_to_string(member);
- }
-
-@@ -875,7 +875,7 @@
- member_copy = *member;
- member = &member_copy;
- zval_copy_ctor(member);
-- member->refcount = 1;
-+ Z_SET_REFCOUNT_P(member, 1);
- convert_to_string(member);
- }
-
-@@ -1391,7 +1391,7 @@
-
- zval_copy_ctor(&callback_copy);
- callback_copy.is_ref = 0;
-- callback_copy.refcount = 1;
-+ Z_SET_REFCOUNT(callback_copy, 1);
- callback_is_true = zval_is_true(&callback_copy);
- zval_dtor(&callback_copy);
- }
-@@ -1411,7 +1411,7 @@
- if (objval->output_handler && return_value_used) {
- *return_value = *objval->output_handler;
- zval_copy_ctor(return_value);
-- return_value->refcount = 1;
-+ Z_SET_REFCOUNT_P(return_value, 1);
- return_value->is_ref = 0;
- } else {
- RETVAL_FALSE;
-@@ -1432,10 +1432,10 @@
- MAKE_STD_ZVAL(cb);
- *cb = *callback;
- zval_copy_ctor(cb);
-- cb->refcount = 0;
-- cb->is_ref = 0;
-+ Z_SET_REFCOUNT_P(cb, 0);
-+ Z_UNSET_ISREF_P(cb);
- }
-- cb->refcount++;
-+ Z_ADDREF_P(cb);
- objval->output_handler = cb;
- }
- }
-@@ -1469,8 +1469,8 @@
- ALLOC_ZVAL(retval); \
- Z_TYPE_P(retval) = IS_BOOL; \
- Z_BVAL_P(retval) = objval->name; \
-- retval->refcount = 0; \
-- retval->is_ref = 0; \
-+ Z_SET_REFCOUNT_P(retval, 0); \
-+ Z_UNSET_ISREF_P(retval); \
- \
- return retval; \
- }
-@@ -1497,7 +1497,7 @@
- zval_ptr_dtor(&objval->output_handler);
- }
-
-- value->refcount++;
-+ Z_ADDREF_P(value);
- objval->output_handler = value;
- }
-
-@@ -1512,7 +1512,7 @@
- } else {
- ZVAL_LONG(retval, objval->parent_scope);
- }
-- retval->refcount = 0;
-+ Z_SET_REFCOUNT_P(retval, 0);
-
- return retval;
- }
-@@ -1618,7 +1618,7 @@
- member_copy = *member;
- member = &member_copy;
- zval_copy_ctor(member);
-- member->refcount = 1;
-+ Z_SET_REFCOUNT_P(member, 1);
- convert_to_string(member);
- }
-
-@@ -1654,7 +1654,7 @@
- member_copy = *member;
- member = &member_copy;
- zval_copy_ctor(member);
-- member->refcount = 1;
-+ Z_SET_REFCOUNT_P(member, 1);
- convert_to_string(member);
- }
-
-@@ -1690,7 +1690,7 @@
- member_copy = *member;
- member = &member_copy;
- zval_copy_ctor(member);
-- member->refcount = 1;
-+ Z_SET_REFCOUNT_P(member, 1);
- convert_to_string(member);
- }
-
-@@ -1714,7 +1714,6 @@
- * Class Definition *
- ******************** */
-
--static
- ZEND_BEGIN_ARG_INFO_EX(php_runkit_require_two_args, 0, 0, 2)
- ZEND_ARG_PASS_INFO(0)
- ZEND_ARG_PASS_INFO(0)