aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-05-09 02:38:56 +0800
committerpgj <pgj@FreeBSD.org>2011-05-09 02:38:56 +0800
commitcd7d33d16180b3972d958ef6789d9c03788990e4 (patch)
tree56e2479fc867bf024faaf5859fd5ec22b7d4dd54
parent6c7798b5d6b697ff0fb84611df64e176534d3834 (diff)
downloadfreebsd-ports-gnome-cd7d33d16180b3972d958ef6789d9c03788990e4.tar.gz
freebsd-ports-gnome-cd7d33d16180b3972d958ef6789d9c03788990e4.tar.zst
freebsd-ports-gnome-cd7d33d16180b3972d958ef6789d9c03788990e4.zip
A library which exposes zero-copy sendfile functionality in a portable way.
If a platform does not support sendfile, a fallback implementation in Haskell is provided. Currently supported platforms: Windows 2000+ (Native), Linux 2.6+ (Native), FreeBSD (Native), OS-X 10.5+ (Native), Everything else (Portable Haskell code). WWW: http://patch-tag.com/r/mae/sendfile Obtained from: FreeBSD Haskell
-rw-r--r--net/hs-sendfile/Makefile21
-rw-r--r--net/hs-sendfile/distinfo2
-rw-r--r--net/hs-sendfile/pkg-descr8
3 files changed, 31 insertions, 0 deletions
diff --git a/net/hs-sendfile/Makefile b/net/hs-sendfile/Makefile
new file mode 100644
index 000000000000..a38c2c387684
--- /dev/null
+++ b/net/hs-sendfile/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-sendfile
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= sendfile
+PORTVERSION= 0.7.3
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A portable sendfile library
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= network>=2
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-sendfile/distinfo b/net/hs-sendfile/distinfo
new file mode 100644
index 000000000000..a6fa42b61580
--- /dev/null
+++ b/net/hs-sendfile/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/sendfile-0.7.3.tar.gz) = 801abd469f306d9a6ad9bc79757ee192b61ca1df3a5a89db8fec70fbbdcf4575
+SIZE (cabal/sendfile-0.7.3.tar.gz) = 10186
diff --git a/net/hs-sendfile/pkg-descr b/net/hs-sendfile/pkg-descr
new file mode 100644
index 000000000000..6623051aaffa
--- /dev/null
+++ b/net/hs-sendfile/pkg-descr
@@ -0,0 +1,8 @@
+A library which exposes zero-copy sendfile functionality in a portable way.
+If a platform does not support sendfile, a fallback implementation in Haskell
+is provided.
+
+Currently supported platforms: Windows 2000+ (Native), Linux 2.6+ (Native),
+FreeBSD (Native), OS-X 10.5+ (Native), Everything else (Portable Haskell code).
+
+WWW: http://patch-tag.com/r/mae/sendfile