aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-01-17 04:20:03 +0800
committermva <mva@FreeBSD.org>2014-01-17 04:20:03 +0800
commitcd866eecc87f4c2fb54ce3d59f1492e8b13a0ccb (patch)
treeeecddc32b46952975247745d0f138e141ecf906c
parente2d64d883fd058c7a0fdaa7d9a4565cbee64c6d8 (diff)
downloadfreebsd-ports-gnome-cd866eecc87f4c2fb54ce3d59f1492e8b13a0ccb.tar.gz
freebsd-ports-gnome-cd866eecc87f4c2fb54ce3d59f1492e8b13a0ccb.tar.zst
freebsd-ports-gnome-cd866eecc87f4c2fb54ce3d59f1492e8b13a0ccb.zip
- enable stagedir support
- shorten COMMENT to pet portlint
-rw-r--r--games/gish-demo/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/games/gish-demo/Makefile b/games/gish-demo/Makefile
index ab2a33ae8fd3..55a1de23625b 100644
--- a/games/gish-demo/Makefile
+++ b/games/gish-demo/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= http://s159260531.onlinehome.us/demos/
DISTNAME= gishdemo
MAINTAINER= mva@FreeBSD.org
-COMMENT= A platform game with a gelatinous 12-pound ball of tar named Gish (Demo version)
+COMMENT= Platform game with a gelatinous 12-pound ball of tar (Demo version)
RESTRICTED= (c) Copyright 2004 Chronic Logic All rights reserved
ONLY_FOR_ARCHS= i386 amd64
@@ -20,12 +20,11 @@ DATADIR= ${PREFIX}/lib/${PORTNAME}
SUB_FILES= rungish.sh
SUB_LIST= LINUXBASE=${LINUXBASE}
-NO_STAGE= yes
do-install:
- ${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/* ${DATADIR}
- ${BRANDELF} -t Linux ${DATADIR}/gishdemo
- ${BRANDELF} -t Linux ${DATADIR}/gishdemo
- ${INSTALL_SCRIPT} ${WRKDIR}/rungish.sh ${PREFIX}/bin/gish
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${CP} -R ${WRKSRC}/* ${STAGEDIR}${DATADIR}
+ ${BRANDELF} -t Linux ${STAGEDIR}${DATADIR}/gishdemo
+ ${BRANDELF} -t Linux ${STAGEDIR}${DATADIR}/gishdemo
+ ${INSTALL_SCRIPT} ${WRKDIR}/rungish.sh ${STAGEDIR}${PREFIX}/bin/gish
.include <bsd.port.mk>