aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-04-13 14:51:44 +0800
committerdanfe <danfe@FreeBSD.org>2015-04-13 14:51:44 +0800
commitcdd539d6b5970efce45a6bdd32e92a0f17e3a253 (patch)
treee9f275e7bfdebbafef9c1bd4a8e4e0aa630a83b0
parentc212d4b4dea79237d135aefb92e2b0aa228f6945 (diff)
downloadfreebsd-ports-gnome-cdd539d6b5970efce45a6bdd32e92a0f17e3a253.tar.gz
freebsd-ports-gnome-cdd539d6b5970efce45a6bdd32e92a0f17e3a253.tar.zst
freebsd-ports-gnome-cdd539d6b5970efce45a6bdd32e92a0f17e3a253.zip
- Unbreak by providing working mastersite
- Improve COMMENT, canonicalize Makefile header - Unmute installation commands, misc. cleanups - Reformat port description; kill EOL whitespace - Remove defunct WWW from port description - Transfer maintainership to the submitter PR: 199324 Submitted by: Chris Hutchinson
-rw-r--r--dns/fastresolve/Makefile27
-rw-r--r--dns/fastresolve/pkg-descr18
2 files changed, 22 insertions, 23 deletions
diff --git a/dns/fastresolve/Makefile b/dns/fastresolve/Makefile
index d9e4bc0b327f..46a14f3274f5 100644
--- a/dns/fastresolve/Makefile
+++ b/dns/fastresolve/Makefile
@@ -1,40 +1,41 @@
-# Created by: verm@drunkmonk.net
+# Created by: Amar Takhar <verm@drunkmonk.net>
# $FreeBSD$
PORTNAME= fastresolve
PORTVERSION= 2.10
PORTREVISION= 5
CATEGORIES= dns
-MASTER_SITES= http://www.djmnet.org/sw/dist/
+MASTER_SITES= http://BSDforge.com/projects/source/dns/fastresolve/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Programs that process web logs to get DNS and domain ownership info
-
-BROKEN= Unfetchable
-LIB_DEPENDS= libadns.so:${PORTSDIR}/dns/adns
-RUN_DEPENDS= p5-BerkeleyDB>=0:${PORTSDIR}/databases/p5-BerkeleyDB
+MAINTAINER= portmaster@BSDforge.com
+COMMENT= Programs to get DNS and domain ownership information from web logs
LICENSE= GPLv2
-OPTIONS_DEFINE= DOCS
+LIB_DEPENDS= libadns.so:${PORTSDIR}/dns/adns
+RUN_DEPENDS= p5-BerkeleyDB>=0:${PORTSDIR}/databases/p5-BerkeleyDB
USES= perl5 tar:bzip2
USE_BDB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PERL=${PERL} \
djm_cv_lib_db_Dbopen=yes
+
LDFLAGS+= -L${LOCALBASE}/lib -L${BDB_LIB_DIR}
CXXFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR}
+OPTIONS_DEFINE= DOCS
+
post-patch:
- @${REINPLACE_CMD} -e 's/-ldb"/-l${BDB_LIB_CXX_NAME}"/g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/-ldb"/-l${BDB_LIB_CXX_NAME}"/' \
+ ${WRKSRC}/configure
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in AUTHORS COPYING ChangeLog INSTALL NEWS README
- @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
- @${INSTALL_DATA} ${WRKSRC}/doc/TODO ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/timings ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/TODO ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/timings ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/dns/fastresolve/pkg-descr b/dns/fastresolve/pkg-descr
index 40bd79a4eed4..223651331cb7 100644
--- a/dns/fastresolve/pkg-descr
+++ b/dns/fastresolve/pkg-descr
@@ -1,10 +1,8 @@
-Fastresolve is a package of programs to process web log files to get DNS
-and domain ownership information for log analysis. It sends out many
-queries in parallel, and caches results, for speed. Its DNS resolver is
-about 10 times as fast as logresolve.pl from the Apache 1.3.9
-distribution, and about 50 times as fast as logresolve.c from that
-distribution. It is 5-20 times as fast as the adnslogres program that
-comes with the adns library, and about 3 times as fast as jdresolve,
-which is a Perl program that uses similar algorithms.
-
-WWW: http://www.pix.net/staff/djm/sw/fastresolve/
+Fastresolve is a package of programs to process web log files to get DNS
+and domain ownership information for log analysis. It sends out many
+queries in parallel, and caches results, for speed. Its DNS resolver is
+about 10 times as fast as logresolve.pl from the Apache 1.3.9 distribution,
+and about 50 times as fast as logresolve.c from that distribution. It is
+5-20 times as fast as the adnslogres program that comes with the adns
+library, and about 3 times as fast as jdresolve, which is a Perl program
+that uses similar algorithms.