aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-07-08 18:44:13 +0800
committerrakuco <rakuco@FreeBSD.org>2017-07-08 18:44:13 +0800
commitd2c1f20a615ce2b23134ae684ba28884e219f2cc (patch)
tree7bbb9c225170dc97504aef25a4e1986008298317
parent3369b548def3584163aa3ec4fa6f315954212070 (diff)
downloadfreebsd-ports-gnome-d2c1f20a615ce2b23134ae684ba28884e219f2cc.tar.gz
freebsd-ports-gnome-d2c1f20a615ce2b23134ae684ba28884e219f2cc.tar.zst
freebsd-ports-gnome-d2c1f20a615ce2b23134ae684ba28884e219f2cc.zip
Fix qt5-websockets-qml's dependency path in bsd.qt.mk.
libdeclarative_qmlwebsockets.so is not installed into ${QT_LIBDIR}, which causes the dependency logic in bsd.qt.mk to actually do something equivalent to this instead: BUILD_DEPENDS+= ${QT_LIBDIR}/${QT_QMLDIR}/QtWebSockets/libdeclarative_qmlwebsockets.so:www/qt5-websockets-qml RUN_DEPENDS+= ${QT_LIBDIR}/${QT_QMLDIR}/QtWebSockets/libdeclarative_qmlwebsockets.so:www/qt5-websockets-qml which translates into something like /usr/local/lib/qt5//usr/local/lib/qt5/qml/QtWebSockets/libdeclarative_qmlwebsockets.so:www/qt5-websockets-qml which obviously does not exist. Instead of settin websockets-qml_LIB, set websockets-qml_PATH like we do for other QML ports, so that our dependency logic does not needlessly prepend ${QT_LIBDIR} there. This fixes devel/qt5's build. PR: 220045
-rw-r--r--Mk/bsd.qt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 23ae49d365dd..1ea1fdce288b 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -596,7 +596,7 @@ websockets_PORT= www/${_QT_RELNAME}-websockets
websockets_LIB= libQt${_QT_LIBVER}WebSockets.so
websockets-qml_PORT= www/${_QT_RELNAME}-websockets-qml
-websockets-qml_LIB= ${QT_QMLDIR}/QtWebSockets/libdeclarative_qmlwebsockets.so
+websockets-qml_PATH= ${QT_QMLDIR}/QtWebSockets/qmldir
webkit_PORT= www/${_QT_RELNAME}-webkit
webkit_LIB= libQt${_QT_LIBVER}WebKit.so