aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2019-09-05 19:25:53 +0800
committerjbeich <jbeich@FreeBSD.org>2019-09-05 19:25:53 +0800
commitd2fa95d5d10fd78d8729be4c8bf65dc4b83902a2 (patch)
tree3f349fc6b46ea29355f9c740a79dce6156c983f6
parentd3c2a4841e1381b1169795e0ade19141fcef2253 (diff)
downloadfreebsd-ports-gnome-d2fa95d5d10fd78d8729be4c8bf65dc4b83902a2.tar.gz
freebsd-ports-gnome-d2fa95d5d10fd78d8729be4c8bf65dc4b83902a2.tar.zst
freebsd-ports-gnome-d2fa95d5d10fd78d8729be4c8bf65dc4b83902a2.zip
gecko: don't require gconf on non-Gnome2 desktops
Take advantage of lazy bindings by not requiring runtime dependency. DBus is required under Wayland (Gecko-specific) and for MIME handling but GConf2 is useless outside of Gnome2. So, only use GConf2 if it's already installed (similar to PulseAudio). PR: 240323
-rw-r--r--Mk/bsd.gecko.mk3
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox/Makefile1
4 files changed, 5 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 8d1ef479ba37..58104b23d391 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -247,7 +247,8 @@ RUN_DEPENDS+= ffmpeg>=0.8,1:multimedia/ffmpeg
.endif
.if ${PORT_OPTIONS:MGCONF}
-USE_GNOME+= gconf2
+# XXX USE_GNOME+=gconf2:build is not supported
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libgconf-2.so:devel/gconf2
MOZ_OPTIONS+= --enable-gconf
.else
MOZ_OPTIONS+= --disable-gconf
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index d113bd812fd3..b3484ba9b12e 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 68.1.0
+PORTREVISION= 1
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 1b6552dfeff9..d82046f84260 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firefox
DISTVERSION= 68.1.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 74b896a06393..d877c1a420d7 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firefox
DISTVERSION= 69.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \