aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2019-02-24 08:44:49 +0800
committerAlexandre C. GuimarĂ£es <rigoletto@FreeBSD.org>2019-02-24 08:44:49 +0800
commitd9286dc68b02d3d6c34b0ddfbf9b0fc04311bb24 (patch)
tree72cc4713e4affd118bf82eb6d3c16ccf26ae9424
parent8bc5bd1d606e6c748991a13cebe94dfca3b48ac3 (diff)
downloadfreebsd-ports-gnome-d9286dc68b02d3d6c34b0ddfbf9b0fc04311bb24.tar.gz
freebsd-ports-gnome-d9286dc68b02d3d6c34b0ddfbf9b0fc04311bb24.tar.zst
freebsd-ports-gnome-d9286dc68b02d3d6c34b0ddfbf9b0fc04311bb24.zip
graphics/zathura: Update to 4.3.
- update graphics/mupdf to 1.14.0 - update graphics/zathura-pdf-mupdf to 0.3.4 PR: 235952 PR: 233727 PR: 229935 PR: 232902 PR: 233021 Approved by: tcberner (mentor), Zsolt Udvari <uzsolt@uzsolt.hu> (maintainer), Quentin Stievenart <quentin.stievenart@gmail.com> (maintainer) Differential Revision: https://reviews.freebsd.org/D19301
-rw-r--r--graphics/mupdf/Makefile39
-rw-r--r--graphics/mupdf/distinfo6
-rw-r--r--graphics/mupdf/files/patch-Makefile25
-rw-r--r--graphics/mupdf/files/patch-Makerules134
-rw-r--r--graphics/mupdf/files/patch-thirdparty_lcms2_src_cmsmd5.c10
-rw-r--r--graphics/mupdf/pkg-plist9
-rw-r--r--graphics/zathura-pdf-mupdf/Makefile20
-rw-r--r--graphics/zathura-pdf-mupdf/distinfo6
-rw-r--r--graphics/zathura/Makefile11
-rw-r--r--graphics/zathura/distinfo6
-rw-r--r--graphics/zathura/pkg-plist54
11 files changed, 191 insertions, 129 deletions
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
index 55f92721863a..e3d6e181cd54 100644
--- a/graphics/mupdf/Makefile
+++ b/graphics/mupdf/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= mupdf
-PORTVERSION= 1.13.0
+DISTVERSION= 1.14.0
DISTVERSIONSUFFIX= -source
-PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://www.mupdf.com/downloads/ \
@@ -22,21 +21,20 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libjbig2dec.so:graphics/jbig2dec \
libopenjp2.so:graphics/openjpeg
-USES= cpe compiler:c++11-lang gmake jpeg pkgconfig
-MAKE_ARGS= build=release prefix=${PREFIX} mandir=${PREFIX}/man verbose=yes \
- SOVERSION=${PORTVERSION}
-ALL_TARGET= all extra
+USES= cpe compiler:c++11-lang gl gmake jpeg pkgconfig
USE_XORG= x11 xcursor xext xinerama xrandr
USE_GL= gl glut
+CPE_VENDOR= artifex
USE_LDCONFIG= yes
-CFLAGS+= `pkg-config --cflags libopenjp2` -I${WRKSRC}/include/mupdf -fPIC # pkg-config to avoid the conflict with openjpeg15
-LIBS+= -L${LOCALBASE}/lib
-
-CPE_VENDOR= artifex
+MAKE_ARGS= build=release prefix=${PREFIX} mandir=${PREFIX}/man verbose=yes \
+ XCFLAGS+="-I${WRKSRC}/include/mupdf -fPIC" \
+ XLIBS+="-L${LOCALBASE}/lib -L${WRKSRC}/build/release" \
+ SOVERSION=${DISTVERSION}
+ALL_TARGET= all extra
OPTIONS_DEFINE= DOCS JS SCROLL
-OPTIONS_DEFAULT=SCROLL
+OPTIONS_DEFAULT= SCROLL
JS_DESC= JavaScript support (V8 engine)
SCROLL_DESC= Build with scroll hacks
@@ -50,27 +48,20 @@ PLIST_SUB= SOVERSION=${PORTVERSION}
post-patch:
@${REINPLACE_CMD} -e 's/-pipe -O2 //' \
${WRKSRC}/Makerules
- @${REINPLACE_CMD} -e 's/-ldl //' ${WRKSRC}/Makerules ${WRKSRC}/Makethird
- @${RM} -r ${WRKSRC}/thirdparty/curl \
- ${WRKSRC}/thirdparty/freetype \
- ${WRKSRC}/thirdparty/freeglut \
- ${WRKSRC}/thirdparty/harfbuzz \
- ${WRKSRC}/thirdparty/jbig2dec \
- ${WRKSRC}/thirdparty/libjpeg \
- ${WRKSRC}/thirdparty/openjpeg \
- ${WRKSRC}/thirdparty/zlib
+ @${REINPLACE_CMD} -e 's/-ldl //' ${WRKSRC}/Makerules \
+ ${WRKSRC}/Makethird
post-install:
- ${MV} ${STAGEDIR}${PREFIX}/bin/mupdf-x11 ${STAGEDIR}${PREFIX}/bin/mupdf
+ ${MV} ${STAGEDIR}${PREFIX}/bin/mupdf-x11 \
+ ${STAGEDIR}${PREFIX}/bin/mupdf
${INSTALL_PROGRAM} \
${WRKSRC}/build/release/mjsgen \
${WRKSRC}/build/release/mujstest \
- ${WRKSRC}/build/release/mupdf-x11-curl \
${WRKSRC}/build/release/muraster \
${STAGEDIR}${PREFIX}/bin
${LN} -s libmupdf.so.${PORTVERSION} \
${STAGEDIR}${PREFIX}/lib/libmupdf.so
- ${LN} -s libmupdfthird.so.${PORTVERSION} \
- ${STAGEDIR}${PREFIX}/lib/libmupdfthird.so
+ ${LN} -s libmupdf-third.so.${PORTVERSION} \
+ ${STAGEDIR}${PREFIX}/lib/libmupdf-third.so
.include <bsd.port.mk>
diff --git a/graphics/mupdf/distinfo b/graphics/mupdf/distinfo
index ec465502a10c..c2da98ac5271 100644
--- a/graphics/mupdf/distinfo
+++ b/graphics/mupdf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1529321680
-SHA256 (mupdf-1.13.0-source.tar.gz) = 071c6962cbee1136188da62136596a9d704b81e35fe617cd34874bbb0ae7ca09
-SIZE (mupdf-1.13.0-source.tar.gz) = 51425034
+TIMESTAMP = 1542296614
+SHA256 (mupdf-1.14.0-source.tar.gz) = c443483a678c3fc258fa4adc124146225d0bb443c522619faadebf6b363d7724
+SIZE (mupdf-1.14.0-source.tar.gz) = 55654104
diff --git a/graphics/mupdf/files/patch-Makefile b/graphics/mupdf/files/patch-Makefile
index 5692fa0d31ed..1c2f8a2fe543 100644
--- a/graphics/mupdf/files/patch-Makefile
+++ b/graphics/mupdf/files/patch-Makefile
@@ -1,27 +1,22 @@
$OpenBSD: patch-Makefile,v 1.12 2016/12/12 10:54:39 sthen Exp $
---- Makefile.orig 2017-12-13 14:00:30 UTC
+--- Makefile.orig 2018-10-04 09:19:28 UTC
+++ Makefile
-@@ -312,8 +312,8 @@ generate: $(JAVASCRIPT_GEN)
+@@ -190,13 +190,15 @@ generate: source/pdf/js/util.js.h
# --- Library ---
-MUPDF_LIB = $(OUT)/libmupdf.a
--THIRD_LIB = $(OUT)/libmupdfthird.a
-+MUPDF_LIB = libmupdf.so.$(SOVERSION)
-+THIRD_LIB = libmupdfthird.so.$(SOVERSION)
- THREAD_LIB = $(OUT)/libmuthreads.a
-
- MUPDF_OBJ := \
-@@ -344,7 +344,11 @@ THIRD_OBJ := \
- THREAD_OBJ := $(THREAD_OBJ)
+-THIRD_LIB = $(OUT)/libmupdf-third.a
++MUPDF_LIB = $(OUT)/libmupdf.so.$(SOVERSION)
++THIRD_LIB = $(OUT)/libmupdf-third.so.$(SOVERSION)
+ THREAD_LIB = $(OUT)/libmupdf-threads.a
+ PKCS7_LIB = $(OUT)/libmupdf-pkcs7.a
-$(MUPDF_LIB) : $(MUPDF_OBJ)
+$(MUPDF_LIB) : $(MUPDF_OBJ) $(THIRD_LIB)
-+ $(CC) $(LDFLAGS) -fPIC -shared -Wl,-soname=$@ -Wl,--no-undefined -o $@ $^ $(LIBS)
-+
++ $(LINK_CMD) -shared -Wl,-soname -Wl,libmupdf.so.$(SOVERSION)
$(THIRD_LIB) : $(THIRD_OBJ)
-+ $(CC) $(LDFLAGS) -fPIC -shared -Wl,-soname=$@ -Wl,--no-undefined -o $@ $^ $(LIBS)
-+
++ $(LINK_CMD) -shared -Wl,-soname -Wl,libmupdf-third.so.$(SOVERSION)
$(THREAD_LIB) : $(THREAD_OBJ)
+ $(PKCS7_LIB) : $(PKCS7_OBJ)
- INSTALL_LIBS := $(MUPDF_LIB) $(THIRD_LIB)
diff --git a/graphics/mupdf/files/patch-Makerules b/graphics/mupdf/files/patch-Makerules
index 7b1f77534089..238af0ad7967 100644
--- a/graphics/mupdf/files/patch-Makerules
+++ b/graphics/mupdf/files/patch-Makerules
@@ -1,37 +1,105 @@
---- Makerules.orig 2018-06-18 11:40:10 UTC
+--- Makerules.orig 2018-10-04 09:19:28 UTC
+++ Makerules
-@@ -87,7 +87,7 @@ LD = xcrun ld
- RANLIB_CMD = xcrun ranlib $@
+@@ -24,28 +24,28 @@ ifeq ($(build),debug)
+ CFLAGS += -pipe -g
+ LDFLAGS += -g $(LDREMOVEUNREACH)
+ else ifeq ($(build),release)
+- CFLAGS += -pipe -O2 -DNDEBUG -fomit-frame-pointer
++ CFLAGS += -DNDEBUG -fomit-frame-pointer
+ LDFLAGS += $(LDREMOVEUNREACH) -Wl,-s
+ else ifeq ($(build),small)
+ CFLAGS += -pipe -Os -DNDEBUG -fomit-frame-pointer
+ LDFLAGS += $(LDREMOVEUNREACH) -Wl,-s
+ else ifeq ($(build),valgrind)
+- CFLAGS += -pipe -O2 -DNDEBUG -DPACIFY_VALGRIND -fno-omit-frame-pointer
++ CFLAGS += -DNDEBUG -DPACIFY_VALGRIND -fno-omit-frame-pointer
+ LDFLAGS += $(LDREMOVEUNREACH) -Wl,-s
+ else ifeq ($(build),sanitize)
+ CFLAGS += -pipe -g -fno-omit-frame-pointer $(SANITIZE_FLAGS)
+ LDFLAGS += -g $(SANITIZE_FLAGS)
+ else ifeq ($(build),sanitize-release)
+- CFLAGS += -pipe -O2 -DNDEBUG -fno-omit-frame-pointer $(SANITIZE_FLAGS)
++ CFLAGS += -DNDEBUG -fno-omit-frame-pointer $(SANITIZE_FLAGS)
+ LDFLAGS += $(LDREMOVEUNREACH) -Wl,-s $(SANITIZE_FLAGS)
+ else ifeq ($(build),profile)
+- CFLAGS += -pipe -O2 -DNDEBUG -pg
++ CFLAGS += -DNDEBUG -pg
+ LDFLAGS += -pg
+ else ifeq ($(build),coverage)
+ CFLAGS += -pipe -g -pg -fprofile-arcs -ftest-coverage
+ LIBS += -lgcov
+ else ifeq ($(build),native)
+- CFLAGS += -pipe -O2 -DNDEBUG -fomit-frame-pointer -march=native
++ CFLAGS += -DNDEBUG -fomit-frame-pointer -march=native
+ LDFLAGS += $(LDREMOVEUNREACH) -Wl,-s
+ else ifeq ($(build),memento)
+ CFLAGS += -pipe -g -DMEMENTO
+@@ -55,7 +55,7 @@ else ifeq ($(build),memento)
+ LIBS += -ldl
+ endif
+ else ifeq ($(build),gperf)
+- CFLAGS += -pipe -O2 -DNDEBUG -fomit-frame-pointer -DGPERF
++ CFLAGS += -DNDEBUG -fomit-frame-pointer -DGPERF
+ LIBS += -lprofiler
+ else
+ $(error unknown build setting: '$(build)')
+@@ -143,7 +143,58 @@ else ifeq ($(OS),Linux)
+ PTHREAD_LIBS := -lpthread
+ endif
- # Linux uses pkg-config for system libraries.
--else ifeq "$(OS)" "Linux"
-+else ifeq "$(OS)" "FreeBSD"
-
- HAVE_PTHREAD := yes
- SYS_PTHREAD_CFLAGS :=
-@@ -97,21 +97,15 @@ HAVE_GLUT := yes
- SYS_GLUT_CFLAGS :=
- SYS_GLUT_LIBS := -lglut -lGL
-
--ifeq "$(shell pkg-config --exists 'libcrypto >= 1.1.0' && echo yes)" "yes"
--HAVE_LIBCRYPTO := yes
--SYS_LIBCRYPTO_CFLAGS := -DHAVE_LIBCRYPTO $(shell pkg-config --cflags libcrypto)
--SYS_LIBCRYPTO_LIBS := $(shell pkg-config --libs libcrypto)
--endif
-+HAVE_LIBCRYPTO := no
-+SYS_LIBCRYPTO_CFLAGS :=
-+SYS_LIBCRYPTO_LIBS :=
-
- ifeq "$(shell pkg-config --exists libcurl && echo yes)" "yes"
- HAVE_CURL := yes
- SYS_CURL_CFLAGS := $(shell pkg-config --cflags libcurl)
- SYS_CURL_LIBS := $(shell pkg-config --libs libcurl)
--ifeq "$(shell pkg-config --exists openssl && echo yes)" "yes"
--HAVE_OPENSSL_SSL := yes
--SYS_CURL_CFLAGS += $(shell pkg-config --cflags openssl)
--SYS_CURL_DEPS += $(shell pkg-config --libs openssl)
-endif
-+HAVE_OPENSSL_SSL := no
- endif
- SYS_CURL_DEPS += -lpthread -lrt
++else ifeq ($(OS),FreeBSD)
++ PTHREAD_LIBS := -lthr
++# alphabetical order
++ # curl
++ USE_SYSTEM_CURL := yes
++ SYS_CURL_CFLAGS := $(shell pkg-config --cflags libcurl)
++ SYS_CURL_LIBS := $(shell pkg-config --libs libcurl)
++ # freetype
++ USE_SYSTEM_FREETYPE := yes
++ SYS_FREETYPE_CFLAGS := $(shell pkg-config --cflags freetype2)
++ SYS_FREETYPE_LIBS := $(shell pkg-config --libs freetype2)
++ # glut
++ USE_SYSTEM_GLUT := yes
++ SYS_GLUT_CFLAGS :=
++ SYS_GLUT_LIBS := -lglut -lGL
++ # harfbuzz
++ USE_SYSTEM_HARFBUZZ := yes
++ SYS_HARFBUZZ_CFLAGS := $(shell pkg-config --cflags harfbuzz)
++ SYS_HARFBUZZ_LIBS := $(shell pkg-config --libs harfbuzz)
++ # jbig2dec
++ USE_SYSTEM_JBIG2DEC := yes
++ SYS_JBIG2DEC_CFLAGS :=
++ SYS_JIB2DEC_LIBS := -ljbig2dec
++ # lcms2 - needs a patched version of lcms2
++ USE_SYSTEM_LCMS2 := no
++ # libcrypto
++ HAVE_LIBCRYPTO := no
++ SYS_LIBCRYPTO_CFLAGS :=
++ SYS_LIBCRYPTO_LIBS :=
++ # libjpeg
++ USE_SYSTEM_LIBJPEG := yes
++ SYS_LIBJPEG_CFLAGS := $(shell pkg-config --cflags libjpeg)
++ SYS_LIBJPEG_LIBS := $(shell pkg-config --libs libjpeg)
++ # openjpeg
++ USE_SYSTEM_OPENJPEG := yes
++ SYS_OPENJPEG_CFLAGS := $(shell pkg-config --cflags libopenjp2)
++ SYS_OPENJPEG_LIBS := $(shell pkg-config --libs libopenjp2)
++ # openssl
++ HAVE_OPENSSL_SSL := no
++ # pthread
++ HAVE_PTHREAD := yes
++ SYS_PTHREAD_CFLAGS :=
++ SYS_PTHREAD_LIBS := -lpthread
++ # x11
++ HAVE_X11 := yes
++ X11_CFLAGS := $(shell pkg-config --cflags x11 xext)
++ X11_LIBS := $(shell pkg-config --libs x11 xext)
++ # zlib
++ USE_SYSTEM_ZLIB := yes
++ SYS_ZLIB_CFLAGS := $(shell pkg-config --cflags zlib)
++ SYS_ZLIB_LIBS := $(shell pkg-config --libs zlib)
++endif # FreeBSD
+ # The following section has various cross compilation configurations.
+ #
diff --git a/graphics/mupdf/files/patch-thirdparty_lcms2_src_cmsmd5.c b/graphics/mupdf/files/patch-thirdparty_lcms2_src_cmsmd5.c
index 1fa178432d76..f2b2019a87af 100644
--- a/graphics/mupdf/files/patch-thirdparty_lcms2_src_cmsmd5.c
+++ b/graphics/mupdf/files/patch-thirdparty_lcms2_src_cmsmd5.c
@@ -1,4 +1,4 @@
---- thirdparty/lcms2/src/cmsmd5.c.orig 2018-10-31 19:49:39 UTC
+--- thirdparty/lcms2/src/cmsmd5.c.orig 2018-01-23 19:37:31 UTC
+++ thirdparty/lcms2/src/cmsmd5.c
@@ -29,7 +29,7 @@
#ifdef CMS_USE_BIG_ENDIAN
@@ -9,7 +9,7 @@
{
do {
-@@ -42,7 +42,7 @@ void byteReverse(cmsUInt8Number * buf, cmsUInt32Number
+@@ -42,7 +42,7 @@ void byteReverse(cmsUInt8Number * buf, c
}
#else
@@ -18,7 +18,7 @@
#endif
-@@ -196,7 +196,7 @@ void MD5add(cmsHANDLE Handle, cmsUInt8Number* buf, cms
+@@ -196,7 +196,7 @@ void MD5add(cmsHANDLE Handle, cmsUInt8Nu
}
memmove(p, buf, t);
@@ -27,7 +27,7 @@
MD5_Transform(ctx->buf, (cmsUInt32Number *) ctx->in);
buf += t;
-@@ -205,7 +205,7 @@ void MD5add(cmsHANDLE Handle, cmsUInt8Number* buf, cms
+@@ -205,7 +205,7 @@ void MD5add(cmsHANDLE Handle, cmsUInt8Nu
while (len >= 64) {
memmove(ctx->in, buf, 64);
@@ -36,7 +36,7 @@
MD5_Transform(ctx->buf, (cmsUInt32Number *) ctx->in);
buf += 64;
len -= 64;
-@@ -232,21 +232,21 @@ void MD5finish(cmsProfileID* ProfileID, cmsHANDLE Han
+@@ -232,21 +232,21 @@ void MD5finish(cmsProfileID* ProfileID,
if (count < 8) {
memset(p, 0, count);
diff --git a/graphics/mupdf/pkg-plist b/graphics/mupdf/pkg-plist
index 7bffdbd48a76..55bc9dcb5a5a 100644
--- a/graphics/mupdf/pkg-plist
+++ b/graphics/mupdf/pkg-plist
@@ -1,8 +1,6 @@
bin/mjsgen
bin/mujstest
bin/mupdf
-bin/mupdf-gl
-bin/mupdf-x11-curl
bin/muraster
bin/mutool
include/mupdf/fitz.h
@@ -64,7 +62,6 @@ include/mupdf/memento.h
include/mupdf/pdf-tools.h
include/mupdf/pdf.h
include/mupdf/pdf/annot.h
-include/mupdf/pdf/appearance.h
include/mupdf/pdf/clean.h
include/mupdf/pdf/cmap.h
include/mupdf/pdf/crypt.h
@@ -85,8 +82,8 @@ include/mupdf/pdf/xref.h
include/mupdf/ucdn.h
lib/libmupdf.so
lib/libmupdf.so.%%SOVERSION%%
-lib/libmupdfthird.so
-lib/libmupdfthird.so.%%SOVERSION%%
+lib/libmupdf-third.so
+lib/libmupdf-third.so.%%SOVERSION%%
man/man1/mupdf.1.gz
man/man1/mutool.1.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
@@ -98,10 +95,12 @@ man/man1/mutool.1.gz
%%PORTDOCS%%%%DOCSDIR%%/coding-overview.html
%%PORTDOCS%%%%DOCSDIR%%/coding-progressive.html
%%PORTDOCS%%%%DOCSDIR%%/coding-style.html
+%%PORTDOCS%%%%DOCSDIR%%/examples/bbox-device.js
%%PORTDOCS%%%%DOCSDIR%%/examples/create-thumbnail.js
%%PORTDOCS%%%%DOCSDIR%%/examples/draw-device.js
%%PORTDOCS%%%%DOCSDIR%%/examples/draw-document.js
%%PORTDOCS%%%%DOCSDIR%%/examples/example.c
+%%PORTDOCS%%%%DOCSDIR%%/examples/fix-s22pdf.js
%%PORTDOCS%%%%DOCSDIR%%/examples/jpx-to-pdf.js
%%PORTDOCS%%%%DOCSDIR%%/examples/multi-threaded.c
%%PORTDOCS%%%%DOCSDIR%%/examples/pdf-create-lowlevel.js
diff --git a/graphics/zathura-pdf-mupdf/Makefile b/graphics/zathura-pdf-mupdf/Makefile
index 3220c88f2845..16a415880ddd 100644
--- a/graphics/zathura-pdf-mupdf/Makefile
+++ b/graphics/zathura-pdf-mupdf/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= zathura-pdf-mupdf
-PORTVERSION= 0.3.3
-PORTREVISION= 2
+DISTVERSION= 0.3.4
CATEGORIES= graphics
MASTER_SITES= https://pwmt.org/projects/zathura-pdf-mupdf/download/ \
http://www.madpilot.net/~mad/pwmt.org/
@@ -23,18 +22,23 @@ LIB_DEPENDS= libjbig2dec.so:graphics/jbig2dec \
libmupdf.so:graphics/mupdf \
libopenjp2.so:graphics/openjpeg
+USES= compiler:c11 desktop-file-utils gnome jpeg \
+ meson pkgconfig tar:xz
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30
+USE_LDCONFIG= yes
+
+MESON_ARGS= -Dlink-external=true
+
PLIST_FILES= lib/zathura/libpdf-mupdf.so \
share/applications/org.pwmt.zathura-pdf-mupdf.desktop \
share/metainfo/org.pwmt.zathura-pdf-mupdf.metainfo.xml
-#MAKE_ARGS= OPENSSL_INC=-I${OPENSSLINC} OPENSSL_LIB="-L${OPENSSLLIB} -lcrypto"
-USES= compiler:c11 desktop-file-utils gmake jpeg meson pkgconfig tar:xz
-USE_GNOME= cairo gdkpixbuf2 glib20 gtk30
-USE_LDCONFIG= yes
-
CONFLICTS_INSTALL= zathura-pdf-poppler-[0-9]*
post-patch:
- ${REINPLACE_CMD} "s@\(cc.find_library(.*\))@\1,dirs:'${PREFIX}/lib')@" ${WRKSRC}/meson.build
+ ${REINPLACE_CMD} "s@\(cc.find_library(.*\))@\1,dirs:'${PREFIX}/lib')@" \
+ ${WRKSRC}/meson.build
+ ${REINPLACE_CMD} "s@join_paths(datadir, \
+ 'metainfo')@join_paths(datadir, 'appdata')@" ${WRKSRC}/meson.build
.include <bsd.port.mk>
diff --git a/graphics/zathura-pdf-mupdf/distinfo b/graphics/zathura-pdf-mupdf/distinfo
index fc9980c25ac2..0968453edd04 100644
--- a/graphics/zathura-pdf-mupdf/distinfo
+++ b/graphics/zathura-pdf-mupdf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531483831
-SHA256 (zathura-pdf-mupdf-0.3.3.tar.xz) = 52b02ceee272a47f7ef9c2b73cc4f6fb480c02fdce0e7f6b7c8e93ad6ac46dfd
-SIZE (zathura-pdf-mupdf-0.3.3.tar.xz) = 7880
+TIMESTAMP = 1543771885
+SHA256 (zathura-pdf-mupdf-0.3.4.tar.xz) = d64331b9be43e42dce1d113746c62e4e6e9c9a2b4df77889e4bfc743be2dcd98
+SIZE (zathura-pdf-mupdf-0.3.4.tar.xz) = 8092
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index cf9a59e52c5c..020fdf297bc7 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= zathura
-PORTVERSION= 0.4.1
-PORTREVISION= 1
+DISTVERSION= 0.4.3
CATEGORIES= graphics print
MASTER_SITES= https://pwmt.org/projects/zathura/download/ \
http://www.madpilot.net/~mad/pwmt.org/
@@ -20,14 +19,14 @@ LIB_DEPENDS= libcairo.so:graphics/cairo \
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR}
-USES= meson ninja compiler:c11 pkgconfig python tar:xz
+USES= compiler:c11 gettext-tools:build gnome meson ninja \
+ pkgconfig python sqlite tar:xz
USE_GNOME= glib20 gtk30 gdkpixbuf2
+INSTALLS_ICONS= yes
-OPTIONS_DEFINE= NLS SQLITE
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= SQLITE
SQLITE_LIB_DEPENDS= libsqlite3.so:databases/sqlite3
SQLITE_MESON_ARGS_OFF= -Denable-sqlite=false
-NLS_USES= gettext
.include <bsd.port.mk>
diff --git a/graphics/zathura/distinfo b/graphics/zathura/distinfo
index 6434c93cf2e5..04ebc26dfbaf 100644
--- a/graphics/zathura/distinfo
+++ b/graphics/zathura/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541502996
-SHA256 (zathura-0.4.1.tar.xz) = d6f56bf6e7e05d2e91213287c7aea21481c44521b622f9e9ec06a886f51dd9fe
-SIZE (zathura-0.4.1.tar.xz) = 148592
+TIMESTAMP = 1550822518
+SHA256 (zathura-0.4.3.tar.xz) = 7e12194426d709670e0f4b0b107c80dd21322881b57d4a0bf9a09998402ffd41
+SIZE (zathura-0.4.3.tar.xz) = 145796
diff --git a/graphics/zathura/pkg-plist b/graphics/zathura/pkg-plist
index f186fc9d997f..c41e99ebfbea 100644
--- a/graphics/zathura/pkg-plist
+++ b/graphics/zathura/pkg-plist
@@ -12,28 +12,34 @@ man/man5/zathurarc.5.gz
share/applications/org.pwmt.zathura.desktop
share/bash-completion/completions/zathura
share/dbus-1/interfaces/org.pwmt.zathura.xml
+share/icons/hicolor/128x128/apps/org.pwmt.zathura.png
+share/icons/hicolor/16x16/apps/org.pwmt.zathura.png
+share/icons/hicolor/256x256/apps/org.pwmt.zathura.png
+share/icons/hicolor/32x32/apps/org.pwmt.zathura.png
+share/icons/hicolor/64x64/apps/org.pwmt.zathura.png
+share/icons/scalable/apps/org.pwmt.zathura.svg
+share/locale/ca/LC_MESSAGES/zathura.mo
+share/locale/cs/LC_MESSAGES/zathura.mo
+share/locale/de/LC_MESSAGES/zathura.mo
+share/locale/el/LC_MESSAGES/zathura.mo
+share/locale/eo/LC_MESSAGES/zathura.mo
+share/locale/es/LC_MESSAGES/zathura.mo
+share/locale/es_CL/LC_MESSAGES/zathura.mo
+share/locale/et/LC_MESSAGES/zathura.mo
+share/locale/fr/LC_MESSAGES/zathura.mo
+share/locale/he/LC_MESSAGES/zathura.mo
+share/locale/hr/LC_MESSAGES/zathura.mo
+share/locale/id_ID/LC_MESSAGES/zathura.mo
+share/locale/it/LC_MESSAGES/zathura.mo
+share/locale/lt/LC_MESSAGES/zathura.mo
+share/locale/nl/LC_MESSAGES/zathura.mo
+share/locale/no/LC_MESSAGES/zathura.mo
+share/locale/pl/LC_MESSAGES/zathura.mo
+share/locale/pt_BR/LC_MESSAGES/zathura.mo
+share/locale/ru/LC_MESSAGES/zathura.mo
+share/locale/sv/LC_MESSAGES/zathura.mo
+share/locale/ta_IN/LC_MESSAGES/zathura.mo
+share/locale/tr/LC_MESSAGES/zathura.mo
+share/locale/uk_UA/LC_MESSAGES/zathura.mo
+share/metainfo/org.pwmt.zathura.appdata.xml
share/zsh/vendor-completions/_zathura
-%%NLS%%share/icons/hicolor/128x128/apps/org.pwmt.zathura.png
-%%NLS%%share/locale/ca/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/de/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/el/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/eo/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/es/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/es_CL/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/et/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/he/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/hr/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/id_ID/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/it/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/no/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/ta_IN/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/zathura.mo
-%%NLS%%share/locale/uk_UA/LC_MESSAGES/zathura.mo
-%%NLS%%share/metainfo/org.pwmt.zathura.appdata.xml