aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2007-04-19 04:16:21 +0800
committeritetcu <itetcu@FreeBSD.org>2007-04-19 04:16:21 +0800
commitd993999fc4a66eeac019638519f41cd8dda1bcd8 (patch)
treee5a89ed8d4323facc1b1585fa208438c3f053794
parent6cbd57bd81cdbb19175cb98e2ea22729493485cc (diff)
downloadfreebsd-ports-gnome-d993999fc4a66eeac019638519f41cd8dda1bcd8.tar.gz
freebsd-ports-gnome-d993999fc4a66eeac019638519f41cd8dda1bcd8.tar.zst
freebsd-ports-gnome-d993999fc4a66eeac019638519f41cd8dda1bcd8.zip
Add OPTIONS support.
PR: ports/111761 Submitted by: Marcelo Araujo (araujo@bsdmail.org) (maintainer)
-rw-r--r--x11-toolkits/fox10/Makefile35
1 files changed, 7 insertions, 28 deletions
diff --git a/x11-toolkits/fox10/Makefile b/x11-toolkits/fox10/Makefile
index 28e067596bba..b46b0437f56b 100644
--- a/x11-toolkits/fox10/Makefile
+++ b/x11-toolkits/fox10/Makefile
@@ -36,6 +36,13 @@ CONFIGURE_ARGS+=--with-opengl=mesa --with-x
MAN1= reswrap.1
+OPTIONS= SHM "Enable Shared Memory support" on \
+ CUPS "Enable CUPS support" off \
+ DEBUG "Build with DEBUG support" off \
+ FOX_APPLICATIONS "Install sample applications" off \
+ OPTIMIZED_CXXFLAGS "Enable additional optimizations" off \
+ PROFILING "Build with PROFILING support" off
+
##
## Additional Options
##
@@ -118,32 +125,4 @@ post-patch:
${WRKSRC}/Makefile.in
.endif
-pre-everything::
-.if !defined(WITH_OPTIMIZED_CXXFLAGS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can enable additional compilation optimizations'
- @${ECHO_MSG} 'by defining WITH_OPTIMIZED_CXXFLAGS'
-.endif
-.if !defined(WITH_CUPS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can enable CUPS support by defining WITH_CUPS'
-.endif
-.if !defined(WITH_DEBUG)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can build DEBUG support by defining WITH_DEBUG'
-.endif
-.if !defined(WITH_FOX_APPLICATIONS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can install FOX sample applications by defining WITH_FOX_APPLICATIONS'
-.endif
-.if !defined(WITH_PROFILING)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can build PROFILING support by defining WITH_PROFILING'
-.endif
-.if !defined(WITHOUT_SHM)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can disable Shared Memory support by defining WITHOUT_SHM'
-.endif
- @${ECHO_MSG}
-
.include <bsd.port.mk>