aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2018-09-19 01:09:44 +0800
committerswills <swills@FreeBSD.org>2018-09-19 01:09:44 +0800
commitde879bbcbdf2dfb0efd62b33bdd8e6f373ec10d9 (patch)
treed983d801d0425c4c6a75d3a57ab90d689d3eeb1d
parent7256c91728557fc0eea8575cdc88719191e53fde (diff)
downloadfreebsd-ports-gnome-de879bbcbdf2dfb0efd62b33bdd8e6f373ec10d9.tar.gz
freebsd-ports-gnome-de879bbcbdf2dfb0efd62b33bdd8e6f373ec10d9.tar.zst
freebsd-ports-gnome-de879bbcbdf2dfb0efd62b33bdd8e6f373ec10d9.zip
x11-wm/compiz-plugins-main: Add missing dependencies
While here, add LICENSE, NLS option and bump PORTREVISION PR: 230865 Submitted by: Samy Mahmoudi <samy.mahmoudi@gmail.com> Approved by: maintianer timeout (freebsd-ports@dan.me.uk, >3 weeks)
-rw-r--r--x11-wm/compiz-plugins-main/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/x11-wm/compiz-plugins-main/Makefile b/x11-wm/compiz-plugins-main/Makefile
index 1b0ca2d0be33..53345a6ca998 100644
--- a/x11-wm/compiz-plugins-main/Makefile
+++ b/x11-wm/compiz-plugins-main/Makefile
@@ -3,26 +3,30 @@
PORTNAME= compiz-plugins-main
PORTVERSION= 0.8.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
MAINTAINER= freebsd-ports@dan.me.uk
COMMENT= Plugins for Compiz Composite Window Manager
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libcairo.so:graphics/cairo \
- libpangocairo-1.0.so:x11-toolkits/pango
+ libpangocairo-1.0.so:x11-toolkits/pango \
+ libstartup-notification-1.so:x11/startup-notification
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:x11-wm/compiz \
${LOCALBASE}/libdata/pkgconfig/bcop.pc:devel/compiz-bcop
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USE_GL= yes
-USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
+USES= gmake jpeg libtool:keepla pathfix pkgconfig tar:bzip2
USE_CSTD= gnu89
-USE_GNOME= gconf2 intltool
-USE_XORG= xorgproto
+USE_GL= yes
+USE_GNOME= gconf2 intltool libxslt
+USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama xorgproto xrandr xrender
USE_LDCONFIG= yes
GCONF_SCHEMAS= compiz-animation.schemas \
@@ -55,4 +59,10 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-schemas
+OPTIONS_DEFINE= NLS
+OPTIONS_DEFAULT= NLS
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime gettext-tools
+
.include <bsd.port.mk>