aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2010-04-28 13:28:59 +0800
committerknu <knu@FreeBSD.org>2010-04-28 13:28:59 +0800
commite1144001b2babbdae3f44df7cc4795df43965e56 (patch)
treee72576fce7d36d250d99befe20045c72abb7712c
parentb6edb65e14cf799416f49fda0994365aa89b87f2 (diff)
downloadfreebsd-ports-gnome-e1144001b2babbdae3f44df7cc4795df43965e56.tar.gz
freebsd-ports-gnome-e1144001b2babbdae3f44df7cc4795df43965e56.tar.zst
freebsd-ports-gnome-e1144001b2babbdae3f44df7cc4795df43965e56.zip
Add ruby-kyotocabinet, Ruby (1.9.1+) binding to Kyoto Cabinet.
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ruby-kyotocabinet/Makefile56
-rw-r--r--databases/ruby-kyotocabinet/distinfo3
-rw-r--r--databases/ruby-kyotocabinet/files/patch-extconf.rb14
-rw-r--r--databases/ruby-kyotocabinet/pkg-descr8
5 files changed, 82 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 9785d1c57247..7f6086c2c958 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -661,6 +661,7 @@
SUBDIR += ruby-frontbase
SUBDIR += ruby-gdbm
SUBDIR += ruby-interbase
+ SUBDIR += ruby-kyotocabinet
SUBDIR += ruby-memcache
SUBDIR += ruby-msql
SUBDIR += ruby-mysql
diff --git a/databases/ruby-kyotocabinet/Makefile b/databases/ruby-kyotocabinet/Makefile
new file mode 100644
index 000000000000..383dbd4225b7
--- /dev/null
+++ b/databases/ruby-kyotocabinet/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: kyotocabinet-ruby
+# Date created: 28 April 2010
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kyotocabinet
+PORTVERSION= 1.7
+CATEGORIES= databases ruby
+MASTER_SITES= http://1978th.net/kyotocabinet/rubypkg/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Ruby (1.9.1+) binding to Kyoto Cabinet
+
+LIB_DEPENDS= kyotocabinet.2:${PORTSDIR}/databases/kyotocabinet
+
+RUBY_VER= 1.9
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+NO_PACKAGE= GPL3 incompatibility with Ruby
+
+CONFIGURE_ARGS= --with-kyotocabinet-dir="${LOCALBASE}" \
+ --with-bindir="${LOCALBASE}/bin"
+
+.include <bsd.port.pre.mk>
+
+PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/kyotocabinet.so
+
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${RUBY_MODDOCDIR}
+PORTDOCS= *
+.endif
+.if !defined(NOPORTEXAMPLES)
+EXAMPLESDIR= ${RUBY_MODEXAMPLESDIR}
+PORTEXAMPLES= *
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}/
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/example && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+.endif
+
+check:
+ cd ${BUILD_WRKSRC} && ${SETENV} RUBYLIB=. ${RUBY} maketest.rb
+
+.include <bsd.port.post.mk>
diff --git a/databases/ruby-kyotocabinet/distinfo b/databases/ruby-kyotocabinet/distinfo
new file mode 100644
index 000000000000..19eb1d564318
--- /dev/null
+++ b/databases/ruby-kyotocabinet/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/kyotocabinet-ruby-1.7.tar.gz) = da88fcc046379c4c25ddf5c5ee888610
+SHA256 (ruby/kyotocabinet-ruby-1.7.tar.gz) = c90ecb444f9ed00ba213c55fa8b99e030e7b7cb7705f7398f984d3b28ffa7661
+SIZE (ruby/kyotocabinet-ruby-1.7.tar.gz) = 51250
diff --git a/databases/ruby-kyotocabinet/files/patch-extconf.rb b/databases/ruby-kyotocabinet/files/patch-extconf.rb
new file mode 100644
index 000000000000..205f04640626
--- /dev/null
+++ b/databases/ruby-kyotocabinet/files/patch-extconf.rb
@@ -0,0 +1,14 @@
+--- extconf.rb.orig 2010-04-28 13:27:42.120543437 +0900
++++ extconf.rb 2010-04-28 13:04:57.387073893 +0900
+@@ -3,8 +3,9 @@
+ File::unlink("Makefile") if (File::exist?("Makefile"))
+ dir_config('kyotocabinet')
+
+-home = ENV["HOME"]
+-ENV["PATH"] = ENV["PATH"] + ":/usr/local/bin:$home/bin:."
++#home = ENV["HOME"]
++#ENV["PATH"] = ENV["PATH"] + ":/usr/local/bin:$home/bin:."
++ENV["PATH"] = '%s:%s' % [with_config('bindir'), ENV["PATH"]]
+ kccflags = `kcutilcodec conf -i 2>/dev/null`.chomp
+ kcldflags = `kcutilcodec conf -l 2>/dev/null`.chomp
+ kcldflags = kcldflags.gsub(/-l[\S]+/, "").strip
diff --git a/databases/ruby-kyotocabinet/pkg-descr b/databases/ruby-kyotocabinet/pkg-descr
new file mode 100644
index 000000000000..8051612e6420
--- /dev/null
+++ b/databases/ruby-kyotocabinet/pkg-descr
@@ -0,0 +1,8 @@
+This is a Ruby (1.9.1+) binding to Kyoto Cabinet, a straightforward
+implementation of DBM.
+
+Since the library is licensed under GPLv3 which is incompatible with
+the ruby runtime, binary distribution is inhibited.
+
+Author: Mikio Hirabayashi <hirarin@gmail.com>
+WWW: http://1978th.net/kyotocabinet/