aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-11-18 01:31:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-11-18 01:31:12 +0800
commite146164bb3704e386c0dcef3aa3f4f1b13acadcf (patch)
tree4d69078467d9a83ecadc01cb64ac461f19a033d5
parent459c0587e3d87e706b597a5050e4a35663883cdd (diff)
downloadfreebsd-ports-gnome-e146164bb3704e386c0dcef3aa3f4f1b13acadcf.tar.gz
freebsd-ports-gnome-e146164bb3704e386c0dcef3aa3f4f1b13acadcf.tar.zst
freebsd-ports-gnome-e146164bb3704e386c0dcef3aa3f4f1b13acadcf.zip
Fix build for net/gupnp 1.1.0 update
-rw-r--r--net/gupnp-ui/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/net/gupnp-ui/Makefile b/net/gupnp-ui/Makefile
index 07fb8c15ec57..1032845435cc 100644
--- a/net/gupnp-ui/Makefile
+++ b/net/gupnp-ui/Makefile
@@ -14,17 +14,19 @@ LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gupnp>=0.3:net/gupnp
-LIB_DEPENDS= libgupnp-1.0.so:net/gupnp \
+LIB_DEPENDS= libgupnp-1.2.so:net/gupnp \
libsoup-2.4.so:devel/libsoup
RUN_DEPENDS:= ${BUILD_DEPENDS}
+USES= gnome libtool pathfix pkgconfig python
+USE_GNOME= gtk20
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USE_GNOME= gtk20
USE_LDCONFIG= yes
-USES= gnome libtool pathfix pkgconfig python
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS = / s|tests||' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|gupnp-1.0|gupnp-1.2|' ${WRKSRC}/configure ${WRKSRC}/gupnp-ui-1.0.pc.in
.include <bsd.port.mk>