aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-01-31 23:54:10 +0800
committermiwi <miwi@FreeBSD.org>2014-01-31 23:54:10 +0800
commite56ac4e51ea8bcca32c7ff26407fc9ad10c83cb1 (patch)
treea95b737e2a5141881282c5d07edf5d0cbc6adc15
parent78bffef6c5302dd0bcd92aaaa8c81f1a3829e508 (diff)
downloadfreebsd-ports-gnome-e56ac4e51ea8bcca32c7ff26407fc9ad10c83cb1.tar.gz
freebsd-ports-gnome-e56ac4e51ea8bcca32c7ff26407fc9ad10c83cb1.tar.zst
freebsd-ports-gnome-e56ac4e51ea8bcca32c7ff26407fc9ad10c83cb1.zip
- Stage support
- Convert to USES
-rw-r--r--security/create-cert/Makefile6
-rw-r--r--security/ike/Makefile5
-rw-r--r--security/ike/pkg-plist3
-rw-r--r--security/ncrack/Makefile5
-rw-r--r--security/ncrack/pkg-plist1
-rw-r--r--security/pam_krb5-rh/Makefile4
-rw-r--r--security/pam_krb5-rh/pkg-plist3
-rw-r--r--security/pamtester/Makefile8
-rw-r--r--security/ssdeep/Makefile5
-rw-r--r--security/ssdeep/pkg-plist1
-rw-r--r--security/tpm-tools/Makefile13
-rw-r--r--security/tpm-tools/pkg-plist25
12 files changed, 40 insertions, 39 deletions
diff --git a/security/create-cert/Makefile b/security/create-cert/Makefile
index 67d2414f0857..675c447fc6e6 100644
--- a/security/create-cert/Makefile
+++ b/security/create-cert/Makefile
@@ -13,14 +13,12 @@ COMMENT= Create openssl client key and certificates
LICENSE= BSD
-PLIST_FILES= sbin/create-cert
-
-MAN8= create-cert.8
+PLIST_FILES= sbin/create-cert \
+ man/man8/create-cert.8.gz
GNU_CONFIGURE= yes
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/ike/Makefile b/security/ike/Makefile
index 3c20fe81d66b..8ea30c0f2561 100644
--- a/security/ike/Makefile
+++ b/security/ike/Makefile
@@ -31,13 +31,8 @@ QTGUI_DESC= Enable QT client front end applications
NATT_DESC= Enable NAT-Traversal
LDAP_DESC= Enable LDAP XAuth daemon support
-NO_STAGE= yes
.include <bsd.port.options.mk>
-MAN1= ikec.1
-MAN5= iked.conf.5
-MAN8= iked.8
-
.if ${PORT_OPTIONS:MDEBUG}
CMAKE_ARGS+= -DDEBUG=YES
.endif
diff --git a/security/ike/pkg-plist b/security/ike/pkg-plist
index 5845bc340106..1651e4e08732 100644
--- a/security/ike/pkg-plist
+++ b/security/ike/pkg-plist
@@ -17,3 +17,6 @@ lib/libss_log.so
lib/libss_log.so.2.2.1
lib/libss_pfk.so
lib/libss_pfk.so.2.2.1
+man/man1/ikec.1.gz
+man/man5/iked.conf.5.gz
+man/man8/iked.8.gz
diff --git a/security/ncrack/Makefile b/security/ncrack/Makefile
index 0ba46956ddbc..e60193306bf7 100644
--- a/security/ncrack/Makefile
+++ b/security/ncrack/Makefile
@@ -12,9 +12,6 @@ MAINTAINER= lx@FreeBSD.org
COMMENT= High-speed network authentication cracking tool
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
-MAN1= ncrack.1
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/ncrack/pkg-plist b/security/ncrack/pkg-plist
index 2a8b10839465..0f74a16dae05 100644
--- a/security/ncrack/pkg-plist
+++ b/security/ncrack/pkg-plist
@@ -8,4 +8,5 @@ share/ncrack/minimal.usr
share/ncrack/myspace.pwd
share/ncrack/phpbb.pwd
share/ncrack/top50000.pwd
+man/man1/ncrack.1.gz
@dirrm share/ncrack
diff --git a/security/pam_krb5-rh/Makefile b/security/pam_krb5-rh/Makefile
index 9baea076d837..ead167aad099 100644
--- a/security/pam_krb5-rh/Makefile
+++ b/security/pam_krb5-rh/Makefile
@@ -24,10 +24,6 @@ CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG} --without-afs \
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
-MAN5= pam_krb5.5
-MAN8= pam_krb5.8 pam_krb5_cchelper.8
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/security/pam_krb5-rh/pkg-plist b/security/pam_krb5-rh/pkg-plist
index 836cfd9d6f9c..c76013453ea6 100644
--- a/security/pam_krb5-rh/pkg-plist
+++ b/security/pam_krb5-rh/pkg-plist
@@ -37,6 +37,9 @@ lib/pam_krb5.la
%%NLS%%share/locale/uk/LC_MESSAGES/pam_krb5.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/pam_krb5.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/pam_krb5.mo
+man/man5/pam_krb5.5.gz
+man/man8/pam_krb5.8.gz
+man/man8/pam_krb5_cchelper.8.gz
%%NLS%%@dirrmtry share/locale/as/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/bn_IN/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/mr/LC_MESSAGES
diff --git a/security/pamtester/Makefile b/security/pamtester/Makefile
index aa73db0c237d..3a82e145d4fa 100644
--- a/security/pamtester/Makefile
+++ b/security/pamtester/Makefile
@@ -9,13 +9,11 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A command line pam authentication tester
-MAN1= pamtester.1
-
GNU_CONFIGURE= yes
CPPFLAGS+= ${CFLAGS}
-USE_GMAKE= yes
+USES= gmake
-PLIST_FILES= bin/pamtester
+PLIST_FILES= bin/pamtester \
+ man/man1/pamtester.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/ssdeep/Makefile b/security/ssdeep/Makefile
index d6f43b872f40..f61af7306cdf 100644
--- a/security/ssdeep/Makefile
+++ b/security/ssdeep/Makefile
@@ -14,10 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
-MAN1= ssdeep.1
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/ssdeep/pkg-plist b/security/ssdeep/pkg-plist
index fd79c0a0b819..371fcf359cbb 100644
--- a/security/ssdeep/pkg-plist
+++ b/security/ssdeep/pkg-plist
@@ -4,3 +4,4 @@ lib/libfuzzy.a
lib/libfuzzy.la
lib/libfuzzy.so
lib/libfuzzy.so.2
+man/man1/ssdeep.1.gz
diff --git a/security/tpm-tools/Makefile b/security/tpm-tools/Makefile
index 45c85226d00d..ffffc4b3d1c5 100644
--- a/security/tpm-tools/Makefile
+++ b/security/tpm-tools/Makefile
@@ -26,17 +26,4 @@ USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= YES
LDFLAGS+= -L${LOCALBASE}/lib -lintl ${ICONV_LIB}
-MAN1= tpm_sealdata.1 tpm_version.1 \
- tpmtoken_import.1 tpmtoken_init.1 tpmtoken_objects.1 \
- tpmtoken_protect.1 tpmtoken_setpasswd.1
-
-MAN3= tpmUnsealFile.3 tpmUnsealShred.3 tpmUnsealStrerror.3
-
-MAN8= tpm_changeownerauth.8 tpm_clear.8 tpm_createek.8 \
- tpm_getpubek.8 tpm_resetdalock.8 tpm_restrictpubek.8 \
- tpm_revokeek.8 tpm_selftest.8 tpm_setactive.8 \
- tpm_setclearable.8 tpm_setenable.8 tpm_setoperatorauth.8 \
- tpm_setownable.8 tpm_setpresence.8 tpm_takeownership.8
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/tpm-tools/pkg-plist b/security/tpm-tools/pkg-plist
index 28ca623be2c1..38b57cb15070 100644
--- a/security/tpm-tools/pkg-plist
+++ b/security/tpm-tools/pkg-plist
@@ -26,4 +26,29 @@ sbin/tpm_setownable
sbin/tpm_setpresence
sbin/tpm_takeownership
sbin/tpm_version
+man/man1/tpm_sealdata.1.gz
+man/man1/tpm_version.1.gz
+man/man1/tpmtoken_import.1.gz
+man/man1/tpmtoken_init.1.gz
+man/man1/tpmtoken_objects.1.gz
+man/man1/tpmtoken_protect.1.gz
+man/man1/tpmtoken_setpasswd.1.gz
+man/man3/tpmUnsealFile.3.gz
+man/man3/tpmUnsealShred.3.gz
+man/man3/tpmUnsealStrerror.3.gz
+man/man8/tpm_changeownerauth.8.gz
+man/man8/tpm_clear.8.gz
+man/man8/tpm_createek.8.gz
+man/man8/tpm_getpubek.8.gz
+man/man8/tpm_resetdalock.8.gz
+man/man8/tpm_restrictpubek.8.gz
+man/man8/tpm_revokeek.8.gz
+man/man8/tpm_selftest.8.gz
+man/man8/tpm_setactive.8.gz
+man/man8/tpm_setclearable.8.gz
+man/man8/tpm_setenable.8.gz
+man/man8/tpm_setoperatorauth.8.gz
+man/man8/tpm_setownable.8.gz
+man/man8/tpm_setpresence.8.gz
+man/man8/tpm_takeownership.8.gz
@dirrm include/tpm_tools