aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-12-15 01:28:54 +0800
committertobik <tobik@FreeBSD.org>2017-12-15 01:28:54 +0800
commite691229124ccf94d391378942f89f19b986fe158 (patch)
tree725042dc1a97967fcb5dedb531b63dca4e3aefc9
parent632a644c3f469bb784d9196da291af86653a5dc6 (diff)
downloadfreebsd-ports-gnome-e691229124ccf94d391378942f89f19b986fe158.tar.gz
freebsd-ports-gnome-e691229124ccf94d391378942f89f19b986fe158.tar.zst
freebsd-ports-gnome-e691229124ccf94d391378942f89f19b986fe158.zip
devel/libconcurrent: Update to latest commit
While here clean the port up a little and add TEST_TARGET
-rw-r--r--devel/libconcurrent/Makefile29
-rw-r--r--devel/libconcurrent/distinfo5
-rw-r--r--devel/libconcurrent/pkg-plist1
3 files changed, 16 insertions, 19 deletions
diff --git a/devel/libconcurrent/Makefile b/devel/libconcurrent/Makefile
index f7be97e45d18..5c061ab7af7a 100644
--- a/devel/libconcurrent/Makefile
+++ b/devel/libconcurrent/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libconcurrent
-PORTVERSION= 0.0.20160303
-PORTREVISION= 4
+PORTVERSION= 0.0.20160629
CATEGORIES= devel
MAINTAINER= tobik@FreeBSD.org
@@ -12,33 +11,29 @@ COMMENT= Tiny asymmetric-coroutine library
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE
+ONLY_FOR_ARCHS= amd64 i386
+
BUILD_DEPENDS= nasm:devel/nasm
+USES= gmake compiler:c11
USE_GITHUB= yes
GH_ACCOUNT= sharow
# Rolling release
-GH_TAGNAME= f55d33a789a4b2c6267268ec2d44a245f766f500
-
-ONLY_FOR_ARCHS= i386 amd64
-
-OPTIONS_DEFINE= EXAMPLES
+GH_TAGNAME= d84e7374c89be147ed7c0ba0fe844dad7f7ebb3e
MAKEFILE= makefile
MAKE_ARGS= LIBCONCURRENT_DESTDIR=${STAGEDIR}${PREFIX}
-USES= gmake compiler:c11
+TEST_TARGET= test
+
+OPTIONS_DEFINE= EXAMPLES
post-patch:
-# Remove explicitly (re-)set C compiler and linker in libconcurrent's
-# makefile. The ports system will provide the correct ones. This is
-# needed on FreeBSD 9 where cc does not understand -std=c11.
- @${REINPLACE_CMD} 's/CC=cc//g' ${WRKSRC}/makefile
- @${REINPLACE_CMD} 's/LD=ld//g' ${WRKSRC}/makefile
# libconcurrent's makefile resets ${ARCH} internally and the ports
# system interferes with that for some reason, so replace it with a
-# more neutral variant.
- @${REINPLACE_CMD} 's/ARCH/LIBCONCURRENT_ARCH/g' ${WRKSRC}/makefile
-# Same with ${DESTDIR}
- @${REINPLACE_CMD} 's/DESTDIR/LIBCONCURRENT_DESTDIR/g' ${WRKSRC}/makefile
+# more neutral variant. Same with ${DESTDIR}.
+ @${REINPLACE_CMD} -e 's/ARCH/LIBCONCURRENT_ARCH/g' \
+ -e 's/DESTDIR/LIBCONCURRENT_DESTDIR/g' \
+ ${WRKSRC}/makefile
post-patch-EXAMPLES-on:
# Fix examples makefile to work out-of-tree
diff --git a/devel/libconcurrent/distinfo b/devel/libconcurrent/distinfo
index 6518b41fc000..6e6684348552 100644
--- a/devel/libconcurrent/distinfo
+++ b/devel/libconcurrent/distinfo
@@ -1,2 +1,3 @@
-SHA256 (sharow-libconcurrent-0.0.20160303-f55d33a789a4b2c6267268ec2d44a245f766f500_GH0.tar.gz) = 418adeab02ce005756fc9c33165cf121ec4950f7e8f96b842fe22838a23953f4
-SIZE (sharow-libconcurrent-0.0.20160303-f55d33a789a4b2c6267268ec2d44a245f766f500_GH0.tar.gz) = 9550
+TIMESTAMP = 1513271521
+SHA256 (sharow-libconcurrent-0.0.20160629-d84e7374c89be147ed7c0ba0fe844dad7f7ebb3e_GH0.tar.gz) = 109acebc18bf81f16046e5f5011544ae4c849a8c1d31daebd7395fb0413b6a6f
+SIZE (sharow-libconcurrent-0.0.20160629-d84e7374c89be147ed7c0ba0fe844dad7f7ebb3e_GH0.tar.gz) = 10374
diff --git a/devel/libconcurrent/pkg-plist b/devel/libconcurrent/pkg-plist
index c475c2b4dded..688f0df634f3 100644
--- a/devel/libconcurrent/pkg-plist
+++ b/devel/libconcurrent/pkg-plist
@@ -9,4 +9,5 @@ lib/libconcurrent.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/float2.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/many_context1.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/strsplit.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/time_slice1.c