aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-12 00:48:54 +0800
committerantoine <antoine@FreeBSD.org>2017-12-12 00:48:54 +0800
commite7d862214480518390b24d249c119287922363c9 (patch)
tree74a6f3b7daafa1bacd37bf685501c5b6653767d9
parent015c9301e4bdc8c01d28d9d34a5717f7777d2bd2 (diff)
downloadfreebsd-ports-gnome-e7d862214480518390b24d249c119287922363c9.tar.gz
freebsd-ports-gnome-e7d862214480518390b24d249c119287922363c9.tar.zst
freebsd-ports-gnome-e7d862214480518390b24d249c119287922363c9.zip
Fix packaging with python3
-rw-r--r--chinese/ibus-libpinyin/Makefile1
-rw-r--r--chinese/ibus-pinyin/Makefile3
-rw-r--r--devel/d-feet/Makefile3
-rw-r--r--devel/gtranslator/Makefile1
4 files changed, 6 insertions, 2 deletions
diff --git a/chinese/ibus-libpinyin/Makefile b/chinese/ibus-libpinyin/Makefile
index d1bae508ca83..2137785d4524 100644
--- a/chinese/ibus-libpinyin/Makefile
+++ b/chinese/ibus-libpinyin/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libsqlite3.so:databases/sqlite3 \
USES= compiler:c++11-lib gmake python pkgconfig gettext
USE_GNOME= glib20
+USE_PYTHON= py3kplist
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/chinese/ibus-pinyin/Makefile b/chinese/ibus-pinyin/Makefile
index c43b2c7450ab..75252fe4d9f3 100644
--- a/chinese/ibus-pinyin/Makefile
+++ b/chinese/ibus-pinyin/Makefile
@@ -11,7 +11,7 @@ COMMENT= PinYin engine for IBus
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg@${PY_FLAVOR} \
${LOCALBASE}/share/gir-1.0/IBus-1.0.gir:textproc/ibus
LIB_DEPENDS= libpyzy-1.0.so:chinese/pyzy \
libibus-1.0.so:textproc/ibus \
@@ -19,6 +19,7 @@ LIB_DEPENDS= libpyzy-1.0.so:chinese/pyzy \
USES= compiler:c++11-lib gmake pkgconfig python autoreconf libtool
USE_GNOME= glib20
+USE_PYTHON= py3kplist
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking --disable-lua-extension
diff --git a/devel/d-feet/Makefile b/devel/d-feet/Makefile
index 84dc8a95a052..a008795ae88e 100644
--- a/devel/d-feet/Makefile
+++ b/devel/d-feet/Makefile
@@ -15,8 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= itstool:textproc/itstool
NO_ARCH= yes
-USES= gettext gmake gnome perl5 pkgconfig python:2.7+ tar:xz
+USES= gettext gmake gnome perl5 pkgconfig python tar:xz
USE_GNOME= gtk30 intlhack introspection:build libxml2:build libwnck3
+USE_PYTHON= py3kplist
GNU_CONFIGURE= yes
USE_PERL5= build
INSTALLS_ICONS= yes
diff --git a/devel/gtranslator/Makefile b/devel/gtranslator/Makefile
index 9aa74363635f..f18c7669f2e4 100644
--- a/devel/gtranslator/Makefile
+++ b/devel/gtranslator/Makefile
@@ -24,6 +24,7 @@ USE_GNOME= intlhack gnomeprefix gtk30 libgda5 gtksourceview3 libxml2 \
introspection:build
USES= desktop-file-utils gettext gmake libtool pathfix \
pkgconfig python tar:xz
+USE_PYTHON= py3kplist
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes