aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-05-02 21:26:12 +0800
committerjbeich <jbeich@FreeBSD.org>2018-05-02 21:26:12 +0800
commiteb0c717560c6acca5eb249ba8b006fb2a56f9a7c (patch)
tree3e1afd4fb59317aecdae7fe35b8a89b827b88416
parent3f926947b6cf6ea3e3cbf7d32a19903135cfc224 (diff)
downloadfreebsd-ports-gnome-eb0c717560c6acca5eb249ba8b006fb2a56f9a7c.tar.gz
freebsd-ports-gnome-eb0c717560c6acca5eb249ba8b006fb2a56f9a7c.tar.zst
freebsd-ports-gnome-eb0c717560c6acca5eb249ba8b006fb2a56f9a7c.zip
net/opal: correct codec option names after r468745
-rw-r--r--net/opal/Makefile2
-rw-r--r--net/opal/files/patch-ffmpeg44
2 files changed, 3 insertions, 3 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 32d3d7b3c26a..ca94efff7e6e 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opal
PORTVERSION= 3.10.10
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= net
MASTER_SITES= GNOME
diff --git a/net/opal/files/patch-ffmpeg4 b/net/opal/files/patch-ffmpeg4
index 9a742c60c862..ae872bfa8879 100644
--- a/net/opal/files/patch-ffmpeg4
+++ b/net/opal/files/patch-ffmpeg4
@@ -195,7 +195,7 @@ mpeg4.cxx:1329:27: error: use of undeclared identifier 'CODEC_FLAG_4MV'
m_avcontext->rc_min_rate = 0;
// This is set to 0 in ffmpeg.c, the command-line utility.
- m_avcontext->rc_initial_cplx = 0.0f;
-+ av_opt_set_double(m_avcontext, "rc_initial_cplx", 0.0f, 0);
++ av_opt_set_double(m_avcontext, "rc_init_cplx", 0.0f, 0);
// And this is set to 1.
// It seems to affect how aggressively the library will raise and lower
@@ -203,7 +203,7 @@ mpeg4.cxx:1329:27: error: use of undeclared identifier 'CODEC_FLAG_4MV'
// the "vbv buffer", not bits per second, so nobody really knows how
// it works.
- m_avcontext->rc_buffer_aggressivity = 1.0f;
-+ av_opt_set_double(m_avcontext, "rc_buffer_aggressivity", 1.0f, 0);
++ av_opt_set_double(m_avcontext, "rc_buf_aggressivity", 1.0f, 0);
// Ratecontrol buffer size, in bits. Usually 0.5-1 second worth.
// 224 kbyte is what VLC uses, and it seems to fix the quantization pulse (at Level 5)