aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-02-03 03:54:23 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-02-03 03:54:23 +0800
commitee462021e2331453137ff6dcca4f5a788f1764be (patch)
treeb3d3fa3eed1843ffb58af406022267b2b9fe21ae
parent039b38667a54028a5737bbc517bcdb5c66595572 (diff)
downloadfreebsd-ports-gnome-ee462021e2331453137ff6dcca4f5a788f1764be.tar.gz
freebsd-ports-gnome-ee462021e2331453137ff6dcca4f5a788f1764be.tar.zst
freebsd-ports-gnome-ee462021e2331453137ff6dcca4f5a788f1764be.zip
Fix r460400
- Add DICT, FTP, GOPHER, TELNET and TFTP options to OPTIONS_DEFAULT - Add HTTP options to OPTIONS_DEFAULT - Bump PORTREVISION for package change DICT, FTP, GOPHER, TELNET and TFTP options are enabled by default through configure but not being added to OPTIONS_DEFAULT in r460440. HTTP option is enabled by default through HTTP2 option.
-rw-r--r--ftp/curl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index a918a3273406..bd8742a41637 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.58.0
+PORTREVISION= 1
CATEGORIES= ftp net www
MASTER_SITES= https://curl.haxx.se/download/ \
LOCAL/sunpoet
@@ -21,7 +22,7 @@ OPTIONS_GROUP_PROTOCOL= DICT FTP GOPHER HTTP HTTP2 IMAP LDAP LDAPS LIBSSH2 POP3
OPTIONS_RADIO_SSL= GNUTLS NSS OPENSSL POLARSSL WOLFSSL
OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
OPTIONS_SINGLE_RESOLV= CARES THREADED_RESOLVER
-OPTIONS_DEFAULT= CA_BUNDLE COOKIES GSSAPI_${${SSL_DEFAULT} == base :?BASE :NONE} HTTP2 IMAP OPENSSL POP3 PROXY RESOLV RTSP SMTP THREADED_RESOLVER TLS_SRP
+OPTIONS_DEFAULT= CA_BUNDLE COOKIES GSSAPI_${${SSL_DEFAULT} == base :?BASE :NONE} DICT FTP GOPHER HTTP HTTP2 IMAP OPENSSL POP3 PROXY RESOLV RTSP SMTP TELNET TFTP THREADED_RESOLVER TLS_SRP
CA_BUNDLE_DESC= Enable CA bundle for OpenSSL/GnuTLS/mbedTLS
COOKIES_DESC= Cookies support
CURL_DEBUG_DESC= cURL debug memory tracking