aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-01-30 04:41:27 +0800
committertijl <tijl@FreeBSD.org>2014-01-30 04:41:27 +0800
commitf4ece524f54f6e4f4b6f73cb1999ccf6dfa8b3aa (patch)
tree310bc86af07bbd16fbcf8bcdb7cab60217830508
parent86e6ae3f996eeb2157a2e7bcb4998258e4c243cf (diff)
downloadfreebsd-ports-gnome-f4ece524f54f6e4f4b6f73cb1999ccf6dfa8b3aa.tar.gz
freebsd-ports-gnome-f4ece524f54f6e4f4b6f73cb1999ccf6dfa8b3aa.tar.zst
freebsd-ports-gnome-f4ece524f54f6e4f4b6f73cb1999ccf6dfa8b3aa.zip
Allow the use of //TRANSLIT and //IGNORE with PHP iconv.
PR: ports/184596 Tested by: grembo Approved by: ale (maintainer)
-rw-r--r--converters/php5-iconv/Makefile1
-rw-r--r--converters/php53-iconv/Makefile1
-rw-r--r--converters/php55-iconv/Makefile1
-rw-r--r--lang/php5/Makefile.ext2
-rw-r--r--lang/php53/Makefile.ext2
-rw-r--r--lang/php55/Makefile.ext2
6 files changed, 6 insertions, 3 deletions
diff --git a/converters/php5-iconv/Makefile b/converters/php5-iconv/Makefile
index 37db5b190ff2..c8842b1b4843 100644
--- a/converters/php5-iconv/Makefile
+++ b/converters/php5-iconv/Makefile
@@ -1,6 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= converters
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/converters/php53-iconv/Makefile b/converters/php53-iconv/Makefile
index 400ce3c0d9c5..fd8c1411903f 100644
--- a/converters/php53-iconv/Makefile
+++ b/converters/php53-iconv/Makefile
@@ -1,5 +1,6 @@
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= converters
MASTERDIR= ${.CURDIR}/../../lang/php53
diff --git a/converters/php55-iconv/Makefile b/converters/php55-iconv/Makefile
index 1727279f21e3..f1e0bc34edbc 100644
--- a/converters/php55-iconv/Makefile
+++ b/converters/php55-iconv/Makefile
@@ -1,6 +1,7 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= converters
MASTERDIR= ${.CURDIR}/../../lang/php55
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 4c0556ecfbfe..dfd9d1c2aa1f 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -128,7 +128,7 @@ CONFIGURE_ARGS+=--enable-hash \
.if ${PHP_MODNAME} == "iconv"
CONFIGURE_ARGS+=--with-iconv
-USES+= iconv
+USES+= iconv:translit
.endif
.if ${PHP_MODNAME} == "imap"
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index e35398787941..83751fc4e75f 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -127,7 +127,7 @@ CONFIGURE_ARGS+=--enable-hash \
.if ${PHP_MODNAME} == "iconv"
CONFIGURE_ARGS+=--with-iconv
-USES+= iconv
+USES+= iconv:translit
.endif
.if ${PHP_MODNAME} == "imap"
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index f61e2b00fd4b..39037627bec7 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -128,7 +128,7 @@ CONFIGURE_ARGS+=--enable-hash \
.if ${PHP_MODNAME} == "iconv"
CONFIGURE_ARGS+=--with-iconv
-USES+= iconv
+USES+= iconv:translit
.endif
.if ${PHP_MODNAME} == "imap"