aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-01-17 15:06:25 +0800
committerswills <swills@FreeBSD.org>2016-01-17 15:06:25 +0800
commitf6cbc43a402b24cf215a7841d747e5a606f23535 (patch)
tree902fa29d9a5cf9935738607467fcd8ffb0d8fc69
parentce4e4352d8fbfe530591b12bc321de15e6fa30d6 (diff)
downloadfreebsd-ports-gnome-f6cbc43a402b24cf215a7841d747e5a606f23535.tar.gz
freebsd-ports-gnome-f6cbc43a402b24cf215a7841d747e5a606f23535.tar.zst
freebsd-ports-gnome-f6cbc43a402b24cf215a7841d747e5a606f23535.zip
mark ports that don't work with Ruby 2.3
PR: 205774
-rw-r--r--audio/ruby-audiofile/Makefile1
-rw-r--r--audio/ruby-xmms2/Makefile2
-rw-r--r--biology/ruby-bio/Makefile1
-rw-r--r--databases/ruby-bdb/Makefile2
-rw-r--r--databases/ruby-mysql/Makefile1
-rw-r--r--databases/rubygem-bdb1/Makefile1
-rw-r--r--devel/ruby-calendar/Makefile1
-rw-r--r--devel/ruby-date2/Makefile1
-rw-r--r--devel/ruby-langscan/Makefile1
-rw-r--r--devel/ruby-rbbr/Makefile1
-rw-r--r--devel/rubygem-active_scaffold/Makefile2
-rw-r--r--devel/rubygem-blockenspiel/Makefile2
-rw-r--r--devel/rubygem-devise/Makefile2
-rw-r--r--irc/rbot/Makefile2
-rw-r--r--japanese/rubygem-jpmobile/Makefile2
-rw-r--r--lang/rubinius/Makefile2
-rw-r--r--mail/ruby-rmail/Makefile1
-rw-r--r--net/ruby-dict/Makefile1
-rw-r--r--textproc/ruby-deplate/Makefile1
-rw-r--r--textproc/ruby-rss.alt/Makefile1
-rw-r--r--textproc/ruby-sary/Makefile1
-rw-r--r--textproc/ruby-xml-configfile/Makefile1
-rw-r--r--www/ruby-aws/Makefile1
-rw-r--r--www/ruby-google/Makefile1
-rw-r--r--www/rubygem-acts-as-taggable-on/Makefile2
-rw-r--r--www/samidare/Makefile2
26 files changed, 36 insertions, 0 deletions
diff --git a/audio/ruby-audiofile/Makefile b/audio/ruby-audiofile/Makefile
index 5455de722bdc..e01699b25136 100644
--- a/audio/ruby-audiofile/Makefile
+++ b/audio/ruby-audiofile/Makefile
@@ -19,6 +19,7 @@ COMMENT= Ruby binding to the audiofile library
LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/audio/ruby-xmms2/Makefile b/audio/ruby-xmms2/Makefile
index d884e83c7240..623cd62cfdcb 100644
--- a/audio/ruby-xmms2/Makefile
+++ b/audio/ruby-xmms2/Makefile
@@ -16,6 +16,8 @@ CONFIGURE_TARGET= configure
USE_RUBY= yes
USE_GNOME= glib20
+BROKEN_RUBY23= yes
+
PLIST= ${.CURDIR}/pkg-plist
XMMS2_SLAVE= ruby
diff --git a/biology/ruby-bio/Makefile b/biology/ruby-bio/Makefile
index 6e5c647c4dd0..fabba5c99e92 100644
--- a/biology/ruby-bio/Makefile
+++ b/biology/ruby-bio/Makefile
@@ -16,6 +16,7 @@ LICENSE= GPLv2 RUBY
LICENSE_COMB= dual
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= XMLPARSER BDB4 MYSQL PGSQL DOCS
XMLPARSER_DESC= xmlparser support for faster Blast processing
diff --git a/databases/ruby-bdb/Makefile b/databases/ruby-bdb/Makefile
index fa372a4bb186..0b6ecc509bd9 100644
--- a/databases/ruby-bdb/Makefile
+++ b/databases/ruby-bdb/Makefile
@@ -21,6 +21,8 @@ USE_BDB= yes
OPTIONS_DEFINE= DOCS EXAMPLES
+BROKEN_RUBY23= yes
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_RUBY_RDOC= yes
diff --git a/databases/ruby-mysql/Makefile b/databases/ruby-mysql/Makefile
index 8a3840106f41..4e3def8dbba1 100644
--- a/databases/ruby-mysql/Makefile
+++ b/databases/ruby-mysql/Makefile
@@ -17,6 +17,7 @@ LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= DOCS
diff --git a/databases/rubygem-bdb1/Makefile b/databases/rubygem-bdb1/Makefile
index fcbd9cff4cee..ca74b1160eb1 100644
--- a/databases/rubygem-bdb1/Makefile
+++ b/databases/rubygem-bdb1/Makefile
@@ -13,6 +13,7 @@ LICENSE_COMB= dual
BROKEN_RUBY21= yes
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
USES= execinfo
USE_RUBY= yes
diff --git a/devel/ruby-calendar/Makefile b/devel/ruby-calendar/Makefile
index 50b10f003f72..005d3d963c1d 100644
--- a/devel/ruby-calendar/Makefile
+++ b/devel/ruby-calendar/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby modules to handle various calendars
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/devel/ruby-date2/Makefile b/devel/ruby-date2/Makefile
index 728dacacc419..3149b36689d4 100644
--- a/devel/ruby-date2/Makefile
+++ b/devel/ruby-date2/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Alternative date class for Ruby
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/devel/ruby-langscan/Makefile b/devel/ruby-langscan/Makefile
index 875dacf83a69..49df753affbf 100644
--- a/devel/ruby-langscan/Makefile
+++ b/devel/ruby-langscan/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= flex>=2.5.31:${PORTSDIR}/textproc/flex
BROKEN_RUBY21= yes
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
USES= perl5
USE_AUTOTOOLS= aclocal:env automake:env autoconf:env
diff --git a/devel/ruby-rbbr/Makefile b/devel/ruby-rbbr/Makefile
index 165a539e1f90..7519edc62474 100644
--- a/devel/ruby-rbbr/Makefile
+++ b/devel/ruby-rbbr/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS= rubygem-gettext>=0:${PORTSDIR}/devel/rubygem-gettext \
rubygem-gtk2>=0:${PORTSDIR}/x11-toolkits/rubygem-gtk2
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= DOCS
diff --git a/devel/rubygem-active_scaffold/Makefile b/devel/rubygem-active_scaffold/Makefile
index a502fd87bfdc..95fddf86b9fe 100644
--- a/devel/rubygem-active_scaffold/Makefile
+++ b/devel/rubygem-active_scaffold/Makefile
@@ -19,4 +19,6 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
+BROKEN_RUBY23= yes
+
.include <bsd.port.mk>
diff --git a/devel/rubygem-blockenspiel/Makefile b/devel/rubygem-blockenspiel/Makefile
index 2fdfd4eb26c2..88d9d5908f59 100644
--- a/devel/rubygem-blockenspiel/Makefile
+++ b/devel/rubygem-blockenspiel/Makefile
@@ -15,4 +15,6 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
+BROKEN_RUBY23= yes
+
.include <bsd.port.mk>
diff --git a/devel/rubygem-devise/Makefile b/devel/rubygem-devise/Makefile
index a0c35f7306ee..2ec1ef5f9c4f 100644
--- a/devel/rubygem-devise/Makefile
+++ b/devel/rubygem-devise/Makefile
@@ -22,6 +22,8 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
+BROKEN_RUBY23= yes
+
SLAVEDIRS= rubygem-devise-rails4
OPTIONS_SINGLE= RAILS
diff --git a/irc/rbot/Makefile b/irc/rbot/Makefile
index e28d500f05db..e762c2534260 100644
--- a/irc/rbot/Makefile
+++ b/irc/rbot/Makefile
@@ -32,6 +32,8 @@ PORTDOCS= REQUIREMENTS ChangeLog
OPTIONS_DEFINE= DOCS
+BROKEN_RUBY23= yes
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/japanese/rubygem-jpmobile/Makefile b/japanese/rubygem-jpmobile/Makefile
index a11d432e4025..3817b9103ba0 100644
--- a/japanese/rubygem-jpmobile/Makefile
+++ b/japanese/rubygem-jpmobile/Makefile
@@ -20,6 +20,8 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
+BROKEN_RUBY23= yes
+
PORTSCOUT= limit:^3\.0\.
OPTIONS_DEFINE= GEOKIT IPADDRESSES TERMINFO
diff --git a/lang/rubinius/Makefile b/lang/rubinius/Makefile
index 567d9ea47198..424c949ce9bf 100644
--- a/lang/rubinius/Makefile
+++ b/lang/rubinius/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/bundle:${PORTSDIR}/sysutils/rubygem-bundler \
BROKEN_FreeBSD_9= does not build
BROKEN_FreeBSD_11= does not build
+BROKEN_RUBY23= yes
+
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -P "${PREFIX}" \
-I "${PREFIX}/include/rubinius" \
diff --git a/mail/ruby-rmail/Makefile b/mail/ruby-rmail/Makefile
index 6903899268d1..d6da8d807b68 100644
--- a/mail/ruby-rmail/Makefile
+++ b/mail/ruby-rmail/Makefile
@@ -15,6 +15,7 @@ COMMENT= Lightweight mail manipulating library for Ruby
LICENSE= BSD3CLAUSE
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= DOCS
diff --git a/net/ruby-dict/Makefile b/net/ruby-dict/Makefile
index 0c814eca40d9..e4bd4609d6f0 100644
--- a/net/ruby-dict/Makefile
+++ b/net/ruby-dict/Makefile
@@ -16,6 +16,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= DOCS
diff --git a/textproc/ruby-deplate/Makefile b/textproc/ruby-deplate/Makefile
index c8a4d3ec482e..f55f8282c70c 100644
--- a/textproc/ruby-deplate/Makefile
+++ b/textproc/ruby-deplate/Makefile
@@ -15,6 +15,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
NO_ARCH= yes
USES= zip
diff --git a/textproc/ruby-rss.alt/Makefile b/textproc/ruby-rss.alt/Makefile
index 2259a000bdef..089b7b3a5e12 100644
--- a/textproc/ruby-rss.alt/Makefile
+++ b/textproc/ruby-rss.alt/Makefile
@@ -18,6 +18,7 @@ LICENSE_COMB= dual
RUN_DEPENDS= ja-${RUBY_PKGNAMEPREFIX}uconv>=0:${PORTSDIR}/japanese/ruby-uconv
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
CONFLICTS_INSTALL= ruby-rss-*
diff --git a/textproc/ruby-sary/Makefile b/textproc/ruby-sary/Makefile
index a48021597a8a..6d33a0e61c5f 100644
--- a/textproc/ruby-sary/Makefile
+++ b/textproc/ruby-sary/Makefile
@@ -19,6 +19,7 @@ LICENSE_COMB= dual
LIB_DEPENDS= libsary.so:${PORTSDIR}/textproc/sary
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= DOCS
diff --git a/textproc/ruby-xml-configfile/Makefile b/textproc/ruby-xml-configfile/Makefile
index 805def355152..3b8aa912c1b5 100644
--- a/textproc/ruby-xml-configfile/Makefile
+++ b/textproc/ruby-xml-configfile/Makefile
@@ -16,6 +16,7 @@ LICENSE= GPLv2 RUBY
LICENSE_COMB= dual
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= DOCS
diff --git a/www/ruby-aws/Makefile b/www/ruby-aws/Makefile
index 9f346fbfb615..34c532b5eeaa 100644
--- a/www/ruby-aws/Makefile
+++ b/www/ruby-aws/Makefile
@@ -16,6 +16,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
CONFLICTS= ruby-amazon-[0-9]*
diff --git a/www/ruby-google/Makefile b/www/ruby-google/Makefile
index 83ec6f7d0ab4..2c8318a9a5e2 100644
--- a/www/ruby-google/Makefile
+++ b/www/ruby-google/Makefile
@@ -16,6 +16,7 @@ COMMENT= Ruby interface to Google SOAP-driven Web API
LICENSE= GPLv2
BROKEN_RUBY22= yes
+BROKEN_RUBY23= yes
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/www/rubygem-acts-as-taggable-on/Makefile b/www/rubygem-acts-as-taggable-on/Makefile
index 0d993fdd1f34..46bc42db6493 100644
--- a/www/rubygem-acts-as-taggable-on/Makefile
+++ b/www/rubygem-acts-as-taggable-on/Makefile
@@ -18,4 +18,6 @@ USE_RUBY= YES
USE_RUBYGEMS= YES
RUBYGEM_AUTOPLIST= YES
+BROKEN_RUBY23= yes
+
.include <bsd.port.mk>
diff --git a/www/samidare/Makefile b/www/samidare/Makefile
index 5204efcb9c40..f04dbf830f4a 100644
--- a/www/samidare/Makefile
+++ b/www/samidare/Makefile
@@ -29,6 +29,8 @@ PLIST_FILES= bin/samidare man/man1/samidare.1.gz
OPTIONS_DEFINE= DOCS EXAMPLES
+BROKEN_RUBY23= yes
+
post-build:
@${REINPLACE_CMD} -e '1d' ${BUILD_WRKSRC}/${PORTNAME}
@cd ${BUILD_WRKSRC}; ${MV} ${PORTNAME}.man ${PORTNAME}.1