aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2012-09-08 01:21:27 +0800
committerehaupt <ehaupt@FreeBSD.org>2012-09-08 01:21:27 +0800
commitfa81cdf4e355f18e10deed23af8b5f83bca6e9a2 (patch)
tree5db9ea00f815d8500f6b293460ced089a933f26a
parentc7a1c5f57dcd29bee5add538d5ba51fcbfbf5ec3 (diff)
downloadfreebsd-ports-gnome-fa81cdf4e355f18e10deed23af8b5f83bca6e9a2.tar.gz
freebsd-ports-gnome-fa81cdf4e355f18e10deed23af8b5f83bca6e9a2.tar.zst
freebsd-ports-gnome-fa81cdf4e355f18e10deed23af8b5f83bca6e9a2.zip
- Convert to OPTIONSng
- Remove deprecated header information
-rw-r--r--audio/yell/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/audio/yell/Makefile b/audio/yell/Makefile
index c5d3633b0674..9e5b9a61815d 100644
--- a/audio/yell/Makefile
+++ b/audio/yell/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: yell
-# Date created: 10 August 2004
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
# $FreeBSD$
-#
PORTNAME= yell
PORTVERSION= 1.1
@@ -19,13 +14,16 @@ PLIST_FILES= bin/yell
ONLY_FOR_ARCHS= i386 amd64
-OPTIONS= SUID "Set the setuid bit on the yell program" off
+OPTIONS_DEFINE= SUID
+SUID_DESC= Use suid to allow execution as non root
+
+.include <bsd.port.options.mk>
do-build:
${CC} ${WRKSRC}/yell.c ${CFLAGS} -o ${WRKSRC}/${PORTNAME}
do-install:
-.if defined(WITH_SUID)
+.if ${PORT_OPTIONS:MSUID}
${INSTALL_PROGRAM} -m 4110 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.else
${INSTALL_PROGRAM} -m 0100 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin