aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-07 19:33:23 +0800
committerpawel <pawel@FreeBSD.org>2014-04-07 19:33:23 +0800
commitfae0fae5d67d5afa5aee53d11a2a8974d4c08a5e (patch)
tree752e3295c9016a9c5893f190610cfa9f7aa1559b
parent617fa1a57150ae3a8ea92e97aa87163da5a7d6d9 (diff)
downloadfreebsd-ports-gnome-fae0fae5d67d5afa5aee53d11a2a8974d4c08a5e.tar.gz
freebsd-ports-gnome-fae0fae5d67d5afa5aee53d11a2a8974d4c08a5e.tar.zst
freebsd-ports-gnome-fae0fae5d67d5afa5aee53d11a2a8974d4c08a5e.zip
- Add staging support
- Remove leading article from COMMENT - Convert to USES=tar:bzip2, new options framework
-rw-r--r--editors/mlview/Makefile28
1 files changed, 6 insertions, 22 deletions
diff --git a/editors/mlview/Makefile b/editors/mlview/Makefile
index eb39b7c7ec7e..3462deaa824f 100644
--- a/editors/mlview/Makefile
+++ b/editors/mlview/Makefile
@@ -9,11 +9,10 @@ MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= ports@FreeBSD.org
-COMMENT= A tree oriented XML editor for Gnome
+COMMENT= Tree oriented XML editor for Gnome
-USE_BZIP2= yes
USE_AUTOTOOLS= autoconf libtool
-USES= pathfix gmake iconv pkgconfig
+USES= pathfix gmake iconv pkgconfig tar:bzip2
USE_GNOME= eel2 gnomeprefix gtksourceview libgnomeui
USE_LDCONFIG= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib `pkg-config --libs gnome-vfs-2.0 libgnomeui-2.0` ${ICONV_LIB}"
@@ -21,24 +20,9 @@ CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags gnome-vfs-2.0 libgnomeui-
GCONF_SCHEMAS= mlview.schemas
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DBUS
-# Autodetect dbus
-.if exists (${LOCALBASE}/lib/libdbus-1.so.3)
-WITH_DBUS= yes
-.endif
+DBUS_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
+DBUS_CONFIGURE_ENABLE= dbus
-.if defined (WITH_DBUS)
-LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
-CONFIGURE_ARGS+="--enable-dbus=yes"
-.endif
-
-pre-everything::
-.if !defined (WITH_DBUS)
- @${ECHO_CMD}
- @${ECHO_CMD} Re-run with -DWITH_DBUS in order to enable dbus support!
- @${ECHO_CMD}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>