aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-01 02:19:05 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-01 02:19:05 +0800
commitfb066ae91b933c4d96e35b750a58963ac234815c (patch)
treefcfe06ee5ef45ef7b8ec26e88c1b10b9d0261280
parentbe4416bf1ec0176e1dbc3023913616ae50c07f6f (diff)
downloadfreebsd-ports-gnome-fb066ae91b933c4d96e35b750a58963ac234815c.tar.gz
freebsd-ports-gnome-fb066ae91b933c4d96e35b750a58963ac234815c.tar.zst
freebsd-ports-gnome-fb066ae91b933c4d96e35b750a58963ac234815c.zip
Only append to MAKE_ENV after bsd.port.pre.mk
-rw-r--r--graphics/svgalib/Makefile2
-rw-r--r--sysutils/cdrdao/Makefile2
-rw-r--r--sysutils/sformat/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/graphics/svgalib/Makefile b/graphics/svgalib/Makefile
index 7813d81be171..2a3a4ce49b65 100644
--- a/graphics/svgalib/Makefile
+++ b/graphics/svgalib/Makefile
@@ -25,7 +25,7 @@ ALL_TARGET= shared static
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-MAKE_ENV= NO_ASM=y
+MAKE_ENV+= NO_ASM=y
.endif
post-patch: .SILENT
diff --git a/sysutils/cdrdao/Makefile b/sysutils/cdrdao/Makefile
index f694bf0a1453..51acc01fc20f 100644
--- a/sysutils/cdrdao/Makefile
+++ b/sysutils/cdrdao/Makefile
@@ -69,7 +69,7 @@ CONFIGURE_ARGS+= --with-mp3-support=no --with-ogg-support=no
CONFIGURE_ARGS+= --without-pcctsbin --without-pcctsinc \
--with-posix-threads=no --with-scglib
-MAKE_ENV= CCOM=cc
+MAKE_ENV+= CCOM=cc
SCSILIBXARCH!= ${UNAME} -m
post-extract:
diff --git a/sysutils/sformat/Makefile b/sysutils/sformat/Makefile
index a16c0324ed58..fbfa48312f5d 100644
--- a/sysutils/sformat/Makefile
+++ b/sysutils/sformat/Makefile
@@ -26,7 +26,7 @@ USES= gmake
.include <bsd.port.pre.mk>
CCOM!= ${BASENAME} ${CC}
-MAKE_ENV= CCOM=${CCOM}
+MAKE_ENV+= CCOM=${CCOM}
SFMTTARGET= ${ARCH:S/powerpc64/powerpc/}-freebsd-${CCOM}
post-extract: