aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-07-04 03:34:37 +0800
committerpawel <pawel@FreeBSD.org>2016-07-04 03:34:37 +0800
commitfba93ad2e4c7abe2e6c735dda2d1ae202f123928 (patch)
treee0e110163b3eeaa1b32db0f8e9c2a9dc7e9a51f2
parent8c6f4dc3ec93ed732ec16e13c81fc99b23ca5dbd (diff)
downloadfreebsd-ports-gnome-fba93ad2e4c7abe2e6c735dda2d1ae202f123928.tar.gz
freebsd-ports-gnome-fba93ad2e4c7abe2e6c735dda2d1ae202f123928.tar.zst
freebsd-ports-gnome-fba93ad2e4c7abe2e6c735dda2d1ae202f123928.zip
- Fix SIZE_MAX buildfix patch, use other method now upstreamed
- Convert to USES=ssl - Group IMPOSE options helpers together
-rw-r--r--graphics/podofo/Makefile9
-rw-r--r--graphics/podofo/files/patch-src_base_PdfMemoryManagement.cpp26
2 files changed, 18 insertions, 17 deletions
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 169a8e93e1c2..8837d63262cc 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= podofo
PORTVERSION= 0.9.4
+PORTREVISION= 1
CATEGORIES= graphics print
MASTER_SITES= SF
@@ -16,19 +17,19 @@ LIB_DEPENDS= libidn.so:dns/libidn \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-USES= cmake dos2unix
+USES= cmake dos2unix ssl
CMAKE_ARGS= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
-DPODOFO_BUILD_STATIC:BOOL=FALSE \
-DOPENSSL_INCLUDE_DIR:PATH="${OPENSSLINC}" \
-DOPENSSL_LIBRARIES:PATH="${OPENSSLDIR}"
-USE_OPENSSL= yes
USE_LDCONFIG= yes
DOS2UNIX_FILES= cmake/modules/FindFREETYPE.cmake
OPTIONS_DEFINE= IMPOSE JPEG PNG TIFF
OPTIONS_DEFAULT= JPEG PNG TIFF
-IMPOSE_DESC= Build impose tool (needs Lua)
+IMPOSE_DESC= Build impose tool (needs Lua)
+IMPOSE_USES= lua:51
IMPOSE_CMAKE_ON= -DWANT_LUA:BOOL=TRUE
IMPOSE_CXXFLAGS= -I${LUA_INCDIR}
IMPOSE_LDFLAGS= -L${LUA_LIBDIR}
@@ -42,6 +43,4 @@ PNG_LIB_DEPENDS= libpng.so:graphics/png
TIFF_CMAKE_ON= -DWANT_TIFF:BOOL=TRUE
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
-IMPOSE_USES= lua:51
-
.include <bsd.port.mk>
diff --git a/graphics/podofo/files/patch-src_base_PdfMemoryManagement.cpp b/graphics/podofo/files/patch-src_base_PdfMemoryManagement.cpp
index 12d761f9dfee..df25e1fd6e05 100644
--- a/graphics/podofo/files/patch-src_base_PdfMemoryManagement.cpp
+++ b/graphics/podofo/files/patch-src_base_PdfMemoryManagement.cpp
@@ -1,17 +1,19 @@
---- src/base/PdfMemoryManagement.cpp.orig 2016-06-16 16:10:23 UTC
+--- src/base/PdfMemoryManagement.cpp.orig 2016-07-03 09:12:06 UTC
+++ src/base/PdfMemoryManagement.cpp
-@@ -44,6 +44,14 @@
+@@ -34,15 +34,9 @@
+ #include "PdfMemoryManagement.h"
+ #include "PdfDefinesPrivate.h"
+
+-#ifdef _WIN32
+ #ifndef SIZE_MAX
+-#ifdef _WIN64
+-#define SIZE_MAX _UI64_MAX
+-#else
+-#define SIZE_MAX UINT_MAX
+-#endif
++#define SIZE_MAX std::numeric_limits<size_t>::max()
#endif
- #endif // _WIN32
+-#endif // _WIN32
-+#ifdef __FreeBSD__
-+#if __WORDSIZE == 64
-+#define SIZE_MAX UINT64_MAX
-+#else
-+#define SIZE_MAX UINT_MAX
-+#endif
-+#endif
-+
#if defined(_MSC_VER) && ( _MSC_VER <= 1200 )
// errno.h isn't available in Visual C++ 6 (definitions are in stdlib.h which is already included)
- #else