aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2017-08-06 01:32:01 +0800
committeradamw <adamw@FreeBSD.org>2017-08-06 01:32:01 +0800
commitfca87c75d2565d9ebecd0689202d14ee5175c7af (patch)
treeddcc7834de99c645eac0023a3f76f2d9e6e88699
parentded56b5b2d5fa996f31e69f5c09b19a86d677479 (diff)
downloadfreebsd-ports-gnome-fca87c75d2565d9ebecd0689202d14ee5175c7af.tar.gz
freebsd-ports-gnome-fca87c75d2565d9ebecd0689202d14ee5175c7af.tar.zst
freebsd-ports-gnome-fca87c75d2565d9ebecd0689202d14ee5175c7af.zip
Update to 2.1.22.
Noteworthy changes in version 2.1.22 ==================================== * gpg: Extend command --quick-set-expire to allow for setting the expiration time of subkeys. * gpg: By default try to repair keys during import. New sub-option no-repair-keys for --import-options. * gpg,gpgsm: Improved checking and reporting of DE-VS compliance. * gpg: New options --key-origin and --with-key-origin. Store the time of the last key update from keyservers, WKD, or DANE. * agent: New option --ssh-fingerprint-digest. * dimngr: Lower timeouts on keyserver connection attempts and made it configurable. * dirmngr: Tor will now automatically be detected and used. The option --no-use-tor disables Tor detection. * dirmngr: Now detects a changed /etc/resolv.conf. * agent,dirmngr: Initiate shutdown on removal of the GnuPG home directory. * gpg: Avoid caching passphrase for failed symmetric encryption. * agent: Support for unprotected ssh keys. * dirmngr: Fixed name resolving on systems using only v6 nameservers. * dirmngr: Allow the use of TLS over http proxies. * w32: Change directory of the daemons after startup. * wks: New man pages for client and server. A detailed description of the changes found in this 2.1 branch can be found at <https://gnupg.org/faq/whats-new-in-2.1.html>.
-rw-r--r--security/gnupg/Makefile6
-rw-r--r--security/gnupg/distinfo6
-rw-r--r--security/gnupg/files/patch-scdaemon84
-rw-r--r--security/gnupg/pkg-plist2
4 files changed, 8 insertions, 90 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index 51e3a279ec4b..203992788ce7 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= gnupg
-PORTVERSION= 2.1.21
-PORTREVISION= 2
+PORTVERSION= 2.1.22
CATEGORIES= security
MASTER_SITES= GNUPG
@@ -12,7 +11,7 @@ COMMENT= The GNU Privacy Guard (modern version)
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING
-LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LIB
+LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LGPL3
LIB_DEPENDS= libassuan.so:security/libassuan \
libgcrypt.so:security/libgcrypt \
@@ -31,6 +30,7 @@ CONFIGURE_ARGS= --disable-ntbtls --enable-symcryptrun --disable-wks-tools
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INFO= gnupg
+TEST_TARGET= check-all
OPTIONS_DEFINE= GNUTLS LDAP SCDAEMON NLS DOCS SUID_GPG
OPTIONS_DEFAULT=GNUTLS SCDAEMON
diff --git a/security/gnupg/distinfo b/security/gnupg/distinfo
index c6f21080d043..4b2d1646816c 100644
--- a/security/gnupg/distinfo
+++ b/security/gnupg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1494886846
-SHA256 (gnupg-2.1.21.tar.bz2) = 7aead8a8ba75b69866f583b6c747d91414d523bfdfbe9a8e0fe026b16ba427dd
-SIZE (gnupg-2.1.21.tar.bz2) = 6472887
+TIMESTAMP = 1501953654
+SHA256 (gnupg-2.1.22.tar.bz2) = 46716faf9e1b92cfca86609f3bfffbf5bb4b6804df90dc853ff7061cfcfb4ad7
+SIZE (gnupg-2.1.22.tar.bz2) = 6530433
diff --git a/security/gnupg/files/patch-scdaemon b/security/gnupg/files/patch-scdaemon
deleted file mode 100644
index 23bedab6b95f..000000000000
--- a/security/gnupg/files/patch-scdaemon
+++ /dev/null
@@ -1,84 +0,0 @@
-From a8dd96826f8484c0ae93c954035b95c2a75c80f2 Mon Sep 17 00:00:00 2001
-From: NIIBE Yutaka <gniibe@fsij.org>
-Date: Wed, 17 May 2017 09:46:06 +0900
-Subject: [PATCH] g10: Suppress error for card availability check.
-
-* g10/call-agent.c (start_agent): Add semantics for card; Suppress
-error for card check.
-(warn_version_mismatch): Ignore an error for scdaemon.
-(agent_scd_serialno): Call start_agent with
-FLAG_FOR_CARD_SUPPRESS_ERRORS.
-
---
-
-GnuPG-bug-id: 3165
-Fixes-commit: 97a2394ecafaa6f58e4a1f70ecfd04408dc15606
-Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
----
- g10/call-agent.c | 15 +++++++++------
- 1 file changed, 9 insertions(+), 6 deletions(-)
-
-diff --git a/g10/call-agent.c b/g10/call-agent.c
-index be8c33d74..4698a25a7 100644
---- g10/call-agent.c
-+++ g10/call-agent.c
-@@ -184,7 +184,8 @@ default_inq_cb (void *opaque, const char *line)
-
-
- /* Print a warning if the server's version number is less than our
-- version number. Returns an error code on a connection problem. */
-+ version number. Returns an error code on a connection problem.
-+ Ignore an error for scdaemon (MODE==2). */
- static gpg_error_t
- warn_version_mismatch (assuan_context_t ctx, const char *servername, int mode)
- {
-@@ -193,7 +194,7 @@ warn_version_mismatch (assuan_context_t ctx, const char *servername, int mode)
- const char *myversion = strusage (13);
-
- err = get_assuan_server_version (ctx, mode, &serverversion);
-- if (err)
-+ if (err && mode != 2)
- log_error (_("error getting version from '%s': %s\n"),
- servername, gpg_strerror (err));
- else if (compare_version_strings (serverversion, myversion) < 0)
-@@ -217,10 +218,12 @@ warn_version_mismatch (assuan_context_t ctx, const char *servername, int mode)
- }
-
-
-+#define FLAG_FOR_CARD_SUPPRESS_ERRORS 2
-+
- /* Try to connect to the agent via socket or fork it off and work by
- pipes. Handle the server's initial greeting */
- static int
--start_agent (ctrl_t ctrl, int for_card)
-+start_agent (ctrl_t ctrl, int flag_for_card)
- {
- int rc;
-
-@@ -280,7 +283,7 @@ start_agent (ctrl_t ctrl, int for_card)
- }
- }
-
-- if (!rc && for_card && !did_early_card_test)
-+ if (!rc && flag_for_card && !did_early_card_test)
- {
- /* Request the serial number of the card for an early test. */
- struct agent_card_info_s info;
-@@ -292,7 +295,7 @@ start_agent (ctrl_t ctrl, int for_card)
- rc = assuan_transact (agent_ctx, "SCD SERIALNO openpgp",
- NULL, NULL, NULL, NULL,
- learn_status_cb, &info);
-- if (rc)
-+ if (rc && !(flag_for_card & FLAG_FOR_CARD_SUPPRESS_ERRORS))
- {
- switch (gpg_err_code (rc))
- {
-@@ -1023,7 +1026,7 @@ agent_scd_serialno (char **r_serialno, const char *demand)
- char *serialno = NULL;
- char line[ASSUAN_LINELENGTH];
-
-- err = start_agent (NULL, 1);
-+ err = start_agent (NULL, 1 | FLAG_FOR_CARD_SUPPRESS_ERRORS);
- if (err)
- return err;
-
diff --git a/security/gnupg/pkg-plist b/security/gnupg/pkg-plist
index 0b21bc5cf218..0d0e14e44540 100644
--- a/security/gnupg/pkg-plist
+++ b/security/gnupg/pkg-plist
@@ -23,6 +23,8 @@ man/man1/dirmngr-client.1.gz
man/man1/gpg-agent.1.gz
man/man1/gpg-connect-agent.1.gz
man/man1/gpg-preset-passphrase.1.gz
+man/man1/gpg-wks-client.1.gz
+man/man1/gpg-wks-server.1.gz
man/man1/gpg2.1.gz
man/man1/gpgconf.1.gz
man/man1/gpgparsemail.1.gz