aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-09-28 01:57:38 +0800
committernemysis <nemysis@FreeBSD.org>2013-09-28 01:57:38 +0800
commitfe66a21dc51dc107bae8dbc9640af7124de49c90 (patch)
treeb9f42ae4101fc43cccdf3d060a6ad8ad9dceec75
parent045362ffdee84cf3bf7fdd8cb3c4e0668d32d7cc (diff)
downloadfreebsd-ports-gnome-fe66a21dc51dc107bae8dbc9640af7124de49c90.tar.gz
freebsd-ports-gnome-fe66a21dc51dc107bae8dbc9640af7124de49c90.tar.zst
freebsd-ports-gnome-fe66a21dc51dc107bae8dbc9640af7124de49c90.zip
- Change Makefile header
- Change maintainer email to @FreeBSD.org - Change Desktop entry file - Support STAGEDIR - Mute dir install - Add patch, fix build with Clang Approved by: wg/pawel (mentors)
-rw-r--r--games/twind/Makefile21
-rw-r--r--games/twind/files/patch-twind.c51
2 files changed, 60 insertions, 12 deletions
diff --git a/games/twind/Makefile b/games/twind/Makefile
index bfaa3925fb85..6b6a2b97c59f 100644
--- a/games/twind/Makefile
+++ b/games/twind/Makefile
@@ -1,4 +1,4 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= twind
@@ -7,7 +7,7 @@ PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Match and remove all of the blocks before time runs out
LICENSE= GPLv2
@@ -17,9 +17,8 @@ USE_SDL= sdl image mixer
PORTDOCS= AUTHORS CREDITS ChangeLog NEWS README TODO
DESKTOP_ENTRIES="Twin Distress" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+ "${PORTNAME}" "Game;ArcadeGame;" false
-NO_STAGE= yes
.include <bsd.port.options.mk>
do-build:
@@ -27,15 +26,13 @@ do-build:
-DDATA_PREFIX=\"${DATADIR}/\" -DAUDIO -DLINUX \
-lm `${SDL_CONFIG} --cflags --libs` -lSDL_mixer -lSDL_image twind.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "graphics music sound" ${DATADIR})
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "graphics music sound" ${STAGEDIR}${DATADIR})
- ${INSTALL_DATA} ${WRKSRC}/graphics/${PORTNAME}.png ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/graphics/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/twind/files/patch-twind.c b/games/twind/files/patch-twind.c
new file mode 100644
index 000000000000..9f8c2776e5fe
--- /dev/null
+++ b/games/twind/files/patch-twind.c
@@ -0,0 +1,51 @@
+--- twind.c.orig 2004-07-16 03:44:50.000000000 +0200
++++ twind.c 2013-09-23 12:08:21.000000000 +0200
+@@ -674,10 +674,10 @@
+ if (event.button.x >= MENULX && event.button.x < MENURX && event.button.y >= starty && event.button.y < (starty + height)) {
+ current_menu_high = (event.button.y - starty) / game.font[font].height;
+ /* re-assign current_menu_high if blank option */
+- if (menu_items[game.menu][current_menu_high] == "")
++ if (*menu_items[game.menu][current_menu_high] == '\0')
+ current_menu_high = game.last_menu_high;
+ if (game.last_menu_high != current_menu_high) {
+- if (menu_items[game.menu][current_menu_high] != "") {
++ if (*menu_items[game.menu][current_menu_high] != '\0') {
+ #ifndef NOAUDIO
+ if (game.audio_enabled) Mix_PlayChannel(MENU_OPTION, game.sound[MENU_OPTION], 0);
+ #endif
+@@ -697,7 +697,7 @@
+ if (event.button.x >= MENULX && event.button.x < MENURX && event.button.y >= starty && event.button.y < (starty + height)) {
+ current_menu_high = (event.button.y - starty) / game.font[font].height;
+ /* make sure the option isn't blank */
+- if (menu_items[game.menu][current_menu_high] != "") {
++ if (*menu_items[game.menu][current_menu_high] != '\0') {
+ #ifndef NOAUDIO
+ if (game.audio_enabled) Mix_PlayChannel(OPTION_CHOICE, game.sound[OPTION_CHOICE], 0);
+ #endif
+@@ -917,7 +917,7 @@
+ #endif
+ current_menu_high--;
+ /* if option blank, go to previous */
+- while (menu_items[game.menu][current_menu_high] == "")
++ while (*menu_items[game.menu][current_menu_high] == '\0')
+ current_menu_high--;
+ /* wrap around to the bottom entry */
+ if (current_menu_high == -1)
+@@ -930,7 +930,7 @@
+ #endif
+ current_menu_high++;
+ /* if option blank, go to next */
+- while (menu_items[game.menu][current_menu_high] == "")
++ while (*menu_items[game.menu][current_menu_high] == '\0')
+ current_menu_high++;
+ /* wrap around to the top entry */
+ if (current_menu_high == game.menu_item_cnt)
+@@ -1536,7 +1536,7 @@
+ if (level_time && game.stop_timer + game.added_time < game.best_time)
+ game.best_time = game.stop_timer + game.added_time;
+ /* subtract a set amount of time after level 11 */
+- if (game.current_level > 11)
++ if (game.current_level >= 11)
+ game.level_time -= 10;
+ else
+ game.level_time = times[level_time];