aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-11-23 21:29:57 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-11-23 21:29:57 +0800
commit094ff00be95c6353f8995d81e63a482a9853b715 (patch)
treef4d8c991d9ce9a77232d5018ea757c125b2d1f6e
parent8e0a2ce25fae43054a4e61b108f638610ba2228f (diff)
downloadfreebsd-ports-graphics-094ff00be95c6353f8995d81e63a482a9853b715.tar.gz
freebsd-ports-graphics-094ff00be95c6353f8995d81e63a482a9853b715.tar.zst
freebsd-ports-graphics-094ff00be95c6353f8995d81e63a482a9853b715.zip
- Update to 0.7.6
- Take maintainership PR: 194341, 194711
-rw-r--r--games/pingus/Makefile52
-rw-r--r--games/pingus/distinfo4
-rw-r--r--games/pingus/files/patch-SConscript13
-rw-r--r--games/pingus/files/patch-SConstruct29
-rw-r--r--games/pingus/files/patch-src-editor-editor__screen.hpp11
-rw-r--r--games/pingus/files/patch-src-screenshot.cpp11
-rw-r--r--games/pingus/files/patch-src-tinygettext_iconv.cpp11
-rw-r--r--games/pingus/files/patch-src__pingus__pingus_main.cpp11
-rw-r--r--games/pingus/files/patch-src__pingus__screens__pingus_menu.cpp11
-rw-r--r--games/pingus/files/patch-src__util__file_reader.hpp10
10 files changed, 71 insertions, 92 deletions
diff --git a/games/pingus/Makefile b/games/pingus/Makefile
index cba2f552bb0..e2f6ede5f03 100644
--- a/games/pingus/Makefile
+++ b/games/pingus/Makefile
@@ -2,48 +2,44 @@
# $FreeBSD$
PORTNAME= pingus
-PORTVERSION= 0.7.2
-PORTREVISION= 13
+PORTVERSION= 0.7.6
CATEGORIES= games
-MASTER_SITES= http://pingus.seul.org/files/
+MASTER_SITES= GOOGLE_CODE \
+ http://mirror.amdmi3.ru/distfiles/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Free Lemmings-like game
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
- libboost_regex.so:${PORTSDIR}/devel/boost-libs \
- libphysfs.so:${PORTSDIR}/devel/physfs
+ libboost_signals.so:${PORTSDIR}/devel/boost-libs
-USES= iconv scons tar:bzip2
-MAKE_ARGS= with_linuxusbmouse=0 \
- with_linuxevdev=0
+USES= compiler:c++11-lib iconv scons tar:bzip2
+USE_GL= gl
USE_SDL= sdl image mixer
+LIBS+= ${ICONV_LIB}
+MAKE_ARGS+= LIBS="${LIBS}"
-DESKTOP_ENTRIES="Pingus" "${COMMENT}" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
- "pingus" "" "false"
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+PORTDATA= *
-PLIST= ${WRKDIR}/pkg-plist
+DESKTOP_ENTRIES="Pingus" \
+ "" \
+ "${PORTNAME}" \
+ "${PORTNAME}" \
+ "Game;LogicGame;" \
+ false
post-patch:
- @${REINPLACE_CMD} -e 's|add_path("data")|add_path("${DATADIR}")|g' \
- ${WRKSRC}/src/pingus_main.cpp
-
-pre-install:
- @${RM} -f ${PLIST}
- @${ECHO_CMD} "bin/${PORTNAME}" >> ${PLIST}
- @${ECHO_CMD} "share/pixmaps/${PORTNAME}.ico" >> ${PLIST}
- @cd ${WRKSRC}/data && \
- ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
- ${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
- @${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
+ @${REINPLACE_CMD} -e '/g_path_manager.set_path("data")/ s|data|${DATADIR}|g' \
+ ${WRKSRC}/src/pingus/pingus_main.cpp
+ @${REINPLACE_CMD} -e '/CheckLib.*iconv/ d' ${WRKSRC}/SConscript
do-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC}/data && \
${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/src/win32/icon1.ico \
- ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.ico
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/data/images/icons/pingus-icon.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
.include <bsd.port.mk>
diff --git a/games/pingus/distinfo b/games/pingus/distinfo
index 9bb8ae57ddc..e7d13862883 100644
--- a/games/pingus/distinfo
+++ b/games/pingus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pingus-0.7.2.tar.bz2) = 8d24fbab29ca9401ae1a6a34f7a52eda5de0a9320940e771c6f04f991f5d0052
-SIZE (pingus-0.7.2.tar.bz2) = 11055748
+SHA256 (pingus-0.7.6.tar.bz2) = 759c1253075d1e72691bc1e770b24cdd51917041fd1857c1daf85b65a6686460
+SIZE (pingus-0.7.6.tar.bz2) = 12622268
diff --git a/games/pingus/files/patch-SConscript b/games/pingus/files/patch-SConscript
new file mode 100644
index 00000000000..f025be41ede
--- /dev/null
+++ b/games/pingus/files/patch-SConscript
@@ -0,0 +1,13 @@
+Properly split multiple arguments passed via CXXFLAGS
+--- SConscript.orig 2014-10-17 23:53:30.000000000 +0400
++++ SConscript 2014-10-17 23:53:48.000000000 +0400
+@@ -119,6 +119,9 @@
+ 'CheckSDLLib': CheckSDLLib,
+ 'CheckIconv': CheckIconv,
+ })
++
++ self.env["CXXFLAGS"] = sum(map (lambda x: x.split(" "), self.env["CXXFLAGS"]), [])
++
+ self.fatal_error = ""
+ self.reports = ""
+
diff --git a/games/pingus/files/patch-SConstruct b/games/pingus/files/patch-SConstruct
deleted file mode 100644
index 64416cbaa1f..00000000000
--- a/games/pingus/files/patch-SConstruct
+++ /dev/null
@@ -1,29 +0,0 @@
---- SConstruct 2007-12-21 22:00:22.000000000 -0500
-+++ SConstruct 2007-12-21 22:03:19.000000000 -0500
-@@ -409,7 +409,7 @@
- not (os.path.exists('config.py') and os.path.exists('config.h')) and \
- not GetOption('clean'):
- opts = DefineOptions(None, ARGUMENTS)
-- env = Environment(options = opts)
-+ env = Environment(ENV = os.environ, options = opts)
- Help(opts.GenerateHelpText(env))
-
- opts.Update(env)
-@@ -422,7 +422,8 @@
- if os.environ.has_key('PKG_CONFIG_PATH'):
- env['ENV']['PKG_CONFIG_PATH'] = os.environ['PKG_CONFIG_PATH']
-
-- env['CPPPATH'] += ['.', 'src/']
-+ env['CPPPATH'] = Split(env['CPPPATH'])
-+ env['LIBPATH'] = Split(env['LIBPATH'])
-
- config_h_defines = []
-
-@@ -510,7 +511,6 @@
-
- config_h = open('config.h', 'w')
- config_h.write('#define VERSION "0.7.2"\n')
-- config_h.write('#define ENABLE_BINRELOC 1\n')
- config_h.write('#define ICONV_CONST %s\n' % iconv_const)
- for (v,k) in config_h_defines:
- config_h.write('#define %s %s\n' % (v, k))
diff --git a/games/pingus/files/patch-src-editor-editor__screen.hpp b/games/pingus/files/patch-src-editor-editor__screen.hpp
deleted file mode 100644
index c607fe21ec9..00000000000
--- a/games/pingus/files/patch-src-editor-editor__screen.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/editor/editor_screen.hpp.orig 2007-09-30 20:07:08.000000000 +0400
-+++ src/editor/editor_screen.hpp 2013-08-23 23:08:40.689231327 +0400
-@@ -27,7 +27,7 @@
-
- class DrawingContext;
- class FileDialog;
--class GUI::GUIManager;
-+namespace GUI { class GUIManager; }
- class Pathname;
-
- namespace Editor {
diff --git a/games/pingus/files/patch-src-screenshot.cpp b/games/pingus/files/patch-src-screenshot.cpp
deleted file mode 100644
index 4f6cc17dd13..00000000000
--- a/games/pingus/files/patch-src-screenshot.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/screenshot.cpp.orig 2007-09-30 18:07:08.000000000 +0200
-+++ src/screenshot.cpp 2012-04-29 06:49:26.000000000 +0200
-@@ -159,7 +159,7 @@
- return;
- }
-
-- if (setjmp(png_ptr->jmpbuf))
-+ if (setjmp(png_jmpbuf(png_ptr)))
- {
- // If we get here, we had a problem reading the file
- fclose(fp);
diff --git a/games/pingus/files/patch-src-tinygettext_iconv.cpp b/games/pingus/files/patch-src-tinygettext_iconv.cpp
deleted file mode 100644
index d1017aaa549..00000000000
--- a/games/pingus/files/patch-src-tinygettext_iconv.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tinygettext/iconv.cpp 2007-10-05 11:17:23.000000000 -0500
-+++ src/tinygettext/iconv.cpp 2007-10-05 11:17:35.000000000 -0500
-@@ -78,7 +78,7 @@
- size_t in_size = text.size();
- size_t out_size = 4*in_size; // Worst case scenario: ASCII -> UTF-32?
- std::string result(out_size, ' ');
-- ICONV_CONST char* in_str = &text[0];
-+ const char* in_str = &text[0];
- char* out_str = &result[0];
-
- // Try to convert the text.
diff --git a/games/pingus/files/patch-src__pingus__pingus_main.cpp b/games/pingus/files/patch-src__pingus__pingus_main.cpp
new file mode 100644
index 00000000000..2b6ca5067f6
--- /dev/null
+++ b/games/pingus/files/patch-src__pingus__pingus_main.cpp
@@ -0,0 +1,11 @@
+--- src/pingus/pingus_main.cpp.orig 2011-12-25 01:46:47.000000000 +0400
++++ src/pingus/pingus_main.cpp 2014-10-17 23:57:58.000000000 +0400
+@@ -465,7 +465,7 @@
+ void
+ PingusMain::print_greeting_message()
+ {
+- std::string greeting = "Welcome to Pingus "VERSION;
++ std::string greeting = "Welcome to Pingus " VERSION;
+ greeting += "!";
+ std::cout << greeting << std::endl;
+ for (unsigned int i = 0; i < greeting.length(); ++i)
diff --git a/games/pingus/files/patch-src__pingus__screens__pingus_menu.cpp b/games/pingus/files/patch-src__pingus__screens__pingus_menu.cpp
new file mode 100644
index 00000000000..050e69b36a9
--- /dev/null
+++ b/games/pingus/files/patch-src__pingus__screens__pingus_menu.cpp
@@ -0,0 +1,11 @@
+--- src/pingus/screens/pingus_menu.cpp.orig 2011-12-25 01:46:47.000000000 +0400
++++ src/pingus/screens/pingus_menu.cpp 2014-10-17 23:58:35.000000000 +0400
+@@ -153,7 +153,7 @@
+ gc.get_height()/2 - 280));
+
+ gc.print_left(Fonts::pingus_small, Vector2i(gc.get_width()/2 - 400 + 25, gc.get_height()-140),
+- "Pingus "VERSION" - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
++ "Pingus " VERSION " - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
+ "See the file AUTHORS for a complete list of contributors.\n"
+ "Pingus comes with ABSOLUTELY NO WARRANTY. This is free software, and you are\n"
+ "welcome to redistribute it under certain conditions; see the file COPYING for details.\n");
diff --git a/games/pingus/files/patch-src__util__file_reader.hpp b/games/pingus/files/patch-src__util__file_reader.hpp
new file mode 100644
index 00000000000..1c8e849e694
--- /dev/null
+++ b/games/pingus/files/patch-src__util__file_reader.hpp
@@ -0,0 +1,10 @@
+--- src/util/file_reader.hpp.orig 2011-12-25 01:46:47.000000000 +0400
++++ src/util/file_reader.hpp 2014-10-17 23:56:43.000000000 +0400
+@@ -19,6 +19,7 @@
+
+ #include <memory>
+ #include <vector>
++#include <string>
+
+ class Size;
+ class Color;