aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-08-10 00:26:05 +0800
committersat <sat@FreeBSD.org>2007-08-10 00:26:05 +0800
commit1be77c32043eaf62d611d457fb6b813c8694e7a0 (patch)
tree7db031ad409d107baf73ec746e00fdf1d23e94fb
parent6fcf0e00d68c1e338667a8cb18ef593fdfc89345 (diff)
downloadfreebsd-ports-graphics-1be77c32043eaf62d611d457fb6b813c8694e7a0.tar.gz
freebsd-ports-graphics-1be77c32043eaf62d611d457fb6b813c8694e7a0.tar.zst
freebsd-ports-graphics-1be77c32043eaf62d611d457fb6b813c8694e7a0.zip
- Roll a proper distfile
- Remove unneeded dependency on GTK - Clean up - Conflict with upcoming xsel-conrad - Bump portrevision
-rw-r--r--x11/xsel/Makefile36
-rw-r--r--x11/xsel/distinfo9
-rw-r--r--x11/xsel/pkg-descr1
3 files changed, 22 insertions, 24 deletions
diff --git a/x11/xsel/Makefile b/x11/xsel/Makefile
index 8a09c153b93..40675f576b2 100644
--- a/x11/xsel/Makefile
+++ b/x11/xsel/Makefile
@@ -1,4 +1,3 @@
-# ex:ts=8
# Ports collection makefile for: xsel
# Date created: Jan 14, 2003
# Whom: ijliao
@@ -8,31 +7,32 @@
PORTNAME= xsel
PORTVERSION= 0.04.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11
-MASTER_SITES= http://www.niksula.cs.hut.fi/~vherva/xsel/
-DISTFILES= xsel.c xsel.man
+MASTER_SITES= CENKES
+#http://www.niksula.cs.hut.fi/~vherva/xsel/xsel.{c,man}
MAINTAINER= ports@FreeBSD.org
COMMENT= Access X selection from command line
-EXTRACT_CMD= ${CP}
-EXTRACT_BEFORE_ARGS=
-EXTRACT_AFTER_ARGS= ${WRKDIR}
-USE_XLIB= yes
-USE_GNOME= gtk12
-NO_WRKSUBDIR= yes
-CFLAGS+= `${GTK_CONFIG} --cflags`
-LDFLAGS+= `${GTK_CONFIG} --libs` -lXt -lXaw
-
-MAN1= xsel.1
-PLIST_FILES= bin/xsel
+CONFLICTS= xsel-conrad-[0-9]*
+USE_BZIP2= yes
+USE_XORG= xmu xaw xt xproto xkbfile
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -lXt -lXaw
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= ${PORTNAME}.html
do-build:
- (cd ${WRKSRC} && ${CC} ${CFLAGS} xsel.c -o xsel ${LDFLAGS})
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} xsel.c -o xsel ${LDFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xsel ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/xsel.man ${MAN1PREFIX}/man/man1/xsel.1
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${MAN1PREFIX}/man/man1/${PORTNAME}.1
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
.include <bsd.port.mk>
diff --git a/x11/xsel/distinfo b/x11/xsel/distinfo
index 2206c1a0949..8ad463d253a 100644
--- a/x11/xsel/distinfo
+++ b/x11/xsel/distinfo
@@ -1,6 +1,3 @@
-MD5 (xsel.c) = 8d655ed634d3649cd6b7052a4e28ff9b
-SHA256 (xsel.c) = 599ef12c7b656b6101b41ffc986edfecf7e4d7ceced9aeddb0306c99d0506b79
-SIZE (xsel.c) = 12082
-MD5 (xsel.man) = 976e843b4900e626dd7d966e6723b543
-SHA256 (xsel.man) = d906949f60376cdd783dda6f9bc27a6424be0d30f33cde33ad58d646eccd9de7
-SIZE (xsel.man) = 3795
+MD5 (xsel-0.04.1.tar.bz2) = 79ad31d3fb18583fe51d64f096bc90cc
+SHA256 (xsel-0.04.1.tar.bz2) = c4e13c45e60263c4c749710bd59314b887ef8ed87f505ed0fcd5256d560a0b53
+SIZE (xsel-0.04.1.tar.bz2) = 7335
diff --git a/x11/xsel/pkg-descr b/x11/xsel/pkg-descr
index a28700be1d6..a2a3f1ed002 100644
--- a/x11/xsel/pkg-descr
+++ b/x11/xsel/pkg-descr
@@ -3,3 +3,4 @@ You can paste stuff from the X selection to stdout and copy stuff from stdin
to X selection.
WWW: http://www.niksula.cs.hut.fi/~vherva/xsel/
+Author: Ville Herva <v@iki.fi>