aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-07-04 14:46:28 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-07-04 14:46:28 +0800
commit2a607f37257f21a4a127c309ef8f26fcfccc7fb7 (patch)
tree10fd8ee9e42163e432919bbdef03d2b9bcd2ea2e
parenteb9f3e5fd3dba4b47cdf61cdd2d2ffb9a4a15cd9 (diff)
downloadfreebsd-ports-graphics-2a607f37257f21a4a127c309ef8f26fcfccc7fb7.tar.gz
freebsd-ports-graphics-2a607f37257f21a4a127c309ef8f26fcfccc7fb7.tar.zst
freebsd-ports-graphics-2a607f37257f21a4a127c309ef8f26fcfccc7fb7.zip
- Unbreak this port
- Support STAGEDIR - Remove unnecessary WRKSRC - Update GRASS_INST_DIR - Bump PORTREVISION - Cosmetic change
-rw-r--r--graphics/gdal-grass/Makefile40
-rw-r--r--graphics/gdal-grass/files/patch-Makefile.in14
2 files changed, 30 insertions, 24 deletions
diff --git a/graphics/gdal-grass/Makefile b/graphics/gdal-grass/Makefile
index 5111151c63a..9db4c3052c5 100644
--- a/graphics/gdal-grass/Makefile
+++ b/graphics/gdal-grass/Makefile
@@ -3,40 +3,32 @@
PORTNAME= gdal-grass
PORTVERSION= 1.4.3
-PORTREVISION= 13
+PORTREVISION= 15
CATEGORIES= graphics
MASTER_SITES= http://download.osgeo.org/gdal/
MAINTAINER= ports@FreeBSD.org
COMMENT= GDAL drivers for GRASS raster and vector files
-BROKEN= Fails to configure
+LICENSE= MIT
-BUILD_DEPENDS= grass>6:${PORTSDIR}/databases/grass
-LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal
-RUN_DEPENDS= grass>6:${PORTSDIR}/databases/grass
+BUILD_DEPENDS= grass>=6:${PORTSDIR}/databases/grass
+LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal \
+ libgrass_gis.so:${PORTSDIR}/databases/grass
+RUN_DEPENDS= grass>=6:${PORTSDIR}/databases/grass
-GRASS_INST_DIR= grass-6.4.2
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= gmake
+ALL_TARGET= # empty
+CONFIGURE_ARGS= --with-autoload=${PREFIX}/lib/gdalplugins \
+ --with-gdal=${LOCALBASE}/bin/gdal-config \
+ --with-grass=${LOCALBASE}/${GRASS_INST_DIR}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gdal=${LOCALBASE}/bin/gdal-config \
- --with-grass=${LOCALBASE}/${GRASS_INST_DIR} \
- --with-autoload=${GDAL_AUTOLOAD_DIR}
-ALL_TARGET=
-NO_STAGE= yes
+USE_GCC= yes # from databases/grass
+USES= gmake
-.include <bsd.port.pre.mk>
+GRASS_INST_DIR!=${MAKE} -C ${.CURDIR}/../../databases/grass/ -V GRASS_INST_DIR
pre-install:
- ${MKDIR} ${PREFIX}/share/gdal
-
-.if !defined(GDAL_AUTOLOAD_DIR)
-GDAL_AUTOLOAD_DIR=${PREFIX}/lib/gdalplugins
-.endif
-
-.if !defined (GRASS_INST_DIR)
-GRASS_INST_DIR= grass
-.endif
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/gdalplugins/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/gdal/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/gdal-grass/files/patch-Makefile.in b/graphics/gdal-grass/files/patch-Makefile.in
new file mode 100644
index 00000000000..e3991043378
--- /dev/null
+++ b/graphics/gdal-grass/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig 2007-08-06 05:54:24.000000000 +0800
++++ Makefile.in 2014-07-04 10:44:22.506228799 +0800
+@@ -13,9 +13,9 @@
+
+ LIBS = @LIBS@
+
+-GRASSTABLES_DIR = @prefix@/share/gdal/grass
++GRASSTABLES_DIR = $(DESTDIR)@prefix@/share/gdal/grass
+
+-AUTOLOAD_DIR = @AUTOLOAD_DIR@
++AUTOLOAD_DIR = $(DESTDIR)@AUTOLOAD_DIR@
+
+ GLIBNAME = gdal_GRASS.so
+ OLIBNAME = ogr_GRASS.so