aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-15 23:12:57 +0800
committeradamw <adamw@FreeBSD.org>2014-07-15 23:12:57 +0800
commit4ab945241320d55f3c78a6e7c266811ceacb10d3 (patch)
treeef27f1cef88f7925648306434181155cc05f92d0
parent021d00be099bc1a08e1cbf275a9cb6864228c410 (diff)
downloadfreebsd-ports-graphics-4ab945241320d55f3c78a6e7c266811ceacb10d3.tar.gz
freebsd-ports-graphics-4ab945241320d55f3c78a6e7c266811ceacb10d3.tar.zst
freebsd-ports-graphics-4ab945241320d55f3c78a6e7c266811ceacb10d3.zip
Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.
-rw-r--r--emulators/frodo/Makefile2
-rw-r--r--emulators/kqemu-kmod-devel/Makefile2
-rw-r--r--emulators/kqemu-kmod/Makefile2
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/vice/Makefile2
5 files changed, 7 insertions, 3 deletions
diff --git a/emulators/frodo/Makefile b/emulators/frodo/Makefile
index 9a1db1fe466..350cd240786 100644
--- a/emulators/frodo/Makefile
+++ b/emulators/frodo/Makefile
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
ROM= 1541 Basic Char Kernal
-OPTIONS_DEFINE=SDL
+OPTIONS_DEFINE= SDL DOCS
OPTIONS_DEFAULT=SDL
.include <bsd.port.options.mk>
diff --git a/emulators/kqemu-kmod-devel/Makefile b/emulators/kqemu-kmod-devel/Makefile
index e740c15b361..bca3af9de98 100644
--- a/emulators/kqemu-kmod-devel/Makefile
+++ b/emulators/kqemu-kmod-devel/Makefile
@@ -29,6 +29,8 @@ USE_RC_SUBR= kqemu
USES= kmod gmake uidfix
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
PORTDOCS= kqemu-doc.html kqemu-tech.html
diff --git a/emulators/kqemu-kmod/Makefile b/emulators/kqemu-kmod/Makefile
index 2dc1aaf80bb..e058954ec07 100644
--- a/emulators/kqemu-kmod/Makefile
+++ b/emulators/kqemu-kmod/Makefile
@@ -29,6 +29,8 @@ USE_RC_SUBR= kqemu
USES= kmod gmake uidfix
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
PORTDOCS= kqemu-doc.html kqemu-tech.html
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index babc581c6ac..c93f8a78a06 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -23,7 +23,7 @@ ONLY_FOR_ARCHS= amd64 i386
CONFLICTS= qemu-devel-[0-9]*
OPTIONS_DEFINE= KQEMU RTL8139_TIMER SAMBA SDL GNUTLS CURL PCAP GNS3 \
- CDROM_DMA ADD_AUDIO ALL_TARGETS
+ CDROM_DMA ADD_AUDIO ALL_TARGETS DOCS
KQEMU_DESC= Build with (alpha!) accelerator module
RTL8139_TIMER_DESC= allow use of re(4) nic with FreeBSD guests
SAMBA_DESC= samba dependency (for -smb)
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 5abcf5b7be1..f199502da03 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -64,7 +64,7 @@ FIX_XAW= src/arch/unix/x11/xaw/about.c \
src/arch/unix/x11/xaw/widgets/MultiListP.h \
src/arch/unix/x11/xaw/widgets/ScrList.c \
-OPTIONS_DEFINE= SDL ASOUND PULSE
+OPTIONS_DEFINE= SDL ASOUND PULSE DOCS
OPTIONS_SINGLE= GUI
OPTIONS_SINGLE_GUI= GNOMEUI XAW3D XAW
OPTIONS_DEFAULT?= GNOMEUI SDL