aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-20 03:38:48 +0800
committermarino <marino@FreeBSD.org>2015-03-20 03:38:48 +0800
commit5493ed78ecfb5074d9fa41de884a0d868a1b082b (patch)
treeeb902d4bb3c5d2f6db22635bd56e8cf867a54746
parentf4329bb8b842cb91d2454922bae3819c41ce658f (diff)
downloadfreebsd-ports-graphics-5493ed78ecfb5074d9fa41de884a0d868a1b082b.tar.gz
freebsd-ports-graphics-5493ed78ecfb5074d9fa41de884a0d868a1b082b.tar.zst
freebsd-ports-graphics-5493ed78ecfb5074d9fa41de884a0d868a1b082b.zip
five milter ports: Add or improve support on systems missing sendmail
In some cases no-sendmail support was in place but missing CFLAGS or LDFLAGS, but in others it needed to be added. Problems found as a result of DragonFly removing sendmail from base. Approved by: just fix it.
-rw-r--r--mail/milter-bogom/Makefile7
-rw-r--r--mail/milter-skem/Makefile5
-rw-r--r--mail/opendmarc/Makefile5
-rw-r--r--mail/py-milter/Makefile1
-rw-r--r--security/clamav/Makefile1
5 files changed, 18 insertions, 1 deletions
diff --git a/mail/milter-bogom/Makefile b/mail/milter-bogom/Makefile
index 442f0c6e763..f391e23a5a1 100644
--- a/mail/milter-bogom/Makefile
+++ b/mail/milter-bogom/Makefile
@@ -14,8 +14,13 @@ COMMENT= Simple sendmail milter to interface bogofilter
RUN_DEPENDS= bogofilter:${PORTSDIR}/mail/bogofilter
+.if !exists(/usr/lib/libmilter.so)
+LIB_DEPENDS= libmilter.so:${PORTSDIR}/mail/sendmail
+LDFLAGS+= -I${LOCALBASE}/include
+.endif
+
MAKE_ARGS= CPPFLAGS="-DDEF_CONF=\\\"${PREFIX}/etc/bogom.conf\\\" ${PTHREAD_CFLAGS}" \
- LIBS="-lmilter ${PTHREAD_LIBS}"
+ LIBS="-lmilter ${PTHREAD_LIBS}" LDFLAGS="${LDFLAGS}"
USE_RC_SUBR= milter-bogom
SUB_FILES= pkg-message
diff --git a/mail/milter-skem/Makefile b/mail/milter-skem/Makefile
index 2b57198d773..53e3e5c0454 100644
--- a/mail/milter-skem/Makefile
+++ b/mail/milter-skem/Makefile
@@ -9,6 +9,11 @@ MASTER_SITES= http://virtual-estates.net/skem/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Cache earlier sendmail's verdicts for the relays
+.if !exists( /usr/include/libmilter/mfapi.h )
+BUILD_DEPENDS+= ${LOCALBASE}/include/libmilter/mfapi.h:${PORTSDIR}/mail/sendmail
+CFLAGS+= -I${LOCALBASE}/include
+.endif
+
USES= tar:bzip2 uidfix
PLIST_FILES= sbin/skem \
diff --git a/mail/opendmarc/Makefile b/mail/opendmarc/Makefile
index bcad8d03c91..28c6ee753a2 100644
--- a/mail/opendmarc/Makefile
+++ b/mail/opendmarc/Makefile
@@ -19,6 +19,11 @@ LICENSE_GROUPS_SENDMAIL= FSF OSI
LICENSE_NAME_SENDMAIL= Sendmail Open Source License
LICENSE_PERMS_SENDMAIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+.if !exists( /usr/include/libmilter/mfapi.h )
+BUILD_DEPENDS+= ${LOCALBASE}/include/libmilter/mfapi.h:${PORTSDIR}/mail/sendmail
+CFLAGS+= -I${LOCALBASE}/include
+.endif
+
USES= libtool shebangfix
SHEBANG_FILES= reports/opendmarc-expire.in \
reports/opendmarc-import.in \
diff --git a/mail/py-milter/Makefile b/mail/py-milter/Makefile
index 6dce26b4211..d572b687b53 100644
--- a/mail/py-milter/Makefile
+++ b/mail/py-milter/Makefile
@@ -17,6 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
.if !exists(/usr/lib/libmilter.so)
LIB_DEPENDS= libmilter.so:${PORTSDIR}/mail/sendmail
+CFLAGS+= -I${LOCALBASE}/include
.endif
PYPORTNAME= ${PKGNAMEPREFIX:C/[0-9]+-//}${PORTNAME}
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 03d6cd529d9..604443ee352 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -150,6 +150,7 @@ LDFLAGS+= -lldap
. if !exists(/usr/lib/libmilter.a) || exists(${LOCALBASE}/lib/libmilter.a)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
CONFIGURE_ARGS+=--with-sendmail=${LOCALBASE}/sbin/sendmail
+LDFLAGS+= -L${LOCALBASE}/lib
. else
CONFIGURE_ARGS+=--with-sendmail=/usr/sbin/sendmail
. endif