aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-09-11 05:31:33 +0800
committerantoine <antoine@FreeBSD.org>2013-09-11 05:31:33 +0800
commit67f0c1ae295da5f9c6346b1ceb657dd2f1faf070 (patch)
tree64d1dd939e0e8960c2c5620ed1e135ca08c1fd33
parent8a8f767a247d47f6100b5946d98c7aa7267bf6cc (diff)
downloadfreebsd-ports-graphics-67f0c1ae295da5f9c6346b1ceb657dd2f1faf070.tar.gz
freebsd-ports-graphics-67f0c1ae295da5f9c6346b1ceb657dd2f1faf070.tar.zst
freebsd-ports-graphics-67f0c1ae295da5f9c6346b1ceb657dd2f1faf070.zip
Add an explicit dependency on pkgconf
Approved by: portmgr (bapt)
-rw-r--r--devel/gps/Makefile5
-rw-r--r--editors/gobby/Makefile2
-rw-r--r--finance/grisbi/Makefile3
-rw-r--r--graphics/grafx2/Makefile2
-rw-r--r--graphics/gsculpt/Makefile1
-rw-r--r--mail/gkrellmmailwatch2/Makefile2
-rw-r--r--mail/gmail-notify/Makefile8
-rw-r--r--math/gretl/Makefile3
-rw-r--r--misc/gkrellm-helium/Makefile7
-rw-r--r--misc/gkrellm-xkb/Makefile7
-rw-r--r--misc/gkrellmbgchg2/Makefile1
-rw-r--r--misc/gkrellmlaunch2/Makefile1
-rw-r--r--misc/gkrellshoot2/Makefile1
-rw-r--r--misc/gkrellweather2/Makefile8
-rw-r--r--net/gkrellmwireless2/Makefile8
-rw-r--r--science/gsmc/Makefile8
-rw-r--r--security/gnome-ssh-askpass/Makefile1
-rw-r--r--sysutils/gkrellfire/Makefile8
-rw-r--r--sysutils/gkrellm-trayicons/Makefile7
-rw-r--r--sysutils/gkrelltop/Makefile2
-rw-r--r--www/gnome-web-photo/Makefile10
21 files changed, 31 insertions, 64 deletions
diff --git a/devel/gps/Makefile b/devel/gps/Makefile
index 8d1cd4c9995..a786360bbd0 100644
--- a/devel/gps/Makefile
+++ b/devel/gps/Makefile
@@ -20,11 +20,10 @@ LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
LATEST_LINK= gps-ide
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_BZIP2= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
ALL_TARGET= default
-USES= ada
+USES= ada gmake perl5 pkgconfig
WRKSRC= ${WRKDIR}/gps-release-ide-${PORTVERSION}-src
CONFIGURE_ENV+= AWK=/usr/bin/awk
diff --git a/editors/gobby/Makefile b/editors/gobby/Makefile
index 47a9c93c937..15eed22080a 100644
--- a/editors/gobby/Makefile
+++ b/editors/gobby/Makefile
@@ -20,7 +20,7 @@ OPTIONS_DEFINE= GTKSPELL NLS
GTKSPELL_DESC= Enable GtkSpell support
USE_GNOME= gnomehack gtksourceview2 intltool
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
index 1cb7336ce04..7d484dca549 100644
--- a/finance/grisbi/Makefile
+++ b/finance/grisbi/Makefile
@@ -15,8 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= ofx.5:${PORTSDIR}/finance/libofx
USE_BZIP2= yes
-USES= iconv
-USE_GMAKE= yes
+USES= gmake iconv pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= gtk20 glib20 libxml2
USE_OPENSSL= yes
diff --git a/graphics/grafx2/Makefile b/graphics/grafx2/Makefile
index 2a4b6329c56..d0a22f3ef68 100644
--- a/graphics/grafx2/Makefile
+++ b/graphics/grafx2/Makefile
@@ -14,7 +14,7 @@ COMMENT= Pixelart-oriented bitmap painting program
LIB_DEPENDS= X11:${PORTSDIR}/x11/libX11 \
png15:${PORTSDIR}/graphics/png
-USES= gmake
+USES= gmake pkgconfig
USE_GCC= any
USE_SDL= sdl image
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
index baac57d9fef..635333299dc 100644
--- a/graphics/gsculpt/Makefile
+++ b/graphics/gsculpt/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>0:${PORTSDIR}/graphics/py-opengl \
WRKSRC= ${WRKDIR}/${DISTNAME:S,-src,,}
+USES= pkgconfig
USE_GNOME= pygtk2
USE_GL= glu
USE_XORG= x11
diff --git a/mail/gkrellmmailwatch2/Makefile b/mail/gkrellmmailwatch2/Makefile
index 7adb2d54ef1..cfd2ebc2064 100644
--- a/mail/gkrellmmailwatch2/Makefile
+++ b/mail/gkrellmmailwatch2/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
WRKSRC= ${WRKDIR}/gkrellm-mailwatch
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_LDCONFIG= yes
MAKE_ENV+= PLUGIN_DIR=${PREFIX}/libexec/gkrellm2/plugins
diff --git a/mail/gmail-notify/Makefile b/mail/gmail-notify/Makefile
index 90d577063db..793f340c0bf 100644
--- a/mail/gmail-notify/Makefile
+++ b/mail/gmail-notify/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gmail-notify
-# Date created: 07 June 2005
-# Whom: David
-#
+# Created by: David
# $FreeBSD$
-#
PORTNAME= gmail-notify
PORTVERSION= 1.6.1.1
@@ -18,7 +14,7 @@ BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11-toolkits/py-gnome-extras:extract
USE_GNOME= pygtk2
USE_PYTHON= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
.include <bsd.port.pre.mk>
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 6dcf86cbbb3..79cf59488f0 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -15,9 +15,8 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_FORTRAN= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USES= pathfix
+USES= gmake pathfix pkgconfig
WANT_GNOME= yes
ALL_TARGET= # empty
diff --git a/misc/gkrellm-helium/Makefile b/misc/gkrellm-helium/Makefile
index 9130b361d31..27f063b608b 100644
--- a/misc/gkrellm-helium/Makefile
+++ b/misc/gkrellm-helium/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkrellm-helium
-# Date Created: 19 Apr 2003
-# Whom: Pav Lucistnik <pav@oook.cz>
-#
+# Created by: Pav Lucistnik <pav@oook.cz>
# $FreeBSD$
-#
PORTNAME= gkrellm-helium
PORTVERSION= 2.3.1
@@ -19,6 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkre
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/helium.so
CFLAGS+= -fPIC -I${LOCALBASE}/include
diff --git a/misc/gkrellm-xkb/Makefile b/misc/gkrellm-xkb/Makefile
index 92f20c42e61..83110482771 100644
--- a/misc/gkrellm-xkb/Makefile
+++ b/misc/gkrellm-xkb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkrellm-xkb
-# Date Created: Jun 24 2003
-# Whom: Pav Lucistnik <pav@oook.cz>
-#
+# Created by: Pav Lucistnik <pav@oook.cz>
# $FreeBSD$
-#
PORTNAME= gkrellm-xkb
PORTVERSION= 1.05
@@ -17,6 +13,7 @@ COMMENT= X keyboard layout plugin for GKrellM
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/xkb.so
MAKE_ENV= PLUGIN_DIR=${PREFIX}/libexec/gkrellm2/plugins
ALL_TARGET= xkb.so
diff --git a/misc/gkrellmbgchg2/Makefile b/misc/gkrellmbgchg2/Makefile
index db41a3e3a79..68bb3a46e03 100644
--- a/misc/gkrellmbgchg2/Makefile
+++ b/misc/gkrellmbgchg2/Makefile
@@ -15,6 +15,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
USE_GNOME= gtk20
PLIST_FILES= libexec/gkrellm2/plugins/gkrellmbgchg.so
diff --git a/misc/gkrellmlaunch2/Makefile b/misc/gkrellmlaunch2/Makefile
index 80fccc82036..874e1a91a18 100644
--- a/misc/gkrellmlaunch2/Makefile
+++ b/misc/gkrellmlaunch2/Makefile
@@ -14,6 +14,7 @@ COMMENT= Application launcher plugin for GKrellM2
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/gkrellmlaunch.so
ALL_TARGET= ${PORTNAME}.so
diff --git a/misc/gkrellshoot2/Makefile b/misc/gkrellshoot2/Makefile
index 6ab4cc7b3c0..5111de43062 100644
--- a/misc/gkrellshoot2/Makefile
+++ b/misc/gkrellshoot2/Makefile
@@ -15,6 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkre
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
import:${PORTSDIR}/graphics/ImageMagick
+USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/gkrellshoot.so
WRKSRC= ${WRKDIR}/gkrellShoot-${PORTVERSION}
diff --git a/misc/gkrellweather2/Makefile b/misc/gkrellweather2/Makefile
index 68c57aea617..14c579d2535 100644
--- a/misc/gkrellweather2/Makefile
+++ b/misc/gkrellweather2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkrellweather2
-# Date Created: 24 Nov 2002
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= gkrellweather
PORTVERSION= 2.0.7
@@ -18,7 +14,7 @@ COMMENT= GKrellWeather is a weather plugin for GKrellM
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
-USE_GMAKE= yes
+USES= gmake pkgconfig
ALL_TARGET= gkrellweather.so
MAKE_ENV= enable_nls=1 PTHREAD_LIBS=${PTHREAD_LIBS}
diff --git a/net/gkrellmwireless2/Makefile b/net/gkrellmwireless2/Makefile
index 52cb8f78243..54b9ffd2f89 100644
--- a/net/gkrellmwireless2/Makefile
+++ b/net/gkrellmwireless2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkrellm-wireless
-# Date Created: 17 Mar 2003
-# Whom: KT Sin <ktsin@acm.org>
-#
+# Created by: KT Sin <ktsin@acm.org>
# $FreeBSD$
-#
PORTNAME= gkrellmwireless
PORTVERSION= 2.0.2
@@ -20,6 +16,6 @@ RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
WRKSRC= ${WRKDIR}/gkrellmwireless
USE_XORG= x11
-USE_GMAKE= yes
+USES= gmake pkgconfig
.include <bsd.port.mk>
diff --git a/science/gsmc/Makefile b/science/gsmc/Makefile
index ee7ef302da0..e77a1dfaba8 100644
--- a/science/gsmc/Makefile
+++ b/science/gsmc/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: gsmc
-# Date created: 11 February 2006
-# Whom: db
-#
+# Created by: db
# $FreeBSD$
-#
PORTNAME= gsmc
PORTVERSION= 1.1
@@ -18,7 +14,7 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_AUTOTOOLS= aclocal automake autoconf
AUTOMAKE_ARGS= -i --add-missing --foreign --copy
diff --git a/security/gnome-ssh-askpass/Makefile b/security/gnome-ssh-askpass/Makefile
index c5898823e66..7934f378dd0 100644
--- a/security/gnome-ssh-askpass/Makefile
+++ b/security/gnome-ssh-askpass/Makefile
@@ -18,6 +18,7 @@ BUILD_WRKSRC= ${WRKSRC}/contrib
ALL_TARGET= gnome-ssh-askpass2
PLIST_FILES= bin/gnome-ssh-askpass2
+USES= pkgconfig
USE_GNOME= gtk20
.include <bsd.port.pre.mk>
diff --git a/sysutils/gkrellfire/Makefile b/sysutils/gkrellfire/Makefile
index d500a991f8c..235fd0c52f2 100644
--- a/sysutils/gkrellfire/Makefile
+++ b/sysutils/gkrellfire/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkrellfire
-# Date created: 2004-07-16
-# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
-#
+# Created by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
# $FreeBSD$
-#
PORTNAME= gkrellfire
PORTVERSION= 0.4.2
@@ -21,7 +17,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkre
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
PLIST_FILES= libexec/gkrellm2/plugins/${PORTNAME}.so
-USE_GMAKE= yes
+USES= gmake pkgconfig
MAKE_ARGS= CC="${CC}"
do-install:
diff --git a/sysutils/gkrellm-trayicons/Makefile b/sysutils/gkrellm-trayicons/Makefile
index f3aebd2bfc6..8e0722c8815 100644
--- a/sysutils/gkrellm-trayicons/Makefile
+++ b/sysutils/gkrellm-trayicons/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkrellm-trayicons
-# Date created: Wed Jun 23 14:55:49 CEST 2004
-# Whom: Tobias Roth <ports@fsck.ch>
-#
+# Created by: Tobias Roth <ports@fsck.ch>
# $FreeBSD$
-#
PORTNAME= trayicons
PORTVERSION= 1.03
@@ -19,6 +15,7 @@ COMMENT= GKrellM2 plugin to display definable icons as notifiers or launchers
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/trayicons.so
ALL_TARGET= trayicons.so
diff --git a/sysutils/gkrelltop/Makefile b/sysutils/gkrelltop/Makefile
index 395b100a176..bcea56c4ecd 100644
--- a/sysutils/gkrelltop/Makefile
+++ b/sysutils/gkrelltop/Makefile
@@ -13,7 +13,7 @@ COMMENT= Plugin for gkrellm 2.x shows top three processes, requires procfs
RUN_DEPENDS= gkrellmd:${PORTSDIR}/sysutils/gkrellm2
BUILD_DEPENDS:= ${RUN_DEPENDS}
-USES= gmake
+USES= gmake pkgconfig
MAKE_ARGS= INSTALLDIR=${LOCALBASE}/libexec/gkrellm2/plugins \
INSTALLDIRD=${PREFIX}/libexec/gkrellm2/plugins-gkrellmd
diff --git a/www/gnome-web-photo/Makefile b/www/gnome-web-photo/Makefile
index fe2c815728e..969bc3d5a1e 100644
--- a/www/gnome-web-photo/Makefile
+++ b/www/gnome-web-photo/Makefile
@@ -1,11 +1,6 @@
-# New ports collection makefile for: gnome-web-photo
-# Date created: 2005-11-30
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/www/gnome-web-photo/Makefile,v 1.5 2007/08/07 03:27:32 mezz Exp $
-#
-#
PORTNAME= gnome-web-photo
PORTVERSION= 0.10.3
@@ -23,8 +18,7 @@ LIB_DEPENDS= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
USE_XZ= yes
USE_GNOME= gconf2 gnomehack gnomeprefix
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules \
--with-gtk=2.0