aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-10-12 19:51:51 +0800
committerhq <hq@FreeBSD.org>2005-10-12 19:51:51 +0800
commit74e3d29e12d20467da71758b9b37e3d663e9a6a8 (patch)
tree8a8a62a91eade560acfe99d79b99dceee668afee
parent119908d8564e4e6b20d8388ae05846bf1aff06b8 (diff)
downloadfreebsd-ports-graphics-74e3d29e12d20467da71758b9b37e3d663e9a6a8.tar.gz
freebsd-ports-graphics-74e3d29e12d20467da71758b9b37e3d663e9a6a8.tar.zst
freebsd-ports-graphics-74e3d29e12d20467da71758b9b37e3d663e9a6a8.zip
The Servlet API
Java Servlet technology provides Web developers with a simple, consistent mechanism for extending the functionality of a Web server and for accessing existing business systems. A servlet can almost be thought of as an applet that runs on the server side -- without a face. Java servlets make many Web applications possible. WWW: http://java.sun.com/products/servlet/
-rw-r--r--www/Makefile1
-rw-r--r--www/servlet-api/Makefile27
-rw-r--r--www/servlet-api/distinfo2
-rw-r--r--www/servlet-api/pkg-descr9
4 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5e56e41f73b..7ce83f83514 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -764,6 +764,7 @@
SUBDIR += screem
SUBDIR += script4rss
SUBDIR += selenium
+ SUBDIR += servlet-api
SUBDIR += shttpd
SUBDIR += sidplug
SUBDIR += simplog
diff --git a/www/servlet-api/Makefile b/www/servlet-api/Makefile
new file mode 100644
index 00000000000..c7c97c5d43a
--- /dev/null
+++ b/www/servlet-api/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Servlet API
+# Date created: October 13, 2005
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= servlet-api
+PORTVERSION= 2.4
+CATEGORIES= www java
+MASTER_SITES= http://www.ibiblio.org/maven/servletapi/jars/
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY= # empty
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= The Servlet API (JSR-168)
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+do-install:
+ ${INSTALL_DATA} ${_DISTDIR}/${DISTFILES} ${JAVAJARDIR}/${PORTNAME}.jar
+
+.include <bsd.port.mk>
diff --git a/www/servlet-api/distinfo b/www/servlet-api/distinfo
new file mode 100644
index 00000000000..404947df1bd
--- /dev/null
+++ b/www/servlet-api/distinfo
@@ -0,0 +1,2 @@
+MD5 (servlet-api-2.4.jar) = f6cf3fde0b992589ed3d87fa9674015f
+SIZE (servlet-api-2.4.jar) = 97693
diff --git a/www/servlet-api/pkg-descr b/www/servlet-api/pkg-descr
new file mode 100644
index 00000000000..91b722e9b31
--- /dev/null
+++ b/www/servlet-api/pkg-descr
@@ -0,0 +1,9 @@
+The Servlet API
+
+Java Servlet technology provides Web developers with a simple, consistent
+mechanism for extending the functionality of a Web server and for accessing
+existing business systems. A servlet can almost be thought of as an applet that
+runs on the server side -- without a face. Java servlets make many Web
+applications possible.
+
+WWW: http://java.sun.com/products/servlet/