aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-12-10 06:53:34 +0800
committermarino <marino@FreeBSD.org>2016-12-10 06:53:34 +0800
commit8c6284398b8628155164a0ff7149aa8fa8d27a4e (patch)
tree624dd96a49e4dd5311ec8f5d96957e1101c30626
parenta41250f018ed4e2fc117ff5275a2183ffb0e690c (diff)
downloadfreebsd-ports-graphics-8c6284398b8628155164a0ff7149aa8fa8d27a4e.tar.gz
freebsd-ports-graphics-8c6284398b8628155164a0ff7149aa8fa8d27a4e.tar.zst
freebsd-ports-graphics-8c6284398b8628155164a0ff7149aa8fa8d27a4e.zip
ports-mgmt/portal: Support ports ncurses and honor FLAGS
Approved by: general and ncurses blankets
-rw-r--r--ports-mgmt/portal/Makefile2
-rw-r--r--ports-mgmt/portal/files/patch-Makefile11
2 files changed, 13 insertions, 0 deletions
diff --git a/ports-mgmt/portal/Makefile b/ports-mgmt/portal/Makefile
index 6d20dc9d661..07cb336c468 100644
--- a/ports-mgmt/portal/Makefile
+++ b/ports-mgmt/portal/Makefile
@@ -19,6 +19,8 @@ USE_GITHUB= yes
GH_ACCOUNT= culot
USES= ncurses compiler:c++11-lib
+CFLAGS+= -I${NCURSESINC}
+LDFLAGS+= -L${NCURSESLIB}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/ports-mgmt/portal/files/patch-Makefile b/ports-mgmt/portal/files/patch-Makefile
new file mode 100644
index 00000000000..cfe6972e7b2
--- /dev/null
+++ b/ports-mgmt/portal/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2016-12-03 18:56:16 UTC
++++ Makefile
+@@ -24,7 +24,7 @@ DEFS= -DVERSION=${VERSION}
+ all: ${PROG}
+
+ ${PROG}: ${OBJS}
+- ${CC} ${CXXFLAGS} -o ${.TARGET} ${OBJS} ${LDADD}
++ ${CC} ${CXXFLAGS} -o ${.TARGET} ${OBJS} ${LDFLAGS} ${LDADD}
+
+ .cc.o:
+ ${CC} ${CXXFLAGS} ${CPPFLAGS} ${DEFS} -c ${.IMPSRC}