aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-07-11 02:16:17 +0800
committerrakuco <rakuco@FreeBSD.org>2016-07-11 02:16:17 +0800
commit9762fdab97af40557954ea1e74302620d92de5d8 (patch)
tree5033f74cc19f632526aa2994fe63cacef5fec8f4
parent4cfa4bc84d7fd811583e0b627b65fd0f49abd33f (diff)
downloadfreebsd-ports-graphics-9762fdab97af40557954ea1e74302620d92de5d8.tar.gz
freebsd-ports-graphics-9762fdab97af40557954ea1e74302620d92de5d8.tar.zst
freebsd-ports-graphics-9762fdab97af40557954ea1e74302620d92de5d8.zip
Add missing dependencies to pass `make stage-qa'.
Error: /usr/local/bin/qtcreator is linked to /usr/local/lib/.mesa/libGL.so from graphics/libGL but it is not declared as a dependency Warning: you need USE_GL+=gl Error: /usr/local/lib/qtcreator/plugins/libCore.so is linked to /usr/local/lib/libQt5Help.so.5 from devel/qt5-help but it is not declared as a dependency Warning: you need USE_QT5+=help Error: /usr/local/lib/qtcreator/plugins/libCore.so is linked to /usr/local/lib/libQt5PrintSupport.so.5 from print/qt5-printsupport but it is not declared as a dependency Warning: you need USE_QT5+=printsupport MFH: 2016Q3
-rw-r--r--devel/qtcreator/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index aa908c1e4b0..48147303f9d 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qtcreator
DISTVERSION= 4.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= QT/official_releases/qtcreator/${DISTVERSION:R}/${DISTVERSION}
DISTNAME= qt-creator-opensource-src-${DISTVERSION}
@@ -18,9 +18,10 @@ RUN_DEPENDS= qbs:devel/qbs
USE_LDCONFIG= ${LOCALBASE}/lib/${PORTNAME}
USES= qmake compiler:c++11-lib
-USE_QT5= buildtools concurrent core declarative designer gui linguist \
- network qdoc qml quick quickcontrols script script sql svg \
- webkit widgets xml xmlpatterns
+USE_GL= gl
+USE_QT5= buildtools concurrent core declarative designer gui help \
+ linguist network printsupport qdoc qml quick quickcontrols \
+ script script sql svg webkit widgets xml xmlpatterns
# be paranoid and do not extract qbs (devel/qbs) copy from source tree
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/src/shared/qbs'