aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-11-30 18:05:01 +0800
committerjbeich <jbeich@FreeBSD.org>2015-11-30 18:05:01 +0800
commita0c4f6f29073175c526269c85555dbd9282168a7 (patch)
tree53ec2570bd5acbf27ec732ba6e94342330a9bf24
parent4ed54b4bcbc49cd90434e75775d899786bc4c68e (diff)
downloadfreebsd-ports-graphics-a0c4f6f29073175c526269c85555dbd9282168a7.tar.gz
freebsd-ports-graphics-a0c4f6f29073175c526269c85555dbd9282168a7.tar.zst
freebsd-ports-graphics-a0c4f6f29073175c526269c85555dbd9282168a7.zip
mail/mpop: update to 1.2.3
- Add CPE information - Let pkg-config handle flags for WITH_OPENSSL_PORT in order to - Make sure ld(1) finds correct library - Avoid -I/usr/include -L/usr/lib poisoning ports compiler - Convert the patch to sed(1) line in order to - Respect LOCALBASE for ca_root_nss paths - Apply the fix against INFO page as well - Avoid having to pet portlint with |make makepatch| - Simplify GNUTLS=off + OPENSSL=off logic - Simplify GSASL option a bit more - Take maintainership Changes: http://sourceforge.net/p/mpop/code/ci/e3eff0/log/
-rw-r--r--mail/mpop/Makefile32
-rw-r--r--mail/mpop/distinfo4
-rw-r--r--mail/mpop/files/patch-doc-mpop.133
3 files changed, 19 insertions, 50 deletions
diff --git a/mail/mpop/Makefile b/mail/mpop/Makefile
index adc4ac79285..0246781cc51 100644
--- a/mail/mpop/Makefile
+++ b/mail/mpop/Makefile
@@ -2,18 +2,19 @@
# $FreeBSD$
PORTNAME= mpop
-DISTVERSION= 1.2.2
+DISTVERSION= 1.2.3
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jbeich@FreeBSD.org
COMMENT= Small and fast POP3 client
LICENSE= GPLv3 # (or later)
-USES= gmake pkgconfig tar:xz
+USES= cpe gmake pkgconfig tar:xz
+CPE_VENDOR= martin_lambers
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules
+CONFIGURE_ARGS= --disable-silent-rules --with-tls=no
INFO= mpop
@@ -25,9 +26,9 @@ OPTIONS_SUB= yes
GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
GNUTLS_CONFIGURE_ON= --with-tls=gnutls
-GSASL_DESC= SASL authentication support via GNU SASL
+GSASL_DESC= ${SASL_DESC} via GNU SASL
GSASL_LIB_DEPENDS= libgsasl.so:${PORTSDIR}/security/gsasl
-GSASL_CONFIGURE_OFF= --without-libgsasl
+GSASL_CONFIGURE_WITH= libgsasl
IDN_LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
IDN_CONFIGURE_WITH= libidn
LIBSECRET_DESC= GNOME password management
@@ -36,14 +37,15 @@ LIBSECRET_CONFIGURE_WITH= libsecret
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
OPENSSL_USE= openssl=yes
-OPENSSL_CONFIGURE_ON= --with-tls=openssl \
- libssl_CFLAGS=-I${OPENSSLINC} \
- libssl_LIBS="-lssl -lcrypto"
-
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MGNUTLS) && empty(PORT_OPTIONS:MOPENSSL)
-CONFIGURE_ARGS+= --with-tls=no
-.endif
+OPENSSL_CONFIGURE_ENV= ${OPENSSLINC:M/usr/include:C,.+,libssl_CFLAGS=" ",} \
+ ${OPENSSLLIB:M/usr/lib:C,.+,libssl_LIBS="-lssl -lcrypto",}
+OPENSSL_CONFIGURE_ON= --with-tls=openssl
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's/Debian/${OPSYS}/' \
+ -e 's,/etc/ssl/certs,${LOCALBASE}/share/certs,' \
+ -e '/crt/s/ca(\\?)-certificates/ca\1-root\1-nss/' \
+ -e 's/ca\\?-certificates/ca_root_nss/' \
+ ${WRKSRC}/doc/mpop*
.include <bsd.port.mk>
diff --git a/mail/mpop/distinfo b/mail/mpop/distinfo
index 9257eada1c8..b3b536dc6ed 100644
--- a/mail/mpop/distinfo
+++ b/mail/mpop/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mpop-1.2.2.tar.xz) = d1e7d7d18147996cfc6195cdfb936ca51620cb841a7460043d8cc838ca48bfc3
-SIZE (mpop-1.2.2.tar.xz) = 266272
+SHA256 (mpop-1.2.3.tar.xz) = ed770af29b291291f643e1d132bb1bdae6b2f897cd9c09372d7aadf85290ed70
+SIZE (mpop-1.2.3.tar.xz) = 268584
diff --git a/mail/mpop/files/patch-doc-mpop.1 b/mail/mpop/files/patch-doc-mpop.1
deleted file mode 100644
index 75539ed7ef8..00000000000
--- a/mail/mpop/files/patch-doc-mpop.1
+++ /dev/null
@@ -1,33 +0,0 @@
---- doc/mpop.1.orig 2009-10-05 16:47:15.000000000 -0300
-+++ doc/mpop.1 2009-10-24 12:18:19.000000000 -0200
-@@ -305,8 +305,8 @@ intermediate CAs.)
- .br
- The list of trusted CAs is specified using the \fBtls_trust_file\fP command.
- Usually there is some system-wide default file available, e.g.
--/etc/ssl/certs/ca\-certificates.crt on Debian-based systems, but you can
--also choose to select the trusted CAs yourself.
-+/usr/local/share/certs/ca\-root\-nss.crt on FreeBSD and DragonFly systems,
-+but you can also choose to select the trusted CAs yourself.
- .br
- One practical problem with this approach is that the client program should also
- check if the server certificate has been revoked for some reason, using a
-@@ -350,8 +350,8 @@ or tunnel the session through TLS (\fIof
- .IP "tls_trust_file \fIfile\fP"
- Activate server certificate verification using a list of truted Certification
- Authorities (CAs). The file must be in PEM format. Some systems provide a
--system-wide default file, e.g. /etc/ssl/certs/ca\-certificates.crt on
--Debian-based systems with the ca\-certificates package.
-+system-wide default file, e.g. /usr/local/share/certs/ca\-root\-nss.crt on
-+FreeBSD and DragonFly with ca_root_nss package or security/ca_root_nss port.
- An empty argument disables this. You should also use \fBtls_crl_file\fP.
- .IP "tls_crl_file [\fIfile\fP]"
- Set a certificate revocation list (CRL) file for TLS, to check for revoked
-@@ -542,7 +542,7 @@ tls on
- .br
- # as in this example, or download the root certificate of your CA and use that.
- .br
--tls_trust_file /etc/ssl/certs/ca\-certificates.crt
-+tls_trust_file /usr/local/share/certs/ca\-root\-nss.crt
- .br
-
- .br