aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2016-10-31 15:00:10 +0800
committerjhale <jhale@FreeBSD.org>2016-10-31 15:00:10 +0800
commitbc31f21c817ae778eb404125aef72266ffe8ebcc (patch)
tree1f59405947a8d708fa58f505ee8862750aba9755
parentaef6e1fa5d7e499fb7084d887cea956b9177fffb (diff)
downloadfreebsd-ports-graphics-bc31f21c817ae778eb404125aef72266ffe8ebcc.tar.gz
freebsd-ports-graphics-bc31f21c817ae778eb404125aef72266ffe8ebcc.tar.zst
freebsd-ports-graphics-bc31f21c817ae778eb404125aef72266ffe8ebcc.zip
Fix build for 9.x i386
Quarterly branch has a different version, but suffers from the same error, so the fix should be backported. videoframe.o: In function `VideoFrame::VideoFrame(unsigned long long, AVFrame*, QRect, int, bool)': videoframe.cpp:(.text+0x19db): undefined reference to `__atomic_fetch_add_8' camerasource.o: In function `CameraSource::CameraSource()': camerasource.cpp:(.text+0x327): undefined reference to `__atomic_fetch_add_8' corevideosource.o: In function `CoreVideoSource::CoreVideoSource()': corevideosource.cpp:(.text+0x121): undefined reference to `__atomic_fetch_add_8' collect2: error: ld returned 1 exit status gmake: *** [Makefile:793: qtox] Error 1 PR: 213841 Submitted by: <matthew@reztek.cz> Approved by: <yuri@rawbw.com> (maintainer) MFH: 2016Q4
-rw-r--r--net-im/qTox/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-im/qTox/Makefile b/net-im/qTox/Makefile
index cacf2dff318..528dfd913f9 100644
--- a/net-im/qTox/Makefile
+++ b/net-im/qTox/Makefile
@@ -24,8 +24,6 @@ LIB_DEPENDS= libtoxcore.so:net-im/tox \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-BROKEN_FreeBSD_9_i386= does not build
-
USE_GITHUB= yes
GH_ACCOUNT= tux3
@@ -47,6 +45,13 @@ PLIST_FILES= bin/qtox \
PLIST_FILES+= share/icons/hicolor/${SZ}/apps/qtox.png
.endfor
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == "gcc" && ${ARCH} == i386 && !${CFLAGS:M-march=*}
+# Needed for __atomic_fetch_add_8
+CFLAGS+= -march=i586
+.endif
+
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "Warning: qTox won't build if the option NaCl was selected for Tox!"
@@ -75,4 +80,4 @@ post-install:
${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}/apps/qtox.png
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>