aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-03-27 19:48:45 +0800
committermarino <marino@FreeBSD.org>2014-03-27 19:48:45 +0800
commitececb2bd81f890655e9d6d95ccefcb42888cd5cc (patch)
treeabb53ac3dc92834f3ec6859a721f6e47bea8f573
parenta17f44ef8d3300a5713bfb209f870117f7d6093a (diff)
downloadfreebsd-ports-graphics-ececb2bd81f890655e9d6d95ccefcb42888cd5cc.tar.gz
freebsd-ports-graphics-ececb2bd81f890655e9d6d95ccefcb42888cd5cc.tar.zst
freebsd-ports-graphics-ececb2bd81f890655e9d6d95ccefcb42888cd5cc.zip
www/ocsigen: Update from version 1.1.0 -> 2.2.0 (Unbreaks port)
I started with the PR, but it required heavy modification. It was very out of date after several ports infrastructure changes and updates to its dependencies. Luckily the pkgsrc version also maintained by Jaap was up to date, especially the required patches. The docs generation seems to be broken so it's been inhibited for now. PR: ports/176117 Submitted by: Jaap Boender Stage support: Taken from pkgsrc
-rw-r--r--www/ocsigen/Makefile105
-rw-r--r--www/ocsigen/distinfo4
-rw-r--r--www/ocsigen/files/patch-Makefile112
-rw-r--r--www/ocsigen/files/patch-Makefile.options13
-rw-r--r--www/ocsigen/files/patch-src_Makefile13
-rw-r--r--www/ocsigen/files/patch-src_baselib_Makefile13
-rw-r--r--www/ocsigen/files/patch-src_extensions13
-rw-r--r--www/ocsigen/files/patch-src_http_Makefile13
-rw-r--r--www/ocsigen/pkg-plist98
9 files changed, 229 insertions, 155 deletions
diff --git a/www/ocsigen/Makefile b/www/ocsigen/Makefile
index bbc8490bc4b..7b9828144e7 100644
--- a/www/ocsigen/Makefile
+++ b/www/ocsigen/Makefile
@@ -2,41 +2,52 @@
# $FreeBSD$
PORTNAME= ocsigen
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 2.2.0
CATEGORIES= www
-MASTER_SITES= http://www.ocsigen.org/download/
+MASTER_SITES= http://ocsigen.org/download/
+DISTNAME= ocsigenserver-${PORTVERSION}
MAINTAINER= jaapb@kerguelen.org
COMMENT= Web programming framework for OCaml
-BROKEN= Does not build
+LICENSE= LGPL21_SSLEX
+LICENSE_NAME= Lesser GPL 2.1 with a special OpenSSL exception clause
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BUILD_DEPENDS= ocaml-net>=2:${PORTSDIR}/www/ocaml-net \
+BUILD_DEPENDS= ${SA_DIR}/react/react.a:${PORTSDIR}/devel/ocaml-react \
${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl \
- ${SA_DIR}/lwt/lwt.a:${PORTSDIR}/devel/ocaml-lwt \
- ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
-RUN_DEPENDS= ocaml-net>=2:${PORTSDIR}/www/ocaml-net \
- ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl \
- ${SA_DIR}/lwt/lwt.a:${PORTSDIR}/devel/ocaml-lwt \
- ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
+ ocaml-net>=3:${PORTSDIR}/www/ocaml-net \
+ ocaml-lwt>=2.4.2:${PORTSDIR}/devel/ocaml-lwt \
+ ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre \
+ ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit \
+ ${SA_DIR}/text/text.a:${PORTSDIR}/textproc/ocaml-text \
+ ocaml-tyxml>=2.2.0:${PORTSDIR}/textproc/ocaml-tyxml
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAMLFIND_PLIST= yes
USE_OCAML_LDCONFIG= yes
+OCAML_PKGDIRS= ocsigenserver
+OCAML_LDLIBS= ${OCAML_PKGDIRS:S/^/${OCAML_SITELIBDIR}\//}
+MAKE_JOBS_UNSAFE= yes
-SA_DIR= ${PREFIX}/${OCAML_SITELIBDIR}
+SA_DIR= ${PREFIX}/${OCAML_SITELIBDIR}
-OPTIONS_DEFINE= SQLITE CAMLZIP
-OPTIONS_DEFAULT= CAMLZIP
-CAMLZIP_DESC= Use camlzip for compression
+OPTIONS_DEFINE= CAMLZIP
+OPTIONS_MULTI= DB
+OPTIONS_MULTI_DB= SQLITE DBM
+OPTIONS_DEFAULT= CAMLZIP SQLITE
+OPTIONS_SUB= yes
+SQLITE_DESC= Use sqlite as a database backend
+DBM_DESC= Use dbm as a database backend
+CAMLZIP_DESC= Use camlzip for compression
USES= gmake
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --name ${PORTNAME} \
- --disable-nativecode \
- --disable-debug \
+CONFIGURE_ARGS= --disable-debug \
+ --temproot ${STAGEDIR} \
+ --enable-natdynlink \
--ocsigen-user ${WWWOWN} \
--ocsigen-group ${WWWGRP} \
--bindir ${PREFIX}/bin \
@@ -44,45 +55,35 @@ CONFIGURE_ARGS= --name ${PORTNAME} \
--libdir ${SA_DIR} \
--docdir ${DOCSDIR} \
--sysconfdir ${PREFIX}/etc \
+ --datadir ${PREFIX}/var/ocsigen \
--staticpagesdir ${PREFIX}/share/ocsigen/www \
- --uploaddir /tmp \
- --disable-ocamlduce
+ --uploaddir /tmp
+
+ALL_TARGET= all
+INSTALL_TARGET= install
-ALL_TARGET= depend all
-INSTALL_TARGET= installnodoc
+SQLITE_CONFIGURE_WITH= sqlite
+SQLITE_BUILD_DEPENDS= ${SA_DIR}/sqlite3/sqlite3.a:${PORTSDIR}/databases/ocaml-sqlite3
+SQLITE_RUN_DEPENDS= ${SA_DIR}/sqlite3/sqlite3.a:${PORTSDIR}/databases/ocaml-sqlite3
-MAN1= ocsigen.1
+DBM_CONFIGURE_WITH= dbm
+DBM_BUILD_DEPENDS= ${LOCALBASE}/lib/ocaml/dbm.a:${PORTSDIR}/databases/ocaml-dbm
+DBM_RUN_DEPENDS= ${LOCALBASE}/lib/ocaml/dbm.a:${PORTSDIR}/databases/ocaml-dbm
+
+CAMLZIP_CONFIGURE_WITH= camlzip
+CAMLZIP_BUILD_DEPENDS= ocaml-zip>=1.03_2:${PORTSDIR}/archivers/ocaml-zip
+CAMLZIP_RUN_DEPENDS= ocaml-zip>=1.03_2:${PORTSDIR}/archivers/ocaml-zip
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-INSTALL_TARGET+= docinstall
-PORTDOCS= *
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE}
-BUILD_DEPENDS+= ${SA_DIR}/sqlite3/sqlite3.a:${PORTSDIR}/databases/ocaml-sqlite3
-RUN_DEPENDS+= ${SA_DIR}/sqlite3/sqlite3.a:${PORTSDIR}/databases/ocaml-sqlite3
-CONFIGURE_ARGS+= --enable-sqlite
-PLIST_FILES+= lib/ocsigen/extensions/ocsipersist-sqlite.cma
-.else
-CONFIGURE_ARGS+= --disable-sqlite
-.endif
-
-.if ${PORT_OPTIONS:MCAMLZIP}
-CONFIGURE_ARGS+= --enable-camlzip
-BUILD_DEPENDS+= ocaml-zip>=1.03_2:${PORTSDIR}/archivers/ocaml-zip
-RUN_DEPENDS+= ocaml-zip>=1.03_2:${PORTSDIR}/archivers/ocaml-zip
-PLIST_FILES+= lib/ocsigen/extensions/deflatemod.cmo
-.else
-CONFIGURE_ARGS+= --disable-camlzip
-.endif
-
-post-install:
- @if [ ! -f ${PREFIX}/etc/${PORTNAME}/ocsigen.conf ]; then \
- ${CP} -p ${PREFIX}/etc/${PORTNAME}/ocsigen.conf.sample \
- ${PREFIX}/etc/${PORTNAME}/ocsigen.conf; \
- fi
+# Docs fail with some kind of Netstring-pcre error, wasn't able to fix it
+#.if ${PORT_OPTIONS:MDOCS}
+#ALL_TARGET+= doc
+#INSTALL_TARGET+=install.doc
+#PORTDOCS= *
+#.endif
+
+do-configure:
+ @(cd ${WRKSRC} && ${SH} configure ${CONFIGURE_ARGS})
.include <bsd.port.mk>
diff --git a/www/ocsigen/distinfo b/www/ocsigen/distinfo
index 1e4f60f5072..bc7583cf5a1 100644
--- a/www/ocsigen/distinfo
+++ b/www/ocsigen/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ocsigen-1.1.0.tar.gz) = 9cad514c1162eaee8a48de0acb58c061eca8777fdc0eed0538ebd09f844ebcd2
-SIZE (ocsigen-1.1.0.tar.gz) = 683710
+SHA256 (ocsigenserver-2.2.0.tar.gz) = 21d4d08dd00550647fc08cef214c0a651574671ee3542b7445f76b8234de1f68
+SIZE (ocsigenserver-2.2.0.tar.gz) = 1259122
diff --git a/www/ocsigen/files/patch-Makefile b/www/ocsigen/files/patch-Makefile
index 2858690086f..55d838d5dce 100644
--- a/www/ocsigen/files/patch-Makefile
+++ b/www/ocsigen/files/patch-Makefile
@@ -1,40 +1,74 @@
---- Makefile.orig 2008-07-01 13:50:21.000000000 +0200
-+++ Makefile 2008-07-08 11:25:25.000000000 +0200
-@@ -284,7 +284,6 @@
+--- Makefile.orig 2012-12-07 16:17:09.000000000 +0100
++++ Makefile
+@@ -67,61 +67,33 @@
- installnodoc: partialinstall
- mkdir -p $(TEMPROOT)$(CONFIGDIR)
-- mkdir -p $(TEMPROOT)$(CONFIGDIR)/conf.d
- mkdir -p $(TEMPROOT)$(STATICPAGESDIR)
- mkdir -p $(TEMPROOT)$(STATICPAGESDIR)/miniwiki
- mkdir -p $(TEMPROOT)$(STATICPAGESDIR)/tutorial
-@@ -295,7 +294,6 @@
- [ -p $(TEMPROOT)$(COMMANDPIPE) ] || { mkfifo $(TEMPROOT)$(COMMANDPIPE); \
- chmod 660 $(TEMPROOT)$(COMMANDPIPE); \
- $(CHOWN) -R $(OCSIGENUSER):$(OCSIGENGROUP) $(TEMPROOT)$(COMMANDPIPE);}
--# -mv $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.old
- cat files/ocsigen.conf.in \
- | sed s%_LOGDIR_%$(LOGDIR)%g \
- | sed s%_STATICPAGESDIR_%$(STATICPAGESDIR)%g \
-@@ -318,21 +316,10 @@
- | sed s%[.]cmo%.cmxs%g \
- | sed s%[.]cma%.cmxs%g \
- > $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.opt.sample
-- -mv $(TEMPROOT)$(CONFIGDIR)/mime.types $(TEMPROOT)$(CONFIGDIR)/mime.types.old
- cp -f files/mime.types $(TEMPROOT)$(CONFIGDIR)
- mkdir -p $(TEMPROOT)$(LOGDIR)
- chmod u+rwx $(TEMPROOT)$(LOGDIR)
-- chmod a+rx $(TEMPROOT)$(CONFIGDIR)
-- chmod a+rx $(TEMPROOT)$(CONFIGDIR)/conf.d
-- [ -f $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf ] || \
-- { cp $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.sample \
-- $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf; \
-- chmod a+r $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf; }
- chmod a+r $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.sample
-- [ -f $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf ] || \
-- { cp $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.opt.sample \
-- $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.opt; \
-- chmod a+r $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.opt; }
- chmod a+r $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.opt.sample
- chmod a+r $(TEMPROOT)$(CONFIGDIR)/mime.types
- $(INSTALL) -m 644 files/tutorial/style.css $(TEMPROOT)$(STATICPAGESDIR)/tutorial
+ # BB If install is not run by root but OCSIGENUSER, OCSIGENGROUP is somebody
+ # BB different, make files universally accessible, we cannot chown.
+-INSTALL_CAN_PUT_PERMISSIONS=yes
++INSTALL_CAN_PUT_PERMISSIONS=no
+ INSTALL_USER_GROUP=-o $(OCSIGENUSER) -g $(OCSIGENGROUP)
+ INSTALL_MOD_660=660
+ INSTALL_MOD_644=644
+ INSTALL_MOD_755=755
+ INSTALL_MOD_770=770
+ INSTALL_MOD_750=750
+-ifneq ($(shell id -u), 0)
+- ifneq ($(OCSIGENUSER), $(USERNAME))
+- INSTALL_CAN_PUT_PERMISSIONS=no
+- endif
+- ifneq ($(shell groups ${USERNAME}|grep -q ${OCSIGENGROUP}; echo $$?), 0)
+- INSTALL_CAN_PUT_PERMISSIONS=no
+- endif
+-endif
+-ifeq ($(INSTALL_CAN_PUT_PERMISSIONS), no)
+- INSTALL_USER_GROUP=
+- INSTALL_MOD_660=666
+- INSTALL_MOD_644=666
+- INSTALL_MOD_755=777
+- INSTALL_MOD_770=777
+- INSTALL_MOD_750=777
+-endif
+
+ install.files:
+ @echo INSTALL_CAN_PUT_PERMISSIONS: ${INSTALL_CAN_PUT_PERMISSIONS}
+- ## Command pipe
+- $(INSTALL) -m ${INSTALL_MOD_755} -d $(dir $(TEMPROOT)$(COMMANDPIPE))
+- [ -p $(TEMPROOT)$(COMMANDPIPE) ] || \
+- { mkfifo -m ${INSTALL_MOD_660} $(TEMPROOT)$(COMMANDPIPE); \
+- if [ "${INSTALL_CAN_PUT_PERMISSIONS}" = yes ]; \
+- then $(CHOWN) -R $(OCSIGENUSER):$(OCSIGENGROUP) $(TEMPROOT)$(COMMANDPIPE); \
+- fi; }
+ ## Configuration files
+- $(INSTALL) -m ${INSTALL_MOD_755} -d $(TEMPROOT)$(CONFIGDIR)/conf.d
+- ${INSTALL} -m ${INSTALL_MOD_644} ${PROJECTNAME}.conf.sample $(TEMPROOT)$(CONFIGDIR)/
+- [ -f $(TEMPROOT)$(CONFIGDIR)/$(PROJECTNAME).conf ] || \
+- { $(INSTALL) -m ${INSTALL_MOD_644} $(PROJECTNAME).conf.sample \
+- $(TEMPROOT)$(CONFIGDIR)/$(PROJECTNAME).conf; }
++ ${BSD_INSTALL_DATA} ${PROJECTNAME}.conf.sample $(TEMPROOT)$(CONFIGDIR)/
+ -mv $(TEMPROOT)$(CONFIGDIR)/mime.types $(TEMPROOT)$(CONFIGDIR)/mime.types.old
+ ## Log directory
+- $(INSTALL) -m ${INSTALL_MOD_644} src/files/mime.types $(TEMPROOT)$(CONFIGDIR)
+- $(INSTALL) -d -m ${INSTALL_MOD_755} ${INSTALL_USER_GROUP} $(TEMPROOT)$(LOGDIR)
++ $(BSD_INSTALL_DATA) src/files/mime.types $(TEMPROOT)$(CONFIGDIR)
+ ## Static files
+- $(INSTALL) -d -m ${INSTALL_MOD_755} ${INSTALL_USER_GROUP} $(TEMPROOT)$(STATICPAGESDIR)
+- $(INSTALL) -d -m ${INSTALL_MOD_750} ${INSTALL_USER_GROUP} $(TEMPROOT)$(DATADIR)
+- $(INSTALL) -m ${INSTALL_MOD_644} ${INSTALL_USER_GROUP} \
++ $(BSD_INSTALL_DATA) -d $(TEMPROOT)$(STATICPAGESDIR)
++ $(BSD_INSTALL_DATA) -d $(TEMPROOT)$(DATADIR)
++ $(BSD_INSTALL_DATA) \
+ local/var/www/*.html $(TEMPROOT)$(STATICPAGESDIR)
+- $(INSTALL) -d -m ${INSTALL_MOD_755} ${INSTALL_USER_GROUP} \
++ $(BSD_INSTALL_DATA) -d \
+ $(TEMPROOT)$(STATICPAGESDIR)/ocsigenstuff
+- $(INSTALL) -m ${INSTALL_MOD_644} ${INSTALL_USER_GROUP} \
++ $(BSD_INSTALL_DATA) \
+ local/var/www/ocsigenstuff/*.png local/var/www/ocsigenstuff/*.css \
+ $(TEMPROOT)$(STATICPAGESDIR)/ocsigenstuff
+- $(INSTALL) -d -m ${INSTALL_MOD_755} $(TEMPROOT)$(MANDIR)
+- $(INSTALL) -m ${INSTALL_MOD_644} src/files/${PROJECTNAME}.1 $(TEMPROOT)$(MANDIR)
++ $(BSD_INSTALL_MAN) -d $(TEMPROOT)$(MANDIR)
++ $(BSD_INSTALL_MAN) src/files/${PROJECTNAME}.1 $(TEMPROOT)$(MANDIR)
+
+ uninstall:
+ -make -C doc uninstall
diff --git a/www/ocsigen/files/patch-Makefile.options b/www/ocsigen/files/patch-Makefile.options
new file mode 100644
index 00000000000..d429cbb927e
--- /dev/null
+++ b/www/ocsigen/files/patch-Makefile.options
@@ -0,0 +1,13 @@
+$NetBSD: patch-Makefile.options,v 1.1 2013/06/11 14:56:06 jaapb Exp $
+
+Add netstring-pcre package, no longer provided by netstring by default
+--- Makefile.options.orig 2012-12-07 15:17:09.000000000 +0000
++++ Makefile.options
+@@ -34,6 +34,7 @@ BASE_PACKAGE := lwt
+ SERVER_PACKAGE := lwt.ssl \
+ ${LWT_EXTRA_PACKAGE} \
+ netstring \
++ netstring-pcre \
+ findlib \
+ cryptokit \
+ tyxml \
diff --git a/www/ocsigen/files/patch-src_Makefile b/www/ocsigen/files/patch-src_Makefile
new file mode 100644
index 00000000000..1ef9606afeb
--- /dev/null
+++ b/www/ocsigen/files/patch-src_Makefile
@@ -0,0 +1,13 @@
+$NetBSD: patch-src_Makefile,v 1.2 2012/12/15 11:16:07 jaapb Exp $
+
+Proper support of ocamlfind in pkgsrc
+--- src/Makefile.orig 2012-12-07 15:17:09.000000000 +0000
++++ src/Makefile
+@@ -119,6 +119,7 @@ raw_install:
+ $(OCAMLFIND) install $(PROJECTNAME) \
+ -destdir $(TEMPROOT)$(LIBDIR) \
+ -patch-version ${VERSION} \
++ -ldconf ignore \
+ ${INTF} $(INSTALL_IMPL) $(DOC) files/META
+ # Extensions
+ $(INSTALL) -m 755 -d $(TEMPROOT)${LIBDIR}/${PROJECTNAME}/extensions/
diff --git a/www/ocsigen/files/patch-src_baselib_Makefile b/www/ocsigen/files/patch-src_baselib_Makefile
new file mode 100644
index 00000000000..fad7dcd532a
--- /dev/null
+++ b/www/ocsigen/files/patch-src_baselib_Makefile
@@ -0,0 +1,13 @@
+$NetBSD: patch-src_baselib_Makefile,v 1.1 2013/06/11 14:56:06 jaapb Exp $
+
+Add netstring-pcre package, no longer provided by netstring by default
+--- src/baselib/Makefile.orig 2012-12-07 15:17:09.000000000 +0000
++++ src/baselib/Makefile
+@@ -1,6 +1,6 @@
+ include ../../Makefile.config
+
+-LIBS := -package lwt.unix,netstring,cryptokit,findlib,tyxml,lwt.syntax,${LWT_EXTRA_PACKAGE}
++LIBS := -package lwt.unix,netstring,netstring-pcre,cryptokit,findlib,tyxml,lwt.syntax,${LWT_EXTRA_PACKAGE}
+ OCAMLC := $(OCAMLFIND) ocamlc${BYTEDBG} ${THREAD}
+ OCAMLOPT := $(OCAMLFIND) ocamlopt ${OPTDBG} ${THREAD}
+ OCAMLDOC := $(OCAMLFIND) ocamldoc
diff --git a/www/ocsigen/files/patch-src_extensions b/www/ocsigen/files/patch-src_extensions
new file mode 100644
index 00000000000..c24123ee6ea
--- /dev/null
+++ b/www/ocsigen/files/patch-src_extensions
@@ -0,0 +1,13 @@
+$NetBSD: patch-src_extensions_Makefile,v 1.1 2013/06/11 14:56:06 jaapb Exp $
+
+Add netstring-pcre package, no longer provided by netstring by default
+--- src/extensions/Makefile.orig 2012-12-07 15:17:09.000000000 +0000
++++ src/extensions/Makefile
+@@ -4,6 +4,7 @@ PACKAGE := lwt.unix \
+ lwt.ssl \
+ lwt.react \
+ netstring \
++ netstring-pcre \
+ tyxml.parser \
+
+ LIBS := -I ../baselib -I ../http -I ../server ${addprefix -package ,${PACKAGE}}
diff --git a/www/ocsigen/files/patch-src_http_Makefile b/www/ocsigen/files/patch-src_http_Makefile
new file mode 100644
index 00000000000..c0c6fb2188f
--- /dev/null
+++ b/www/ocsigen/files/patch-src_http_Makefile
@@ -0,0 +1,13 @@
+$NetBSD: patch-src_http_Makefile,v 1.1 2013/06/11 14:56:06 jaapb Exp $
+
+Add netstring-pcre package, no longer provided by netstring by default
+--- src/http/Makefile.orig 2012-12-07 15:17:09.000000000 +0000
++++ src/http/Makefile
+@@ -1,6 +1,6 @@
+ include ../../Makefile.config
+
+-LIBS := -package netstring,lwt.ssl,tyxml -I ../baselib
++LIBS := -package netstring,netstring-pcre,lwt.ssl,tyxml -I ../baselib
+ OCAMLC := $(OCAMLFIND) ocamlc${BYTEDBG}
+ OCAMLOPT := $(OCAMLFIND) ocamlopt ${OPTDBG}
+ OCAMLDOC := $(OCAMLFIND) ocamldoc
diff --git a/www/ocsigen/pkg-plist b/www/ocsigen/pkg-plist
index 8616155f929..a839b797249 100644
--- a/www/ocsigen/pkg-plist
+++ b/www/ocsigen/pkg-plist
@@ -1,64 +1,38 @@
-bin/ocsigen
-etc/ocsigen/mime.types
-etc/ocsigen/ocsigen.conf
-etc/ocsigen/ocsigen.conf.sample
-etc/ocsigen/ocsigen.conf.opt.sample
-lib/ocsigen/METAS/META.eliom_examples
-lib/ocsigen/METAS/META.ocsigen_ext
-lib/ocsigen/examples/miniwiki.cmo
-lib/ocsigen/examples/monitoring.cmo
-lib/ocsigen/examples/tutoeliom.cmi
-lib/ocsigen/examples/tutoeliom.cmo
-lib/ocsigen/extensions/accesscontrol.cmo
-lib/ocsigen/extensions/authbasic.cmo
-lib/ocsigen/extensions/cgimod.cmo
-lib/ocsigen/extensions/eliom.cma
-lib/ocsigen/extensions/ocsidbm
-lib/ocsigen/extensions/ocsipersist-dbm.cma
-lib/ocsigen/extensions/outputfilter.cmo
-lib/ocsigen/extensions/redirectmod.cmo
-lib/ocsigen/extensions/revproxy.cmo
-lib/ocsigen/extensions/staticmod.cmo
-lib/ocsigen/extensions/userconf.cmo
-share/ocsigen/www/ocsigen/miniwiki/style.css
-share/ocsigen/www/ocsigen/ocsigenstuff/LICENSE
-share/ocsigen/www/ocsigen/ocsigenstuff/back.png
-share/ocsigen/www/ocsigen/ocsigenstuff/cdimage.png
-share/ocsigen/www/ocsigen/ocsigenstuff/deb.png
-share/ocsigen/www/ocsigen/ocsigenstuff/dvi.png
-share/ocsigen/www/ocsigen/ocsigenstuff/folder_open.png
-share/ocsigen/www/ocsigen/ocsigenstuff/html.png
-share/ocsigen/www/ocsigen/ocsigenstuff/image.png
-share/ocsigen/www/ocsigen/ocsigenstuff/ocsigen5.png
-share/ocsigen/www/ocsigen/ocsigenstuff/pdf.png
-share/ocsigen/www/ocsigen/ocsigenstuff/postscript.png
-share/ocsigen/www/ocsigen/ocsigenstuff/readme.png
-share/ocsigen/www/ocsigen/ocsigenstuff/rpm.png
-share/ocsigen/www/ocsigen/ocsigenstuff/sound.png
-share/ocsigen/www/ocsigen/ocsigenstuff/source_c.png
-share/ocsigen/www/ocsigen/ocsigenstuff/source_java.png
-share/ocsigen/www/ocsigen/ocsigenstuff/source_pl.png
-share/ocsigen/www/ocsigen/ocsigenstuff/source_py.png
-share/ocsigen/www/ocsigen/ocsigenstuff/style.css
-share/ocsigen/www/ocsigen/ocsigenstuff/tar.png
-share/ocsigen/www/ocsigen/ocsigenstuff/tex.png
-share/ocsigen/www/ocsigen/ocsigenstuff/tgz.png
-share/ocsigen/www/ocsigen/ocsigenstuff/txt.png
-share/ocsigen/www/ocsigen/ocsigenstuff/unknown.png
-share/ocsigen/www/ocsigen/ocsigenstuff/video.png
-share/ocsigen/www/ocsigen/tutorial/bulles-bleues.png
-share/ocsigen/www/ocsigen/tutorial/ocsigen5.png
-share/ocsigen/www/ocsigen/tutorial/style.css
-@dirrm share/ocsigen/www/ocsigen/miniwiki
-@dirrm share/ocsigen/www/ocsigen/ocsigenstuff
-@dirrm share/ocsigen/www/ocsigen/tutorial
-@dirrm share/ocsigen/www/ocsigen
+bin/ocsigenserver
+bin/ocsigenserver.opt
+@unexec if cmp -s %D/etc/ocsigenserver.conf.sample %D/etc/ocsigenserver.conf; then rm -f %D/etc/ocsigenserver.conf; fi
+etc/ocsigenserver.conf.sample
+@exec if [ ! -f %D/etc/ocsigenserver.conf ] ; then cp -p %D/%F %B/ocsigenserver.conf; fi
+etc/mime.types
+man/man1/ocsigenserver.1.gz
+share/ocsigen/www/index.html
+share/ocsigen/www/ocsigenstuff/back.png
+share/ocsigen/www/ocsigenstuff/cdimage.png
+share/ocsigen/www/ocsigenstuff/deb.png
+share/ocsigen/www/ocsigenstuff/dvi.png
+share/ocsigen/www/ocsigenstuff/folder_open.png
+share/ocsigen/www/ocsigenstuff/html.png
+share/ocsigen/www/ocsigenstuff/image.png
+share/ocsigen/www/ocsigenstuff/ocsigen5.png
+share/ocsigen/www/ocsigenstuff/pdf.png
+share/ocsigen/www/ocsigenstuff/postscript.png
+share/ocsigen/www/ocsigenstuff/readme.png
+share/ocsigen/www/ocsigenstuff/rpm.png
+share/ocsigen/www/ocsigenstuff/sound.png
+share/ocsigen/www/ocsigenstuff/source_c.png
+share/ocsigen/www/ocsigenstuff/source_java.png
+share/ocsigen/www/ocsigenstuff/source_pl.png
+share/ocsigen/www/ocsigenstuff/source_py.png
+share/ocsigen/www/ocsigenstuff/tar.png
+share/ocsigen/www/ocsigenstuff/tex.png
+share/ocsigen/www/ocsigenstuff/tgz.png
+share/ocsigen/www/ocsigenstuff/txt.png
+share/ocsigen/www/ocsigenstuff/unknown.png
+share/ocsigen/www/ocsigenstuff/video.png
+share/ocsigen/www/ocsigenstuff/style.css
+@dirrm %%OCAML_SITELIBDIR%%/ocsigenserver/extensions
+@dirrm share/ocsigen/www/ocsigenstuff
@dirrm share/ocsigen/www
@dirrm share/ocsigen
-@dirrm lib/ocsigen/METAS
-@dirrm lib/ocsigen/examples
-@dirrm lib/ocsigen/extensions
-@dirrm lib/ocsigen
-@dirrm etc/ocsigen
-@unexec if cmp -s %D/etc/${PORTNAME}/ocsigen.conf.sample %D/etc/${PORTNAME}/ocsigen.conf; then rm -f %D/etc/${PORTNAME}/ocsigen.conf; fi
-@exec if [ ! -f %D/etc/${PORTNAME}/ocsigen.conf ] ; then cp -p %D/%F %B/${PORTNAME}/ocsigen.conf; fi
+@dirrmtry var/ocsigen
+@dirrmtry var