aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-06-04 02:56:39 +0800
committerfjoe <fjoe@FreeBSD.org>2003-06-04 02:56:39 +0800
commited8b45a5857263cf82894ce9d136948da0b810b8 (patch)
tree9e2082fbd3af1e4f1d67edab236604f1a7ba9495
parent56f4fcb170f0faabbd407122a1a3334b78425826 (diff)
downloadfreebsd-ports-graphics-ed8b45a5857263cf82894ce9d136948da0b810b8.tar.gz
freebsd-ports-graphics-ed8b45a5857263cf82894ce9d136948da0b810b8.tar.zst
freebsd-ports-graphics-ed8b45a5857263cf82894ce9d136948da0b810b8.zip
New port: fprobe
Fprobe is a tool that collects network traffic data. Submitted by: Kirill Ponomarew
-rw-r--r--net-mgmt/fprobe/Makefile37
-rw-r--r--net-mgmt/fprobe/distinfo1
-rw-r--r--net-mgmt/fprobe/pkg-descr5
-rw-r--r--net-mgmt/fprobe/pkg-plist4
-rw-r--r--net/Makefile1
-rw-r--r--net/fprobe/Makefile37
-rw-r--r--net/fprobe/distinfo1
-rw-r--r--net/fprobe/pkg-descr5
-rw-r--r--net/fprobe/pkg-plist4
9 files changed, 95 insertions, 0 deletions
diff --git a/net-mgmt/fprobe/Makefile b/net-mgmt/fprobe/Makefile
new file mode 100644
index 00000000000..754206427c0
--- /dev/null
+++ b/net-mgmt/fprobe/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: fprobe
+# Date created: 03.06.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fprobe
+PORTVERSION= 1.0.p5
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/.pre/}
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Tool that collects network traffic data
+
+MAN1= fprobe.1
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ChangeLog README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/fprobe/distinfo b/net-mgmt/fprobe/distinfo
new file mode 100644
index 00000000000..ebd3da40f73
--- /dev/null
+++ b/net-mgmt/fprobe/distinfo
@@ -0,0 +1 @@
+MD5 (fprobe-1.0.pre5.tar.bz2) = 835f6a46c6824ec77bfe9771c8ad8c49
diff --git a/net-mgmt/fprobe/pkg-descr b/net-mgmt/fprobe/pkg-descr
new file mode 100644
index 00000000000..1bf05cb6344
--- /dev/null
+++ b/net-mgmt/fprobe/pkg-descr
@@ -0,0 +1,5 @@
+fprobe: a NetFlow probe - libpcap-based tool that collects
+network traffic data and emit it as NetFlow flows towards the
+specified collector.
+
+WWW: http://fprobe.sourceforge.net
diff --git a/net-mgmt/fprobe/pkg-plist b/net-mgmt/fprobe/pkg-plist
new file mode 100644
index 00000000000..ff327e8246d
--- /dev/null
+++ b/net-mgmt/fprobe/pkg-plist
@@ -0,0 +1,4 @@
+bin/fprobe
+%%PORTDOCS%%share/doc/fprobe/ChangeLog
+%%PORTDOCS%%share/doc/fprobe/README
+@dirrm share/doc/fprobe
diff --git a/net/Makefile b/net/Makefile
index 4ca3493eb50..89f2865bb11 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -149,6 +149,7 @@
SUBDIR += flowscan
SUBDIR += forg
SUBDIR += fping
+ SUBDIR += fprobe
SUBDIR += freebsd-uucp
SUBDIR += freenet
SUBDIR += freenet6
diff --git a/net/fprobe/Makefile b/net/fprobe/Makefile
new file mode 100644
index 00000000000..754206427c0
--- /dev/null
+++ b/net/fprobe/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: fprobe
+# Date created: 03.06.2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fprobe
+PORTVERSION= 1.0.p5
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/.pre/}
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Tool that collects network traffic data
+
+MAN1= fprobe.1
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ChangeLog README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/fprobe/distinfo b/net/fprobe/distinfo
new file mode 100644
index 00000000000..ebd3da40f73
--- /dev/null
+++ b/net/fprobe/distinfo
@@ -0,0 +1 @@
+MD5 (fprobe-1.0.pre5.tar.bz2) = 835f6a46c6824ec77bfe9771c8ad8c49
diff --git a/net/fprobe/pkg-descr b/net/fprobe/pkg-descr
new file mode 100644
index 00000000000..1bf05cb6344
--- /dev/null
+++ b/net/fprobe/pkg-descr
@@ -0,0 +1,5 @@
+fprobe: a NetFlow probe - libpcap-based tool that collects
+network traffic data and emit it as NetFlow flows towards the
+specified collector.
+
+WWW: http://fprobe.sourceforge.net
diff --git a/net/fprobe/pkg-plist b/net/fprobe/pkg-plist
new file mode 100644
index 00000000000..ff327e8246d
--- /dev/null
+++ b/net/fprobe/pkg-plist
@@ -0,0 +1,4 @@
+bin/fprobe
+%%PORTDOCS%%share/doc/fprobe/ChangeLog
+%%PORTDOCS%%share/doc/fprobe/README
+@dirrm share/doc/fprobe