aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbofh <bofh@FreeBSD.org>2015-04-11 19:39:35 +0800
committerbofh <bofh@FreeBSD.org>2015-04-11 19:39:35 +0800
commitf91538fb2943c6ee7ec2e100d5e13cc8caf39243 (patch)
treec4597411ab71144868e785379edbfb861b88c1ae
parentaaa1134117b02b66c12909a10c6b00fcfb57bffb (diff)
downloadfreebsd-ports-graphics-f91538fb2943c6ee7ec2e100d5e13cc8caf39243.tar.gz
freebsd-ports-graphics-f91538fb2943c6ee7ec2e100d5e13cc8caf39243.tar.zst
freebsd-ports-graphics-f91538fb2943c6ee7ec2e100d5e13cc8caf39243.zip
[NEW] lang/c: Tool to compile and run C programs like a shell script
Tool to compile and run C programs like a shell script. WWW: https://www.github.com/ryanmjacobs/c PR: 198365 Submitted by: neel@neelc.org
-rw-r--r--lang/Makefile1
-rw-r--r--lang/c/Makefile26
-rw-r--r--lang/c/distinfo2
-rw-r--r--lang/c/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index c0b29c1e95c..d0ce6d089af 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -22,6 +22,7 @@
SUBDIR += bigloo
SUBDIR += bsh
SUBDIR += bwbasic
+ SUBDIR += c
SUBDIR += ccl
SUBDIR += cdent
SUBDIR += cduce
diff --git a/lang/c/Makefile b/lang/c/Makefile
new file mode 100644
index 00000000000..4b9f1be1b6b
--- /dev/null
+++ b/lang/c/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= c
+PORTVERSION= 0.10
+CATEGORIES= lang
+
+MAINTAINER= neel@neelc.org
+COMMENT= Tool to compile and run C programs like a shell script
+
+LICENSE= MIT
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_GITHUB= yes
+GH_ACCOUNT= ryanmjacobs
+GH_TAGNAME= v${PORTVERSION}
+NO_BUILD= yes
+
+SHEBANG_FILES= c
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/lang/c/distinfo b/lang/c/distinfo
new file mode 100644
index 00000000000..ab94be1d75d
--- /dev/null
+++ b/lang/c/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ryanmjacobs-c-0.10-v0.10_GH0.tar.gz) = 958a2c2b2392b905cf39d75a3007adb47a818815a8485ca2170b4214233f6b14
+SIZE (ryanmjacobs-c-0.10-v0.10_GH0.tar.gz) = 16759
diff --git a/lang/c/pkg-descr b/lang/c/pkg-descr
new file mode 100644
index 00000000000..c4beb0de7e4
--- /dev/null
+++ b/lang/c/pkg-descr
@@ -0,0 +1,3 @@
+Tool to compile and run C programs like a shell script.
+
+WWW: https://www.github.com/ryanmjacobs/c