aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-07 18:29:17 +0800
committertijl <tijl@FreeBSD.org>2014-07-07 18:29:17 +0800
commitfd5efd3690b860eade91d9666d3d6fe2174e6d48 (patch)
tree2dca66588cd14d6caac3253bd4de2fc37a2b480e
parent944210dc9d7f1dc4a6a4753a848a25391d979d71 (diff)
downloadfreebsd-ports-graphics-fd5efd3690b860eade91d9666d3d6fe2174e6d48.tar.gz
freebsd-ports-graphics-fd5efd3690b860eade91d9666d3d6fe2174e6d48.tar.zst
freebsd-ports-graphics-fd5efd3690b860eade91d9666d3d6fe2174e6d48.zip
- Convert security/nessus-* to USES=libtool and bump dependent ports
- Use @sample in security/nessus
-rw-r--r--security/nessus-libnasl/Makefile7
-rw-r--r--security/nessus-libnasl/files/patch-libtool25
-rw-r--r--security/nessus-libnasl/files/patch-nasl-Makefile11
-rw-r--r--security/nessus-libnasl/pkg-plist4
-rw-r--r--security/nessus-libraries/Makefile8
-rw-r--r--security/nessus-libraries/files/patch-ab12
-rw-r--r--security/nessus-libraries/files/patch-libtool146
-rw-r--r--security/nessus-libraries/pkg-plist12
-rw-r--r--security/nessus-plugins/Makefile5
-rw-r--r--security/nessus/Makefile6
-rw-r--r--security/nessus/pkg-plist8
11 files changed, 34 insertions, 210 deletions
diff --git a/security/nessus-libnasl/Makefile b/security/nessus-libnasl/Makefile
index 8077c0689f6..77e5362b7ef 100644
--- a/security/nessus-libnasl/Makefile
+++ b/security/nessus-libnasl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nessus-libnasl
PORTVERSION= 2.2.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ftp://ftp.nessus.org/pub/nessus/nessus-${PORTVERSION}/src/ \
ftp://ftp.gwdg.de/pub/linux/misc/nessus/nessus-${PORTVERSION}/src/ \
@@ -20,10 +20,9 @@ LICENSE= GPLv2
LIB_DEPENDS= libnessus.so:${PORTSDIR}/security/nessus-libraries
-WRKSRC= ${WRKDIR}/libnasl
-USE_AUTOTOOLS= libtool
-USES= bison
GNU_CONFIGURE= yes
+USES= bison libtool
USE_LDCONFIG= YES
+WRKSRC= ${WRKDIR}/libnasl
.include <bsd.port.mk>
diff --git a/security/nessus-libnasl/files/patch-libtool b/security/nessus-libnasl/files/patch-libtool
deleted file mode 100644
index bf833f83d89..00000000000
--- a/security/nessus-libnasl/files/patch-libtool
+++ /dev/null
@@ -1,25 +0,0 @@
---- nasl/Makefile.orig 2005-02-10 17:03:51.000000000 +0100
-+++ nasl/Makefile 2012-01-29 10:29:13.000000000 +0100
-@@ -88,10 +88,11 @@
- nasl_server.c \
- nasl_debug.c
-
--COMPILE = $(LIBTOOL) $(CC) $(CFLAGS) $(NESSUS_INCLUDE)
-+COMPILE = $(LIBTOOL) --mode compile $(CC) $(CFLAGS) $(NESSUS_INCLUDE)
-+LINK = $(LIBTOOL) --mode link $(CC) $(CFLAGS) $(NESSUS_INCLUDE)
- all : cflags libnasl.la nasl
-
--.c.o:
-+.c.o: cflags
- $(COMPILE) -c $<
- cflags :
- @echo "echo \"$(NESSUS_CFLAGS) $(include) $(DEFS) \"" > cflags
-@@ -101,7 +102,7 @@
- $(CC) $(CFLAGS) $(NESSUS_INCLUDE) $(include) -o nasl -DVERSION=\"$(VERSION)\" nasl.c $(OBJS) $(NESSUS_LIBS)
-
- libnasl.la : cflags $(OBJS)
-- $(COMPILE) $(NESSUS_LIBS) -o libnasl.la $(LO_OBJS) -rpath ${libdir} \
-+ $(LINK) $(NESSUS_LIBS) -o libnasl.la $(LO_OBJS) -rpath ${libdir} \
- -version-info ${PACKAGE_VERSION}
-
- install : libnasl.la nasl
diff --git a/security/nessus-libnasl/files/patch-nasl-Makefile b/security/nessus-libnasl/files/patch-nasl-Makefile
new file mode 100644
index 00000000000..6dc64a07bc8
--- /dev/null
+++ b/security/nessus-libnasl/files/patch-nasl-Makefile
@@ -0,0 +1,11 @@
+--- nasl/Makefile.orig 2005-02-10 17:03:51.000000000 +0100
++++ nasl/Makefile 2012-01-29 10:29:13.000000000 +0100
+@@ -91,7 +91,7 @@
+ COMPILE = $(LIBTOOL) $(CC) $(CFLAGS) $(NESSUS_INCLUDE)
+ all : cflags libnasl.la nasl
+
+-.c.o:
++.c.o: cflags
+ $(COMPILE) -c $<
+ cflags :
+ @echo "echo \"$(NESSUS_CFLAGS) $(include) $(DEFS) \"" > cflags
diff --git a/security/nessus-libnasl/pkg-plist b/security/nessus-libnasl/pkg-plist
index d2bbb33a170..2506dcaf0db 100644
--- a/security/nessus-libnasl/pkg-plist
+++ b/security/nessus-libnasl/pkg-plist
@@ -2,9 +2,9 @@ bin/nasl
bin/nasl-config
include/nessus/nasl.h
lib/libnasl.a
-lib/libnasl.la
lib/libnasl.so
-lib/libnasl.so.4
+lib/libnasl.so.2
+lib/libnasl.so.2.2.9
man/man1/nasl.1.gz
man/man1/nasl-config.1.gz
var/nessus/nessus_org.pem
diff --git a/security/nessus-libraries/Makefile b/security/nessus-libraries/Makefile
index 4c3d36ff89d..840070f613c 100644
--- a/security/nessus-libraries/Makefile
+++ b/security/nessus-libraries/Makefile
@@ -6,7 +6,7 @@
PORTNAME= nessus-libraries
PORTVERSION= 2.2.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ftp://ftp.nessus.org/pub/nessus/nessus-${PORTVERSION}/src/ \
ftp://ftp.gwdg.de/pub/linux/misc/nessus/nessus-${PORTVERSION}/src/ \
@@ -20,14 +20,14 @@ COMMENT= Libraries for Nessus, the security scanner
LICENSE= LGPL20
-WRKSRC= ${WRKDIR}/nessus-libraries
-USES= bison
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-cipher
.if defined(WITH_NESSUS_BPF_SHARE)
CONFIGURE_ARGS+= --enable-bpf-sharing
.endif
+USES= bison libtool
USE_LDCONFIG= YES
+WRKSRC= ${WRKDIR}/nessus-libraries
.if ! defined(NESSUS_CLIENT_ONLY)
pre-everything::
diff --git a/security/nessus-libraries/files/patch-ab b/security/nessus-libraries/files/patch-ab
deleted file mode 100644
index ca079833ef9..00000000000
--- a/security/nessus-libraries/files/patch-ab
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.orig Tue Oct 16 19:56:40 2001
-+++ configure Thu Oct 18 06:13:41 2001
-@@ -5074,7 +5074,8 @@
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-
- # Always use our own libtool.
--LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-+# LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-+LIBTOOL='libtool'
-
- # Prevent multiple expansion
-
diff --git a/security/nessus-libraries/files/patch-libtool b/security/nessus-libraries/files/patch-libtool
deleted file mode 100644
index deae3e75c3a..00000000000
--- a/security/nessus-libraries/files/patch-libtool
+++ /dev/null
@@ -1,146 +0,0 @@
---- work/nessus-libraries/libnessus/Makefile 2004-08-31 19:15:07.000000000 +0200
-+++ libnessus/Makefile 2012-01-29 10:19:13.000000000 +0100
-@@ -22,85 +22,85 @@
-
-
- getopt.o : getopt.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c getopt.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c getopt.c
-
- getopt1.o : getopt1.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c getopt1.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c getopt1.c
-
- plugutils.o : plugutils.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c plugutils.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c plugutils.c
-
- resolve.o : resolve.c resolve.h
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c resolve.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c resolve.c
-
- share_fd.o : share_fd.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c share_fd.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c share_fd.c
-
- system.o : system.c system.h
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c system.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c system.c
-
- arglists.o : arglists.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c arglists.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c arglists.c
-
- network.o : network.c network.h
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c network.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c network.c
-
- scanners_utils.o : scanners_utils.c scanners_utils.h
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c scanners_utils.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c scanners_utils.c
-
- ftp_funcs.o : ftp_funcs.c ftp_funcs.h
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ftp_funcs.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ftp_funcs.c
- www_funcs.o : www_funcs.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c www_funcs.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c www_funcs.c
-
- pcap.o : pcap.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c pcap.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c pcap.c
-
- hlst.o : hlst.c hlst.h
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c hlst.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c hlst.c
-
- ptycall.o : ptycall.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ptycall.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ptycall.c
-
- harglists.o : harglists.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c harglists.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c harglists.c
-
- diff.o : diff.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c diff.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c diff.c
-
- ids_send.o : ids_send.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ids_send.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c ids_send.c
-
- bpf_share.o: bpf_share.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c bpf_share.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c bpf_share.c
-
- rand.o: rand.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c rand.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c rand.c
-
- popen.o: popen.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c popen.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c popen.c
-
- services.o: services.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c services.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c services.c
-
- services1.o: services1.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -DCONF_DIR=\"$(sysconfdir)\" -c services1.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -DCONF_DIR=\"$(sysconfdir)\" -c services1.c
-
- proctitle.o: proctitle.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c proctitle.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c proctitle.c
-
- store.o: store.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c store.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -DNESSUS_STATE_DIR=\"$(localstatedir)\" -c store.c
-
-
- kb.o: kb.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c kb.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c kb.c
-
-
- snprintf.o : snprintf.c
-- $(LIBTOOL) $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c snprintf.c
-+ $(LIBTOOL) --mode compile $(CC) $(CIPHER) $(DEFS) $(INCLUDE) $(CFLAGS) -c snprintf.c
- libnessus.la: $(OBJS)
-- $(LIBTOOL) $(CC) -o libnessus.la $(LO_OBJS) -rpath ${libdir} \
-+ $(LIBTOOL) --mode link $(CC) -o libnessus.la $(LO_OBJS) -rpath ${libdir} \
- -version-info ${PACKAGE_VERSION}
-
- install : libnessus.la
---- work/nessus-libraries/libhosts_gatherer/Makefile 2003-04-07 04:06:49.000000000 +0200
-+++ libhosts_gatherer/Makefile 2012-01-29 10:19:27.000000000 +0100
-@@ -22,7 +22,7 @@
- $(LIBTOOL) --finish $(DESTDIR)${libdir}
-
- libhosts_gatherer.la : $(OBJS)
-- $(LIBTOOL) $(CC) -o libhosts_gatherer.la $(LO_OBJS) -rpath ${libdir} \
-+ $(LIBTOOL) --mode link $(CC) -o libhosts_gatherer.la $(LO_OBJS) -rpath ${libdir} \
- -version-info ${PACKAGE_VERSION}
-
- hg_utils.o : hg_utils.h hosts_gatherer.h hg_utils.c
---- work/nessus-libraries/libpcap-nessus/Makefile.in.orig 2004-01-08 17:12:55.000000000 +0100
-+++ libpcap-nessus/Makefile.in 2012-01-29 10:22:47.000000000 +0100
-@@ -31,7 +31,7 @@
- # You shouldn't need to edit anything below.
- #
-
--COMPILE = $(LIBTOOL) $(CC)
-+COMPILE = $(LIBTOOL) --mode compile $(CC)
- CCOPT = @V_CCOPT@
- INCLS = -I. @V_INCLS@ -I../../include
- ### Solaris make does not like += (jordan)
-@@ -89,7 +89,7 @@
-
- libpcap-nessus.la: $(OBJ)
- @rm -f $@
-- $(LIBTOOL) $(CC) -o libpcap-nessus.la $(LO_OBJ) -rpath ${libdir} \
-+ $(LIBTOOL) --mode link $(CC) -o libpcap-nessus.la $(LO_OBJ) -rpath ${libdir} \
- -version-info ${PACKAGE_VERSION}
-
- scanner.c: $(srcdir)/scanner.l
diff --git a/security/nessus-libraries/pkg-plist b/security/nessus-libraries/pkg-plist
index 2062b785069..5efe4076f67 100644
--- a/security/nessus-libraries/pkg-plist
+++ b/security/nessus-libraries/pkg-plist
@@ -7,17 +7,17 @@ include/nessus/pcap-namedb.h
include/nessus/pcap.h
include/nessus/net/bpf.h
lib/libhosts_gatherer.a
-lib/libhosts_gatherer.la
lib/libhosts_gatherer.so
-lib/libhosts_gatherer.so.4
+lib/libhosts_gatherer.so.2
+lib/libhosts_gatherer.so.2.2.9
lib/libnessus.a
-lib/libnessus.la
lib/libnessus.so
-lib/libnessus.so.4
+lib/libnessus.so.2
+lib/libnessus.so.2.2.9
lib/libpcap-nessus.a
-lib/libpcap-nessus.la
lib/libpcap-nessus.so
-lib/libpcap-nessus.so.4
+lib/libpcap-nessus.so.2
+lib/libpcap-nessus.so.2.2.9
man/man1/nessus-config.1.gz
sbin/uninstall-nessus
@dirrm include/nessus/net
diff --git a/security/nessus-plugins/Makefile b/security/nessus-plugins/Makefile
index 26cc022f88c..49f2c52b52e 100644
--- a/security/nessus-plugins/Makefile
+++ b/security/nessus-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nessus-plugins
PORTVERSION= 2.2.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ftp://ftp.nessus.org/pub/nessus/nessus-${PORTVERSION}/src/ \
ftp://ftp.gwdg.de/pub/linux/misc/nessus/nessus-${PORTVERSION}/src/ \
@@ -11,6 +11,7 @@ MASTER_SITES= ftp://ftp.nessus.org/pub/nessus/nessus-${PORTVERSION}/src/ \
ftp://sunsite.cnlab-switch.ch/mirror/nessus/nessus-${PORTVERSION}/src/ \
ftp://ftp.ayamura.org/pub/nessus/nessus-${PORTVERSION}/src/
DISTNAME= nessus-plugins-GPL-${PORTVERSION}
+DIST_SUBDIR= nessus
MAINTAINER= udo.schweigert@siemens.com
COMMENT= Plugins for Nessus, the security scanner
@@ -19,7 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/nessus/nessus-devel.h:${PORTSDIR}/security/n
RUN_DEPENDS= ${LOCALBASE}/include/nessus/nessus-devel.h:${PORTSDIR}/security/nessus \
nmap:${PORTSDIR}/security/nmap
-DIST_SUBDIR= nessus
+USES= libtool
WRKSRC= ${WRKDIR}/nessus-plugins
GNU_CONFIGURE= yes
diff --git a/security/nessus/Makefile b/security/nessus/Makefile
index 65f20831a9e..d8ea0abe307 100644
--- a/security/nessus/Makefile
+++ b/security/nessus/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nessus
PORTVERSION= 2.2.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ftp://ftp.nessus.org/pub/nessus/nessus-${PORTVERSION}/src/ \
ftp://ftp.gwdg.de/pub/linux/misc/nessus/nessus-${PORTVERSION}/src/ \
@@ -35,8 +35,8 @@ WRKSRC= ${WRKDIR}/nessus-core
post-install:
${INSTALL_DATA} ${WRKDIR}/nessusd.conf \
- ${STAGEDIR}${ETCDIR}/nessusd.conf.dist
+ ${STAGEDIR}${ETCDIR}/nessusd.conf.sample
${INSTALL_DATA} ${FILESDIR}/nessusd.rules \
- ${STAGEDIR}${ETCDIR}/nessusd.rules.dist
+ ${STAGEDIR}${ETCDIR}/nessusd.rules.sample
.include <bsd.port.mk>
diff --git a/security/nessus/pkg-plist b/security/nessus/pkg-plist
index fb6e0f732ed..694c28eb216 100644
--- a/security/nessus/pkg-plist
+++ b/security/nessus/pkg-plist
@@ -2,12 +2,8 @@ bin/nessus
bin/nessus-fetch
bin/nessus-mkcert-client
bin/nessus-mkrand
-@unexec if cmp -s %D/etc/nessus/nessusd.conf.dist %D/etc/nessus/nessusd.conf; then rm -f %D/etc/nessus/nessusd.conf 2> /dev/null; fi || true
-@unexec if cmp -s %D/etc/nessus/nessusd.rules.dist %D/etc/nessus/nessusd.rules; then rm -f %D/etc/nessus/nessusd.rules 2> /dev/null; fi || true
-etc/nessus/nessusd.conf.dist
-etc/nessus/nessusd.rules.dist
-@exec if [ ! -f %D/etc/nessus/nessusd.conf ]; then cp -p %D/etc/nessus/nessusd.conf.dist %D/etc/nessus/nessusd.conf; fi
-@exec if [ ! -f %D/etc/nessus/nessusd.rules ]; then cp -p %D/etc/nessus/nessusd.rules.dist %D/etc/nessus/nessusd.rules; fi
+@sample etc/nessus/nessusd.conf.sample
+@sample etc/nessus/nessusd.rules.sample
include/nessus/config.h
include/nessus/includes.h
include/nessus/nessus-devel.h