aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2018-09-20 21:20:08 +0800
committerdaichi <daichi@FreeBSD.org>2018-09-20 21:20:08 +0800
commitfe290f3b1d79f2addd91dd2fc92089e44e44e3bc (patch)
tree1922719b8966fcb226c945a9c0a8881fcf20cda1
parentd6a7ce528063ff899297c710a080dd49bee72847 (diff)
downloadfreebsd-ports-gnome-fe290f3b1d79f2addd91dd2fc92089e44e44e3bc.tar.gz
freebsd-ports-gnome-fe290f3b1d79f2addd91dd2fc92089e44e44e3bc.tar.zst
freebsd-ports-gnome-fe290f3b1d79f2addd91dd2fc92089e44e44e3bc.zip
Add a new port: textproc/tttcmds
Unix-style data processing commands and library Submitted by: daichi Reviewed by: jbeich, eadler Differential Revision: https://reviews.freebsd.org/D16095
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/tttcmds/Makefile28
-rw-r--r--textproc/tttcmds/distinfo3
-rw-r--r--textproc/tttcmds/pkg-descr8
-rw-r--r--textproc/tttcmds/pkg-plist115
5 files changed, 155 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6127aaa091bd..e1b1d2f22359 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1769,6 +1769,7 @@
SUBDIR += translate-toolkit
SUBDIR += ts-hunspell
SUBDIR += tth
+ SUBDIR += tttcmds
SUBDIR += turboxsl
SUBDIR += txt2html
SUBDIR += txt2man
diff --git a/textproc/tttcmds/Makefile b/textproc/tttcmds/Makefile
new file mode 100644
index 000000000000..a49babbf844a
--- /dev/null
+++ b/textproc/tttcmds/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= tttcmds
+PORTVERSION= 1.0.20180920
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc
+
+MAINTAINER= daichi@FreeBSD.org
+COMMENT= Unix-style data processing commands and library
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64
+
+CONFLICTS_INSTALL= open-usp-tukubai
+
+USE_GITHUB= yes
+GH_ACCOUNT= daichigoto
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/tttcmds/distinfo b/textproc/tttcmds/distinfo
new file mode 100644
index 000000000000..d6fc86f1d6a9
--- /dev/null
+++ b/textproc/tttcmds/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1537448857
+SHA256 (daichigoto-tttcmds-v1.0.20180920_GH0.tar.gz) = 0b80034f04e198aad8747485a9c67d37d74de9e102ad1ddba52fee4e6d5b3d89
+SIZE (daichigoto-tttcmds-v1.0.20180920_GH0.tar.gz) = 1584182
diff --git a/textproc/tttcmds/pkg-descr b/textproc/tttcmds/pkg-descr
new file mode 100644
index 000000000000..561db08572f2
--- /dev/null
+++ b/textproc/tttcmds/pkg-descr
@@ -0,0 +1,8 @@
+TTT COMMANDS is a development commands set to build information
+system that could handle large datasets rapidly and flexibly.
+This gives you a way lit power to build a fast process system
+without some kind of databases. You would build the data process
+system using only TTT COMMANDS, Unix-style basic commands and
+text datasets on your own favorite operating systems.
+
+WWW: https://github.com/daichigoto/tttcmds
diff --git a/textproc/tttcmds/pkg-plist b/textproc/tttcmds/pkg-plist
new file mode 100644
index 000000000000..8e9e8eba8f0c
--- /dev/null
+++ b/textproc/tttcmds/pkg-plist
@@ -0,0 +1,115 @@
+bin/append
+bin/assign
+bin/assign_htmlcheckbox
+bin/assign_htmlinput
+bin/assign_htmlselect
+bin/assign_htmltextarea
+bin/calc_subtract_date
+bin/col_append
+bin/col_assign
+bin/col_assign_htmlcheckbox
+bin/col_assign_htmlinput
+bin/col_assign_htmlselect
+bin/col_assign_htmltextarea
+bin/col_count
+bin/col_delete
+bin/col_diff
+bin/col_leavefirst
+bin/col_leavelast
+bin/col_select
+bin/col_select_max
+bin/col_select_min
+bin/conv_form2ssv
+bin/conv_ssv2ssv
+bin/conv_ssv2transposedssv
+bin/conv_ssv2tsv
+bin/conv_ssv2txt
+bin/conv_ssvstr2str
+bin/conv_str2ssvstr
+bin/conv_tag2ssv
+bin/conv_tsv2ssv
+bin/datefmt
+bin/dateformat
+bin/embed_ssv1txt
+bin/embed_txt1txt
+bin/embed_value1txt
+bin/form2ssv
+bin/gyo
+bin/gyo_count
+bin/gyo_delete
+bin/gyo_select
+bin/gyodel
+bin/gyosel
+bin/innerjoin
+bin/join_innerjoin
+bin/join_leftouterjoin
+bin/join_outerjoin
+bin/join_rightouterjoin
+bin/leavefirst
+bin/leavelast
+bin/leftjoin
+bin/millisec
+bin/numfmt
+bin/numformat
+bin/ongs_awk
+bin/outerjoin
+bin/owk
+bin/retu
+bin/retu_append
+bin/retu_assign
+bin/retu_assign_htmlcheckbox
+bin/retu_assign_htmlinput
+bin/retu_assign_htmlselect
+bin/retu_assign_htmltextarea
+bin/retu_count
+bin/retu_dateformat
+bin/retu_delete
+bin/retu_diff
+bin/retu_leavefirst
+bin/retu_leavelast
+bin/retu_numformat
+bin/retu_select
+bin/retu_select_max
+bin/retu_select_min
+bin/retu_strformat
+bin/retudel
+bin/retudiff
+bin/retusel
+bin/retusel_max
+bin/retusel_min
+bin/rightjoin
+bin/row_count
+bin/row_delete
+bin/row_select
+bin/seq_date
+bin/ssv1txt
+bin/ssv2ssv
+bin/ssv2tsv
+bin/ssv2txt
+bin/ssvstr2str
+bin/str2ssvstr
+bin/strfmt
+bin/strformat
+bin/subtract_date
+bin/tag2ssv
+bin/template
+bin/template_cmdargs
+bin/template_conv
+bin/template_gyo
+bin/template_retu
+bin/transpose
+bin/tsv2ssv
+bin/txt1txt
+bin/util_millisecond
+bin/val1txt
+bin/wait_filechanges
+include/ttt_aliases.h
+include/ttt_debug.h
+include/ttt_text.h
+include/ttt_utils.h
+include/ttt.h
+lib/libttt.a
+lib/libttt.so
+lib/libttt.so.0
+lib/libttt.so.0.0.0
+%%PORTDOCS%%%%DOCSDIR%%/README.md