aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-22 02:03:09 +0800
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-22 02:26:14 +0800
commitbabd083d9cc5e98df03cf1c548eb4b2a4bb40448 (patch)
tree502b35452c89272d41ffaee7790c0ce6e88039d6
parentfbd4ab08f01657e04697397f98ce457bab755c28 (diff)
downloadfreebsd-ports-babd083d9cc5e98df03cf1c548eb4b2a4bb40448.tar.gz
freebsd-ports-babd083d9cc5e98df03cf1c548eb4b2a4bb40448.tar.zst
freebsd-ports-babd083d9cc5e98df03cf1c548eb4b2a4bb40448.zip
news/pan: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--news/pan/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index ca8e23467b0c..e178a4a974e7 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -21,27 +21,29 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
USES= compiler:c++11-lang desktop-file-utils gettext-tools:build \
gmake gnome iconv localbase pathfix pkgconfig tar:bzip2
+USE_CXXSTD= c++14
USE_GNOME= cairo gdkpixbuf2 intlhack
+
GNU_CONFIGURE= yes
+
LDFLAGS+= ${ICONV_LIB}
+
OPTIONS_DEFINE= GTKSPELL GNUTLS NLS
OPTIONS_DEFAULT= GTKSPELL GNUTLS GTK2
OPTIONS_RADIO= GTK
OPTIONS_RADIO_GTK= GTK2 GTK3
OPTIONS_SUB= yes
+
GTKSPELL_DESC= Spell checking support (gtk+2 only)
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_CONFIGURE_WITH= gnutls
-
-GTK3_CONFIGURE_WITH= gtk3
-GTK3_USE= gnome=gtk30
GTK2_USE= gnome=gtk20
-
+GTK3_PREVENTS= GTKSPELL
+GTK3_USE= gnome=gtk30
+GTK3_CONFIGURE_WITH= gtk3
GTKSPELL_LIB_DEPENDS= libgtkspell.so:textproc/gtkspell
GTKSPELL_CONFIGURE_WITH=gtkspell
-GTK3_PREVENTS= GTKSPELL
-
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls