summaryrefslogtreecommitdiffstats
path: root/guix/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2014-11-18 21:11:01 +0800
committerTing-Wei Lan <lantw44@gmail.com>2014-11-18 21:14:15 +0800
commit42e2e9ce0012174562d8bcb40c3b850cde5919cd (patch)
treebb9996543c27c4a4dfdefbec832997e0eab284cf /guix/PKGBUILD
parent78009d3feb7c594398c78478eaa31b257798c189 (diff)
downloadAUR-PKGBUILD-42e2e9ce0012174562d8bcb40c3b850cde5919cd.tar.gz
AUR-PKGBUILD-42e2e9ce0012174562d8bcb40c3b850cde5919cd.tar.zst
AUR-PKGBUILD-42e2e9ce0012174562d8bcb40c3b850cde5919cd.zip
guix: 0.7 -> 0.8
Diffstat (limited to 'guix/PKGBUILD')
-rw-r--r--guix/PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/guix/PKGBUILD b/guix/PKGBUILD
index 233bc31..1da6f5c 100644
--- a/guix/PKGBUILD
+++ b/guix/PKGBUILD
@@ -2,32 +2,31 @@
# Modified from guix-git 20130119 PKGBUILD
pkgname=guix
-pkgver=0.7
+pkgver=0.8
pkgrel=1
pkgdesc="GNU guix is a purely functional package manager"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
license=('GPL')
depends=('guile>=2.0.5' 'sqlite>=3.6.19' 'bzip2' 'libgcrypt')
-makedepends=()
+optdepends=('emacs: to enable Emacs Interface')
source=(
"ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"
"guix.service")
md5sums=(
-'c9d174a27fc55889c1f1b005875120ae'
+'415f2a915db749ee28c3991032ab240a'
'4e088207919bdefff13a9d452f79467b')
build() {
current_arch="`uname -m`"
cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --localstatedir=/var \
- --disable-rpath --with-system=${current_arch}-linux
+ ./configure --prefix=/usr --localstatedir=/var --disable-rpath
make
}
check() {
cd ${srcdir}/${pkgname}-${pkgver}
- make -k -j1 check
+ make check
}
package() {