aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sol-cov
diff options
context:
space:
mode:
authorLeonid Logvinov <logvinov.leon@gmail.com>2018-06-12 09:01:33 +0800
committerLeonid Logvinov <logvinov.leon@gmail.com>2018-06-12 09:01:33 +0800
commit94398d70f4511419f77bd17b25d0060eba08c4dc (patch)
treee11f02c0858142b8db9e2840d614636fa996a2e7 /packages/sol-cov
parentf4a61b4c70b18cd4eef70eafc79e14b8c0161df3 (diff)
downloaddexon-0x-contracts-94398d70f4511419f77bd17b25d0060eba08c4dc.tar.gz
dexon-0x-contracts-94398d70f4511419f77bd17b25d0060eba08c4dc.tar.zst
dexon-0x-contracts-94398d70f4511419f77bd17b25d0060eba08c4dc.zip
Speed-up sol-cov
Diffstat (limited to 'packages/sol-cov')
-rw-r--r--packages/sol-cov/src/trace_collection_subprovider.ts4
1 files changed, 2 insertions, 2 deletions
diff --git a/packages/sol-cov/src/trace_collection_subprovider.ts b/packages/sol-cov/src/trace_collection_subprovider.ts
index 7500e5bd3..ba9f03897 100644
--- a/packages/sol-cov/src/trace_collection_subprovider.ts
+++ b/packages/sol-cov/src/trace_collection_subprovider.ts
@@ -163,7 +163,7 @@ export class TraceCollectionSubprovider extends Subprovider {
cb();
}
private async _recordTxTraceAsync(address: string, data: string | undefined, txHash: string): Promise<void> {
- await this._web3Wrapper.awaitTransactionMinedAsync(txHash);
+ await this._web3Wrapper.awaitTransactionMinedAsync(txHash, 0);
const trace = await this._web3Wrapper.getTransactionTraceAsync(txHash, {
disableMemory: true,
disableStack: false,
@@ -222,7 +222,7 @@ export class TraceCollectionSubprovider extends Subprovider {
};
try {
const txHash = await this._web3Wrapper.sendTransactionAsync(fakeTxData);
- await this._web3Wrapper.awaitTransactionMinedAsync(txHash);
+ await this._web3Wrapper.awaitTransactionMinedAsync(txHash, 0);
} catch (err) {
// Even if this transaction failed - we've already recorded it's trace.
_.noop();
lass='insertions'>+4 * - Update to 20071025miwi2007-10-262-4/+4 * - Update to 20071017miwi2007-10-232-4/+4 * - Update to 20071015miwi2007-10-172-7/+5 * Pass maintainership to Philippe Audeoud <jadawin@tuxaco.net>, who hasmux2007-10-091-2/+2 * Update to the latest version from NetBSD's CVS repository.mux2007-10-052-4/+4 * Remove the now superfluous USE_REINPLACE=yes.mux2006-01-221-1/+0 * Join the ambient paranoia and add an SHA256 checksum.mux2005-11-131-0/+1 * Update to the latest version of NetBSD's wtf.mux2005-11-052-3/+3 * - Update to latest acronyms database from NetBSD.mux2005-05-063-7/+6 * Add size data into distinfo.mux2004-03-181-0/+1 * Simplify the Makefile a bit by using ${REINPLACE_CMD}.mux2004-01-251-6/+2 * - Update to the latest version as found in NetBSD. This adds a fairmux2004-01-253-4/+6 * Clear moonlight beckons.ade2003-03-072-1/+1 * o Sync with NetBSD's latest versionmux2002-10-062-3/+3 * This port actually doesn't need perl, so remove USE_PERL5=yes.mux2002-04-271-1/+0 * Update MASTER_SITES and my maintainer email address.mux2002-03-211-2/+2 * - update to 20020210petef2002-02-25ns'>+1 * Bump the PORTREVISION for the ports directly affected by the gettext upgrade.marcus2003-08-271-0/+1 * Chase the libintl.so shared lib version.marcus2003-08-251-1/+1 * update misc/kcd: 6.4.2 -> 7.0.0daichi2003-07-112-2/+2 * Update to version 6.4.2naddy2003-04-242-2/+2 * De-pkg-comment.knu2003-02-212-1/+1 * upgrade to 6.4.1ijliao2002-11-204-4/+38 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-112-2/+1 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-072-1/+2 * fix buildijliao2002-10-221-4/+4 * BROKEN: Does not compilekris2002-10-061-0/+2 * Chase shlib rev of devel/gettextade2002-08-021-1/+1