aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2016-01-10 21:44:01 +0800
committermiwi <miwi@FreeBSD.org>2016-01-10 21:44:01 +0800
commit0020c93df2abb92a69eaf82126aa082b08eaa957 (patch)
treeb8447521c5429bde9c0f3b26224fff14d68df28c
parentb39a42b0244d5aa471cbeda2982f4456fb7b62b1 (diff)
downloadfreebsd-ports-gnome-0020c93df2abb92a69eaf82126aa082b08eaa957.tar.gz
freebsd-ports-gnome-0020c93df2abb92a69eaf82126aa082b08eaa957.tar.zst
freebsd-ports-gnome-0020c93df2abb92a69eaf82126aa082b08eaa957.zip
PyCryptodome is a fork of PyCrypto. It brings the following
enhancements with respect to the last official version of PyCrypto (2.6.1): * Authenticated encryption modes (GCM, CCM, EAX, SIV, OCB) * Accelerated AES on Intel platforms via AES-NI * First class support for PyPy * SHA-3 (including SHAKE XOFs) and BLAKE2 hash algorithms * Salsa20 and ChaCha20 stream ciphers * scrypt and HKDF * Deterministic DSA * Password-protected PKCS#8 key containers * Shamir's Secret Sharing scheme * Random numbers get sourced directly from the OS (and not from a CSPRNG in userspace) * Simplified install process, including better support for Windows * Cleaner RSA and DSA key generation (largely based on FIPS 186-4) * Major clean ups and simplification of the code base WWW: https://pypi.python.org/pypi/pycryptodome/ PR: 206095 Submitted by: Yuri Victorovich <yuri@rawbw.com>
-rw-r--r--security/Makefile1
-rw-r--r--security/py-pycryptodome/Makefile27
-rw-r--r--security/py-pycryptodome/distinfo2
-rw-r--r--security/py-pycryptodome/pkg-descr20
4 files changed, 50 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 55c99b1908b9..18c2718b9917 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -850,6 +850,7 @@
SUBDIR += py-pyaff4
SUBDIR += py-pyclamd
SUBDIR += py-pycrypto
+ SUBDIR += py-pycryptodome
SUBDIR += py-pycryptopp
SUBDIR += py-pydeep
SUBDIR += py-pyelliptic
diff --git a/security/py-pycryptodome/Makefile b/security/py-pycryptodome/Makefile
new file mode 100644
index 000000000000..62c96b3b6d9c
--- /dev/null
+++ b/security/py-pycryptodome/Makefile
@@ -0,0 +1,27 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pycryptodome
+PORTVERSION= 3.3.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Cryptographic library for Python
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/Crypto/Cipher/*.so
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/Crypto/Hash/*.so
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/Crypto/Util/*.so
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/security/py-pycryptodome/distinfo b/security/py-pycryptodome/distinfo
new file mode 100644
index 000000000000..34c1d86c84db
--- /dev/null
+++ b/security/py-pycryptodome/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pycryptodome-3.3.1.tar.gz) = 1b52d5643e243a6d5ba4b5706e6ae59ee61b14e800ff812c1e47ec4dfe8e4761
+SIZE (pycryptodome-3.3.1.tar.gz) = 3050117
diff --git a/security/py-pycryptodome/pkg-descr b/security/py-pycryptodome/pkg-descr
new file mode 100644
index 000000000000..9db170b53a61
--- /dev/null
+++ b/security/py-pycryptodome/pkg-descr
@@ -0,0 +1,20 @@
+PyCryptodome is a fork of PyCrypto. It brings the following
+enhancements with respect to the last official version of
+PyCrypto (2.6.1):
+
+* Authenticated encryption modes (GCM, CCM, EAX, SIV, OCB)
+* Accelerated AES on Intel platforms via AES-NI
+* First class support for PyPy
+* SHA-3 (including SHAKE XOFs) and BLAKE2 hash algorithms
+* Salsa20 and ChaCha20 stream ciphers
+* scrypt and HKDF
+* Deterministic DSA
+* Password-protected PKCS#8 key containers
+* Shamir's Secret Sharing scheme
+* Random numbers get sourced directly from the OS (and not from
+ a CSPRNG in userspace)
+* Simplified install process, including better support for Windows
+* Cleaner RSA and DSA key generation (largely based on FIPS 186-4)
+* Major clean ups and simplification of the code base
+
+WWW: https://pypi.python.org/pypi/pycryptodome/